Multihomed Windows 2003 DC server - prevent DNS registration of one network card

Discussion in 'Windows Networking' started by Håkan, Oct 15, 2007.

  1. Håkan

    Håkan Guest

    I have a multi-homed 2003 Server running as a Domain Controller. I want the
    IP address on one of the network cards not to register it self with the DNS
    server. I have unchecked the "register this connection's addresses in DNS"
    check box on the DNS tab for the IP configuration for this network card.
    Still the IP address keep showing up in the DNS server.

    I have tried to delete the record manually with no success as the address
    reappears at next reboot.

    Anyone has any clue what makes the server register the address even though I
    told it not to?


    /Håkan
     
    Håkan, Oct 15, 2007
    #1
    1. Advertisements

  2. Note that this is rarely a good idea and can cause all kinds of problems
    with DNS, and other things. Depending on your reasons for using this config,
    you may be better off with a router or VLAN configuration.
    Try posting an *unedited* ipconfig /all from this server.
     
    Lanwench [MVP - Exchange], Oct 15, 2007
    #2
    1. Advertisements

  3. Håkan

    Håkan Guest

    Why is this rarely a good idea? Microsoft even made a compleate product
    around the concept of a DC with two network cards (Small Business Server)??

    Anyway, I want help with the question I have....I don't want and
    recomendations on a solution or anything like that. Because if I can't get
    the network card not to registrate it self with the DNS I will have to
    figure out a compleatly different solution...like uninstalling the domain
    and running without a domain.


    So the question again:
    How do i prevent the DC from rerigtrating one of the network cards IP
    Address with the DNS server?
    (I have unchecked the "register this connection's addresses in DNS" check
    box on the DNS tab for the IP configuration for this network card. Still the
    IP address keep showing up in the DNS server.)



    C:\>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : pripps
    Primary Dns Suffix . . . . . . . : Snurre.local
    Node Type . . . . . . . . . . . . : Unknown
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : Snurre.local


    Ethernet adapter VMware Network Adapter VMnet1:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : VMware Virtual Ethernet Adapter for
    VMnet1
    Physical Address. . . . . . . . . : 00-50-56-C0-00-01
    DHCP Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 192.168.11.101
    Subnet Mask . . . . . . . . . . . : 255.255.255.0
    Default Gateway . . . . . . . . . :


    Ethernet adapter Internet:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom BCM5708C NetXtreme II GigE
    (NDIS VBD Client)
    Physical Address. . . . . . . . . : 00-1D-09-01-75-EE
    DHCP Enabled. . . . . . . . . . . : No
    IP Address. . . . . . . . . . . . : 194.238.76.244
    Subnet Mask . . . . . . . . . . . : 255.255.255.240
    Default Gateway . . . . . . . . . : 194.238.76.241


    Ethernet adapter Snurre.local:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Broadcom BCM5708C NetXtreme II GigE
    (NDIS VBD Client) #2
    Physical Address. . . . . . . . . : 00-1D-09-01-75-F0
    DHCP Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Autoconfiguration IP Address. . . : 169.254.54.204
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :

    Thanks
    /Håkan

    "Lanwench [MVP - Exchange]"
     
    Håkan, Oct 15, 2007
    #3
  4. That is SBS, not yours. MS designed SBS to be that way,...regular DCs are
    not.
    So you are saying, "Don't tell me the truth",...and "Don't give me the
    correct advice"?
    So instead of doing it the correct way,...you just eliminate the Domain?
    In addition to unchecking the "register this connection's addresses in DNS",
    you also need to make sure that the TCP/IP Specs of that particular Nic have
    a Blank DNS entry. The other Nic should have the DNS entry.

    Then delete the rouge entry from.

    The Broadcom BCM5708C is set to use DHCP, but there is no DHCP Server
    providing an address for it, hence the 169.254.*.* address. Leave the nic
    unpluged and disabled.
     
    Phillip Windell, Oct 15, 2007
    #4
  5. Håkan

    Håkan Guest

    The whole concept of these newsgroups are to help other users...by answering
    their questions. I think it is a bit arrogant to tell the people they ask
    the wrong question, especially when you don't have all the info on the
    subect.

    Youy say: ""Don't tell me the truth",...and "Don't give me the correct
    advice"?" with that statement you are implying that I have the wrong
    solution...which you impossibly could know, since you know only a small
    portion of the parameters that i have to take into account when designing
    the network.

    My suggestion to you is to not answer any more questions unless you really
    want to help the user asking the question.

    /Håkan



     
    Håkan, Oct 15, 2007
    #5
  6. I did give you advice if you would have continued to read the rest of the
    post.
    It is also arrogant to think that your question could not be wrong in its
    premise and that you could not possibly be following a bad design from the
    beginnning which would be the "root" cause of your problem.

    It is also arrogant to complain that someone doesn't have all the
    information about your network, when you are the one that was supposed to
    give the relevant information to them so their analysis could be more
    accurate.

    So, yes, your post made me mad, which was obvious.

    --
    Phillip Windell
    www.wandtv.com

    The views expressed, are my own and not those of my employer, or Microsoft,
    or anyone else associated with me, including my cats.
    -----------------------------------------------------
     
    Phillip Windell, Oct 15, 2007
    #6
  7. SBS is its own beast. Even in SBS, it's a bad configuration. I don't use two
    NICs in any of my SBS installs. That said, as Phil Windell pointed out, you
    are not *using* SBS, so this is irrelevant.
    Well, if you will read my reply to you very carefully, you will see that in
    addition to my *politely* suggesting that this is a bad configuration, I
    *also* asked you a valid question about your ipconfig details ....this
    should have made it clear I intended to try and help you with your specific
    question.

    At this point, I must say that the tone of your reply to me, as well as that
    of your replies to Phil, makes me uninclined to continue trying to help you.
    If this is the case, perhaps you shouldn't ask for free tech support from
    complete strangers who are kindly volunteering their time to help others in
    a public newsgroup....caveat emptor. You can call Microsoft product support
    services and they will give you dedicated one-on-one support for a flat
    rate...currently $135/USD, I believe.
    Well, that may take care of the symptom, but then, so would disconnecting
    the power supply. It's a bit drastic.

    <snip>

    Good luck out there.
     
    Lanwench [MVP - Exchange], Oct 15, 2007
    #7
  8. Håkan

    Håkan Guest

    Obviously you are both americans, which explains your lack of logic in
    realising that when somewone asks Question A they don't want answer to
    Question B. Or that the their realty is wrong and they should start using
    your reality instead. I hope you didn't use the same strategy in the war,
    it would lead to a dissaster...ops, you did...and now the whole world hates
    you.....strange...isn't it?

    /H


    "Lanwench [MVP - Exchange]"
     
    Håkan, Oct 15, 2007
    #8
  9. Actually I am English/Irish/French, and she, If I'm not mistaken, she is
    French. We just live in America.
    .....resulting in us being more technologically advanced than a large part of
    the world over the years. We know a bad idea when we see it and look for a
    better way.
    A war that we won in record time. The war itself is over.
    It's those in the aftermath (who aren't Americans BTW) that don't have
    enough brains to stop shooting each other and everyone else around them that
    keeps the problems going.
    If they stopped,...we'd leave. Then they could run the place however they
    want.
    I guess you could always shoot that extra Nic with a AK47 and it would
    probably stop registering in DNS.

    Those that hate us do so because their governments and their "religious"
    leaders tell them to hate us and fill thier minds with propaganda. The rest
    hate us because we are more successful as a country and people want to hate
    everyone who is more successful than they are themselves,...it's called
    Class Envy and jealousy, and it grows like weeds everywhere you water it.

    --
    Phillip Windell
    www.wandtv.com

    The views expressed, are my own and not those of my employer, or Microsoft,
    or anyone else associated with me, including my cats.
    -----------------------------------------------------
     
    Phillip Windell, Oct 15, 2007
    #9
  10. Why, how terribly charming and diplomatic of you to make wild, random
    assumptions
    such as that about my politics, not to mention my grasp of logic and
    technology.

    <plonk>
     
    Lanwench [MVP - Exchange], Oct 15, 2007
    #10
  11. Håkan

    Håkan Guest

    Or you just don't get IT....ever thought about that? Proboboly not since you
    are always right...and why bather to to do what somewone else wants when you
    can do what you want instead.....who cares if it is helpfull to the other
    guy or not...as long as I have my freedom to do what I want the other guy
    have to stand down...he is wrong anyway...and probobly a looser, so who
    cares?


    Now I am tired of your narrow minded world, your eager to do things "your
    way" and your lack of empathy for others. You are obviously one of the
    religious fanatics with no care for anyone but your self and only want to
    impose your world on others.

    /H
     
    Håkan, Oct 15, 2007
    #11
  12. Håkan

    Bill Grant Guest

    "Lanwench [MVP - Exchange]"
    Hakan, I can assure you that I am an Australian of Irish/Scottish descent
    and would give you much the same advice. If you persist with using an
    unsupported configuration and don't supply any details of your setup, you
    are on your own.

    KB292822 will give you an outline of the sorts of problems multihomed
    DCs present. It refers to problems with remote access but the problems are
    much the same no matter how the multihoming comes about. The basic problem
    is the fact that the machine name is associated with more than one IP
    address, whether that name is a DNS or Netbios name.
     
    Bill Grant, Oct 16, 2007
    #12
  13. Håkan

    Håkan Guest

    I know this, it has been there same problem since windows NT 3.5.

    But my question is not regarding this. It is about stopping a network card
    from registering it's IP addresses with the DNS server. I don't have any
    problems with anything else. If I can get the network card to stop
    registrating it's address I have no problems at all. The fact that I
    uncheck the register checkbox and the nic still registers it's addresses is
    my problem, nothing else.

    /H

     
    Håkan, Oct 16, 2007
    #13
  14. Håkan

    Bill Grant Guest

    It may not be the card at all. DHCP can do it,or some other machine can
    act as a proxy.

     
    Bill Grant, Oct 16, 2007
    #14
  15. Håkan

    Håkan Guest

    Microsft has already confirmed this to be a problem in Windows 2003 which is
    suposed to be soleved in SP1...still i get the problem. The reason it gets
    into the DNS is most likely because Netlogon puts it the.

    Anyway this is obviously a matter to complicated for the newsgroup to
    handel.

    /H


     
    Håkan, Oct 16, 2007
    #15
  16. Håkan

    heapteach Guest

    Håkan,

    Try this on the second interface that you do not want register it’s IP
    in DNS
    1. Uncheck Register this connection's Address in DNS
    2. Disable NetBIOS over TCP/IP

    This should stop the second interface from registering in your DNS.

    Cheers,

    Cody
     
    heapteach, Nov 12, 2007
    #16
  17. Håkan

    trucker Guest

    trucker, May 29, 2008
    #17
  18. Håkan

    dennyd Guest

    Are you using DHCP to obtain the address? If that is the case, DHCP wil
    register it for you
     
    dennyd, Jun 8, 2008
    #18
  19. Håkan

    Cornelis na Guest

    you want to go to the DNS manager, right click on the server, properties and select "listen on" "only the following Ip addresses". Delete the ones you don't want
     
    Cornelis na, Dec 27, 2010
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.