mppe Fedora Core 1 mppe not supported

Discussion in 'Linux Networking' started by stephen, Aug 31, 2004.

  1. stephen

    stephen Guest

    I have followed the instructions at
    http://pptpclient.sourceforge.net/howto-fedora.phtml

    I get a 'kernel does not support mppe' message. I am confused: all the
    rpms in steps b+ install without complaint. I use rpm -iv and it looks
    like a clean install. But obviously something is wrong.

    I have the source for my kernel /usr/src/linux-2.4.22-1.2199.nptl/kernel
    and I have gcc and cpp 3.2.2 so I skipped the instructions in 1a thinking
    I was up to date.

    Something is wrong though:

    The instructions say kernel-source-2.4.22-1.2115.nptl.i386.rpm - which is
    not the source for my kernel - so I think probably the docs aren't quite
    up to date? Shouldn't I be using the source for my kernel?

    Also I had to use modprobe ppp_mppe. The instructions say modprobe
    ppp-compress-18, but that didn't work for me even though my modules.conf
    sets alias ppp-compress-18 mppe.

    I have rebooted. I am running pptpconfig as root.

    The mppe kernel does not show up on my grub menu, though. Should it?
     
    stephen, Aug 31, 2004
    #1
    1. Advertisements

  2. I don't know how you could boot to it otherwise. Apparently the Grub
    menu wasn't configured to include it as a kernel choice.
     
    Clifford Kite, Aug 31, 2004
    #2
    1. Advertisements

  3. stephen

    stephen Guest

    Ok this morning I booted up again, did modprobe mppe and received a
    warning about 'taint the kernel', but I have read to ignore that so I ran
    pptpconfig and easily got a connection to my employers vpn.

    After work today I booted up again - I'm working on a laptop so I don't
    leave it running all the time - and modprobe can not find mppe or
    ppp-compress-18!

    Although rpm insists that kernel-mppe-2.4.22-1.2199.nptl is installed,
    whereis can not find mppe anywhere.

    What's going on? The machine was off all day.

    This is very perplexing.

    Here is my modules.conf
    alias eth0 8139too
    alias usb-controller usb-uhci
    alias sound-slot-0 i810_audio
    alias ppp-compress-18 mppe
    post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L
    /etc/.aumixrc -S >/dev/null 2>&1 || :
     
    stephen, Sep 1, 2004
    #3
  4. If the kernel supports MPPE then it isn't a standard kernel. That is,
    it's modified, presumably by whomever distributes "Fedora Core 1."

    A "modprobe -c" here, from module-init-tools version 3.0 (modprobe -V),
    shows ppp_mppe is the module for a kernel that knows it by the name
    ppp-compress-18, but I can find no MPPE configuration implemented in
    the standard 2.4.26 (or even 2.6.7) kernel source.
    That certainly is bad behavior on the part of something, but I don't
    know what.
    Do "uname -r" to find the version of the running kernel. Whereis only
    searches for certain types of file in certain places. It's likely that
    it doesn't look for a kernel module. Try "locate mppe" .
    Beats me. But it sounds like you might be booting to different kernels.
    Indeed. Only someone who has had a similar experience with Fedora is
    likely to *know* what causes the problem.
    I've never seen anything like the last 3 lines (or one wrapped)
    in modules.conf, which is not to say that they are not meaningful -
    according to "man modules.conf" there _is_ a "post-install module
    command ..." directive for modules.conf.

    It may help to know that all kernel modules should_ be in subdirectories
    of /lib/modules/`uname -r`/ . Also "lsmod" shows the inserted modules.
     
    Clifford Kite, Sep 1, 2004
    #4
  5. stephen

    stephen Guest

    Poking around I saw it looked like mppe was in the kernel - not in
    the modules! So on a hunch, I removed from modules.conf :

    alias ppp-compress-18 mppe

    This seems to have solved the problem. I don't need modprobe at all.
    Perhaps the instructions are out of date for the mppe kernel version? Or
    perhaps I'm just too dangerous to be poking around at this level.

    Thanks.
     
    stephen, Sep 1, 2004
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.