mount.cifs - Can someone give me a working example please?

Discussion in 'Linux Networking' started by Ohmster, Oct 21, 2006.

  1. Ohmster

    Ohmster Guest

    I want to mount some of my XP shares on my Fedora Core 5 box on my home
    LAN
    and used to be able to do this with "mount -t smbfs..." and now that does
    not work anymore. I see that cifs is used instead but I am having a very
    hard time getting that to work. My old syntax does not work anymore and I
    am not sure of the currently required syntax on how to do this.
    Previously,
    this worked:

    mount -t smbfs //missy/MY_vids_01 /mnt/MY_vid_01 -o
    username=myuser,password=mypassword,rw

    (missy is in my /etc/hosts file as 192.168.0.3)

    This does not work anymore, nor does it work by substituting cifs for
    smbfs.

    Not even mount.cifs works, I get error after error, no matter what I try.
    I
    thought that for sure this would work but it does not...

    [[email protected] mnt]# mount.cifs -t cifs //192.168.0.3/MY_vids_01
    /mnt/MY_vid_01 -o username=user,password=pass,rw

    Mounting the DFS root for domain not implemented yet
    No ip address specified and hostname not found
    [[email protected] mnt]#

    I tried again with a credential file:

    [[email protected] mnt]# mount -t cifs //missy/MY_Vids_01 /mnt/MY_vid_01/ -o
    rw,credentials=/home/ohmster/scripts/cifsauth
    mount error 12 = Cannot allocate memory
    Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
    [[email protected] mnt]#

    I don't quite understand this memory thing. I googled for it and came up
    with this from some kind of Xen page:

    Error: Error creating domain: (12, ' Cannot allocate memory')

    * Versions: 2.0
    * Occurs when: trying to start domain
    * Probable cause
    o allocated memory for "dom0 + running domUs + domU that you
    are trying to start" exceeds physical memory
    * Solution
    o Reduce the amount of memory required for the new domU, or
    balloon down the memory of the running domUs

    What does that mean? I am not trying to run any kind of a domain server,
    I only want to mount a Windows share with a workgroup name, user name,
    and user password.

    Does mount -t cifs or mount.cifs actually work at all and could someone
    please give me an example that would work for my setup?

    Worgroup=workgroup
    User=user
    Password=pass
    XP Machine=192.168.0.3
    FC5 Machine=192.168.0.1

    I am pulling my hair out with this, can somebody please supply a working
    example? Thanks.
     
    Ohmster, Oct 21, 2006
    #1
    1. Advertisements

  2. Ohmster

    kurt Guest

    mount -t cifs //missy/MY_vids_01 /mnt/MY_vid_01 -o
    username=myuser,password=mypassword


    ....kurt
     
    kurt, Oct 24, 2006
    #2
    1. Advertisements

  3. Ohmster

    Ohmster Guest

    Kurt,

    I had an error that resulted in me not being able to mount the share:
    mount error 12 = Cannot allocate memory

    And of course, the share would fail to mount. I have since solved this
    problem and will make a new post, giving the solution for anyone that needs
    it. I for sure could not find anything for this on the net so maybe this
    will help someone else.

    Thanks for your reply, Kurt.
     
    Ohmster, Oct 24, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.