Linux NFS client to Solaris 8 NFS Server

Discussion in 'Linux Networking' started by uberlinuxguy, Oct 16, 2007.

  1. uberlinuxguy

    uberlinuxguy Guest

    The problem I am seeing is that when I transfer large-ish files (files
    over ~40MB) from the Solaris NFS Server to the Linux NFS server, the
    Solaris machine begins to stop responding on the network properly.
    CPU load is not spiking, but ping times creep up almost exponentially
    the more connections from the Linux NFS client.

    The Linux machine is a Pentium 4 running Fedora Core 6.
    The Solaris machine is a Ultra Sparc 10 running Solaris 8.

    Both machines are on a 100Mbps network.
    The interesting part of this is that if I go from Solaris to Solaris,
    there is little to no effect on the network throughput on the Solaris
    NFS server. It seems that Linux NFS has some hidden overhead that I
    cannot compensate for. I've tried forcing NFS Version 2, I've tried
    various different settings for the rsize and wsize options in Linux,
    but nothing can get me to a satisfactory result.

    Has anyone else seen this? Does anyone know of anything that I might
    be missing?
     
    uberlinuxguy, Oct 16, 2007
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.