Linux host PC(ipv6) can't ping with embedded board(ipv6) with ping6

Discussion in 'Linux Networking' started by sangsu, Oct 10, 2005.

  1. sangsu

    sangsu Guest

    Hi, all

    I have a problem about ping with ipv6.
    I want to ping between the host PC(ipv6) and the embedded board(ipv6).

    The host PC is 2.4.26 kernel, vmware machine.
    The embedded board is 2.4.18-rmk7-pxa1-xhyper255 kernel, Xscale board.

    When the embedded board ping to the host PC, ping worked well.
    But when the host PC ping to the embedded board, ping didn't work well.
    The host PC sent a icmp packet(solicitation) to the embedded board, but
    the embedded board didn't send a icmp packet(advertisement).

    I don't know what is worng.
    please advise me.
     
    sangsu, Oct 10, 2005
    #1
    1. Advertisements

  2. sangsu

    Bill Marcum Guest

    Does the embedded machine lack ipv4? Can you ping with ipv4? That would
    seem to rule out a hardware problem. Try ifconfig on both machines
    before and after a ping attempt, to see if any errors are counted.
     
    Bill Marcum, Oct 10, 2005
    #2
    1. Advertisements

  3. sangsu

    sangsu Guest

    we succeed ping with piv4.
    And when we try ifconfig on both machines before and after a ping6
    attempt,
    we can't find any errors.

    But, after the host ping to the embedded, the neighbor ip table of the
    host PC doesn't
    show the ip and mac-addr information of the embedded.
    And after the embedded ping to the host PC, the neighbor ip table of
    the host PC
    show the ip and mac-addr information of the embedded.

    I think that the icmp machanizm of the embedded doesn't work well.
     
    sangsu, Oct 11, 2005
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.