Linksys WUSB54G and WRV54G - Timeouts

Discussion in 'Wireless Internet' started by Jago, Jul 30, 2004.

  1. Jago

    Jago Guest

    I'm hoping someone here can help me with this problem. I'm trying to
    figure out why my wireless connection occasionally timeouts, and I can't
    tell if the WUSB54G or the WRV54G is at fault. I'm using WPA-PSK with TKIP
    encryption. This is what my router is using under Advanced Wireless
    Settings:

    Authentication Type: Open System
    CTS Protection Mode: Auto
    Basic Data Rates: All(1-2-5.5-6-11-24)
    Control Tx Rates: Auto
    Beacon Interval: 100
    DTIM Interval: 1
    RTS Threshold: 2346
    Fragmentation Threshold: 2346

    My goal is to use the wireless AP with encryption, so turning it off is not
    an option. Right now I'm using a CAT5 cable to the router, and it has
    worked perfectly. This leads me to believe that the WUSB54G could be at
    fault. Approximately every 30 seconds the WUSB54G will completely stop
    transmitting (its link light completely goes out, but the power light
    remains lit), then it will continue as normal until it stops transmitting
    again. There are no other WAPs in the neighborhood. One thing I noticed
    is that the RTS Threshold for the router and the WUSB54G didn't match, so I
    changed the router to match the client, both at 2346. This didn't help as
    the timeouts still persists, and it's most annoying during games and voice
    chats. The WUSB54G has the latest XP driver, and the WRV54G has the latest
    firmware. Any ideas? --Jago
     
    Jago, Jul 30, 2004
    #1
    1. Advertisements

  2. Jago

    Nico Guest

    I have the same probleme whith my WUSB54G (last driver 1.0.8.0 support WPA)
    and WRT54G when I'm using WPA-PSK with TKIP (it works in WEP) :
    When I ping the router I lost 1 ping every 30 seconds and sometimes my
    connection break down (2 or 3 time a day)
    When I connect my PC to the router with another wireless adapter it works
    fine so I believe that the WUSB54G is in fault

    I tried a lot of things :
    - my XP pro is patched
    - broadcast SSID enable
    (http://support.microsoft.com/default.aspx?scid=kb;en-us;811427)
    - router firmeware flashed with different versions
    - ...

    I have no solution for the moment
    Someone can help ?

    My usb port is not 2.0 (but the linksys says that WUSB54G works with 1.1 )
    perhaps it is the probleme and you Jago ?

    Thanks
    Nico
    --sorry for my poor english--
     
    Nico, Aug 3, 2004
    #2
    1. Advertisements

  3. Jago

    Jago Guest

    I found the culprit, though it's quite an annoying one. The wireless
    zero configuration utility is at fault for the timesouts, so I partially
    resolved the issue by completely disabling the service. When this is
    off, the timeouts completely disappear. However, there's one catch.
    After I reboot the computer, the WUSB54G will not making any connection
    to the internet or the router itself, even though the security settings
    are correct, and the IPs have been properly set (I manually set them).
    However, the adapter makes absolutely no data transfers to anywhere until
    I turn on the zero wireless utility.

    I initially thought that the utility was strictly for configuring
    wireless adapters, but it looks like in my case it's also involved with
    making the initial transfers. What's weird to me is that after the
    WUSB54G is able to transfer packets, I can disable the wireless config
    utility under Services, and the adapter will continue to work with ZERO
    timeouts until the next reboot. The same exact thing happened with an
    SMC wireless device I previously used. My laptop has a PCMCIA Linksys
    adapter with the config utility enabled, and it also experiences no
    timeouts. This leads me to believe a) the zero config utility is needed
    for initial transfers with USB devices, b) it's an issue with the zero
    config utility and USB, c) the USB on my motherboard is that picky (other
    USB devices [mouse, gamepad, MIDI controller, and printer] work fine), or
    d) my computer is affected by the moon.

    So far the only workaround is to enable the config utility at boot,
    double check the adapter by accessing the internet or perform a simple
    ping, then disable the config utility service upon success. It's a pain,
    but it's the only solution I've found so far. This is also with the
    latest router firmware (WRV54G) and drivers (WUSB54G). Hopefully, this
    might help you as well. --Jago
     
    Jago, Aug 4, 2004
    #3
  4. Jago

    Nico Guest

    So far the only workaround is to enable the config utility at boot,
    Thanks for your response
    Your solution works fine with my config
    I have no deconnection when stop the service (after the boot)

    I read that microsoft made an update of the wifi config service in XP SP2
    perhaps this problem will desappear

    Nico
     
    Nico, Aug 4, 2004
    #4
  5. Jago

    SOS571s Guest

    Thankyou so much Jago. This has finally fixed that timeout problem. I'
    just curious as to how you figured this out. The Wireless zer
    configuration is so hidden that it just seems odd for that to be th
    culprit. Anyway, thankyou very much for the informatio
     
    SOS571s, Aug 18, 2004
    #5
  6. Jago

    Jago Guest

    It was all trial-n-error. Unfortunately, I found a new problem. I cannot
    use WPA with the zero configuration utility disabled. I can disable it
    once the initial connection has been made, but future connections kill the
    association to my router. This doesn't occur with WEP. I'd like to use
    WPA, but the utility will have to stay enabled, which means dealing with
    timeouts once again. :-( So it's WEP and being proactive with WEP key
    changing for now until I can fix this issue. Even Service Pack 2 for XP
    didn't cure it. I might have to settle with a PCI card that can use a
    detachable antenna. Cheers!
     
    Jago, Aug 20, 2004
    #6
  7. Jago

    JayNYC Guest

    Yes!! I have been having the same strange drop-outs for months wit
    Linksys WRV54G with WPA! XP2 did not solve anything. Every 30 - 20
    seconds the connection drops outs, then comes back. It is soooo
    frustrating. I have been back and forth with Linksys on this and the
    are of no help

    Does anyone have WPA working reliably without hacking around an
    disbaling zero config
     
    JayNYC, Jan 24, 2005
    #7
  8. Jago

    Peter Pan Guest

    Not sure on the WRV54G, but my WRT54G was doing that when I upgraded to sp2,
    On the linksys website they have a firmware upgrade (and installer), you may
    want to see if they have it for your V
     
    Peter Pan, Jan 24, 2005
    #8
  9. Jago

    Jack Nolan Guest

    I've been having a problem with my WRT54G even after sp2. Problem is not
    consistent as I have been online for a couple of hours one time and dropping
    every other minute another time.
    There is another thread regarding a linksys device which suggests the
    problem may be in the Quality of Service (QoS) that is built into XP. They
    suggest stopping the service and turning it off the network connection
    profile for the pci card in your computer. I tried that last night and am
    going to test it some more tonight and tomorrow.
    It is almost definitely a problem with XP. I have run laptops with Win 2K
    that remain connected all the time.
     
    Jack Nolan, Jan 25, 2005
    #9
  10. Jago

    Michael Guest

    I am having the same issues. I thought it was my gear, so have swapped it
    all out and I get the same thing.

    Any Suggestions?
     
    Michael, Jan 28, 2005
    #10
  11. Jago

    Peter Pan Guest

    Did you update the firmware on the WAP/router? It's free and only takes a
    few minutes.. Heck it may be worth a shot.
    Go to the linksys website, and to the router page and they have a free
    download of the firmware installer and the firmware (as of dec 2nd for some
    models)... You may have gotten the router AFTER that date and think you're
    okay, but they have to order/ship/transport/stock/etc so it may very well
    have been built awhile before you got it... and like I said, what the heck,
    it's free and may just work for you.....

    Especially you Michael, the wrt54g was specifically updated and fixed a
    dropout with xp-sp2.. Like I said, it's free, what you got to lose except
    something to complain about? If it works, watch the superbowl and have a
    beer for me :)

    For those of you that have wap/routers and multiple 'puters, sometimes you
    can narrow it way down. I have two laptops, one i set up wired, and the
    other wireless.

    There are certain model revisions that only work wired (latest was a toshiba
    satellite rev c worked wireless but rev f would only work wired). Real handy
    to have both a wap/router, and a computer that does both wired and wireless
    for this.. But if it works one way, swap it and try it the other, if it
    screws up, you pretty much know where/what the problem is.

    LAST BUT ABSOLUTE TEST
    There is another suggestion, but if you mess up, you can REALLY mess up.....
    got something like Ghost and a USB hard drive for backups? Back up your
    entire system... reinstall it fresh from the emergency disks almost all
    systems come with, install the wireless and give it a try. Sounds silly, but
    you never know what someone has installed/removed (especially some freeware)
    that screwed something up/replaced with it's own version, of something that
    is needed (especially true of dll's)

    Good luck!
     
    Peter Pan, Jan 28, 2005
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.