Linksys WRT54G V1.1 Stops Responding

Discussion in 'Wireless Internet' started by dll2002dll, Dec 31, 2005.

  1. dll2002dll

    dll2002dll Guest

    I am having a problem with my Linksys WRT54G v1.1 with latest Firmware
    v4.20.7, Aug. 18, 2005 [Please note that I am using wired ethernet
    connection], I noticed a lot of times when I leave my computer
    unattended for a long time and come back to use it again the Internet
    dies, if I try to ping the router it doesnt respond, as soon as i
    reboot the router it begins to work. I have also observed that numerous
    times the router reboots itself, I have seen all the active LEDs on the
    font panel blinking in sync and the network icon in Windows XP pro
    machine saying Local area disconnected and then couple of seconds later
    saying connected, I have noticed this happening quiet often sometimes.

    Any idea?
     
    dll2002dll, Dec 31, 2005
    #1
    1. Advertisements

  2. dll2002dll

    Duane Arnold Guest

    There is (free) 3rd party firmware for the device. You can flash the
    router with one of them or flash it with v4.20.7 again. It might fix you
    problems. It can't hurt.

    You sure you're not having a problem with the modem? I have even heard
    of a NIC giving a router problems.

    Duane :)
     
    Duane Arnold, Dec 31, 2005
    #2
    1. Advertisements

  3. Are you running some P2P app like BitTorrent? I've seen that crash a
    lot of low-end routers, including the WRT54G
     
    William P.N. Smith, Dec 31, 2005
    #3
  4. dll2002dll

    Peter Pan Guest

    From Linksys, the latest version of that routers firmware description:

    Linksys, A division of Cisco Systems, Inc.

    Product: WRT54G

    Classification: Firmware Release History

    Firmware Date: 12/7/2005

    Release Date: 12/9/2005

    Last Firmware Version: 1.00.4
    __________________________________________________________________________
    Firmware 1.00.4
    - Resolves issues with slow downstream speeds
    - Resolves issues with certain web sites not loading or loading slowly
    - Resolves issues with obtaining an IP address from Windows 2000 Server
    - Resolves issues with certain Internet video streaming
    - Resolves issues with playing PSP games online

    Firmware 1.00.2
    - Resolves issue with SES and interoperability with other adapters
    - Resolves issue with DynDNS abusive updates

    Firmware 1.00.1
    - Resolves issue with enabling remote management
    - Resolves issue with unstable device boot up
    - Resolves issue with International country codes

    Firmware 1.00.0
    - Initial Release

    ** NOTE ** This firmware is only compatible with WRT54G v.5 or above. Please
    check the bottom of your router for the router's hardware version.Consider
    going to www.linksys.com and go to that product page and the hardware update
    link, or just go to
    http://www.linksys.com/servlet/Sate...957298&pagename=Linksys/Common/VisitorWrapper
     
    Peter Pan, Dec 31, 2005
    #4
  5. What's your point? We know the V5 has issues, but the OP has V1.1
     
    William P.N. Smith, Dec 31, 2005
    #5
  6. hath wroth:
    If you install one of the alternative firmwares, such as DD-WRT:
    http://www.dd-wrt.com
    you get an "AP watchdog timer" which allegedly detects if the router
    has gone comatose and reboots it automagically.
    "The AP Watchdog enables a timer that will check to see if any
    clients are connected in the interval seconds given. If no
    clients are attached, the watchdog assumes the AP needs to be reset.
    When clients are connected this reset will not occur. The watchdog
    is intended for situations where the AP becomes unavailable due to
    interference or internal chip problems."
    There's also a WDS connection watchdog which does the same thing for
    WDS links.

    I use a WRT54G v1.1 with dd-wrt v23 12/30/05 release as part of out
    neighborhood LAN. The AP watchdog function is enabled, but I've never
    seen it reboot the router. It would show up on my log files if it
    rebooted (and on the uptime when I login and tinker). It only reboots
    on power failures and sometimes on sustained high traffic loads.
     
    Jeff Liebermann, Dec 31, 2005
    #6
  7. dll2002dll

    KraftDiner Guest

    I had the exact same problems... Same hardware to.
    I started by getting rid of my 2.4Ghz cordless phones.
    I've upgraded to v4.20.7 firmware.
    I've enabled the SSID under the basic wireless settings.
    I'm running WEP (see wireless security)
    Secure Easy Setup is enabled.
    The DHCP server is enabled.

    By the way. On my MAC laptop I created a network that matched what
    the network I created on the router. It seems like if its not hard
    coded then
    I guess it doesn't allways see the SSID broadcast...

    On my PC laptop I'm running McAfee Wireless Security. I got rid of the
    MS Broadband Network Utility.

    Since I made those changes all seems stable and I haven't had to reset
    the Linksys on a regular basis.. and torrents don't seem to bother it.
     
    KraftDiner, Dec 31, 2005
    #7
  8. dll2002dll

    Peter Pan Guest

    The point is that the linksys website does NOT even show V1.1 They do show
    something else as a 1.1. If you go by the actual firmare number, I show 4
    has problems, and that 5 and above are okay.. But again, either 4 or 5 is
    NOT 1.1 (that's what the OP had in the subject)
     
    Peter Pan, Dec 31, 2005
    #8
  9. I think he meant *HARDWARE* version 1.1, not software version.
    Linksys WRT54G came in hardware versions 1.0, 1.1, 2.0, 2.2, 3.0, 3.1,
    4.0, and 5.0. Each has its own line of corresponding firmware.
    Unfortunately, Linksys hasn't been particularly careful about not
    using the same number sequences for their hardware and their software
    versions.
     
    Jeff Liebermann, Dec 31, 2005
    #9
  10. dll2002dll

    KraftDiner Guest

    That is correct the HARDWARE of the OP is V1.1
    Mine is V2.0
     
    KraftDiner, Jan 1, 2006
    #10
  11. dll2002dll

    dll2002dll Guest

    Yes I am using Hardware v1.1 of Linksys WRT54G.

    I tried loading .bin of DD-WRT through the web interface, but it says
    failed, I dont know why.

    William, regarding using P2P, you are right I am using BitTorrent, but
    I am sure I was successfully using it earlier when I bought it new a
    year ago.
     
    dll2002dll, Jan 1, 2006
    #11
  12. You may have exceeded some unknown number of {connections, requests,
    packets} that now causes it to fail.

    Someday I'm gonna try one of the aftermarket firmwares for a GL or V.4
    router, but last time I tried one I bricked the router, and the
    silence on the 'support' forums are (IME) deafening when you have a
    problem. I'll probably try the one Jeff reccomends next, but I
    suspect the problem is buried in the Linksys code which didn't change
    with all the aftermarket firmwares.
     
    William P.N. Smith, Jan 1, 2006
    #12
  13. hath wroth:
    Did you use the correct .bin image? This is the latest non-beta
    version 23.
    http://dd-wrt.gruftie.com/dd-wrtv2/downloads/index.php?path=dd-wrt.v23/&download=dd-wrt.v23.std.zip

    Did you follow instructions exactly?
    http://wrt-wiki.bsr-clan.de/index.p...22Right_Way.22_to_Flash_Your_WRT54G.2FGL.2FGS
    I've "bricked" two WRT54G routers because I was in a hurry. When it
    says to leave it alone, do nothing, don't touch the computer, don't
    click the "continue" button, etc, for 2 minutes, it really means it.
    Try decreasing the number of streams or connections (i.e. number of
    allowed IP sockets) and see if it helps. 30 is a good low starting
    number.
     
    Jeff Liebermann, Jan 1, 2006
    #13
  14. I'm not convinced it's a number of (allowed) connections, it feels
    more like 'number of connection attempts', which isn't something you
    can set. Tens of thousands of requests for 'the hot new file', even
    if they are denied from your LAN machine, might exhaust your (say)
    stack space in your router. OSLT...
     
    William P.N. Smith, Jan 1, 2006
    #14
  15. dll2002dll

    dll2002dll Guest

    I have successfully configured my router for Firmware: DD-WRT v23
    (12/25/05), I have also configured BT client (Azureus) for this:

    Max simultaneous outbound connection attempts: 1
    Max num of connections per torrent: 20
    Max num of connections globally: 40
    Upload Speed: 12KB/s

    Would this help? I'll know it by tommorow :)
     
    dll2002dll, Jan 3, 2006
    #15
  16. dll2002dll

    KraftDiner Guest

    Hey I have the same router V2.0
    Has anybody noticed that there is a DHCP lease time that is set to 0?
    0 according to the documentation is a 1 day lease.
    I'm wondering if when you have the torrent open if you leave it open
    for more than 24 hours. If so what happens to software running on a
    machine
    after the ip address is changed.. (If indeed it actually does.)
    I can't say that I've seen the IP address actually chang, but if the
    configuration
    option is there what is it doing?
     
    KraftDiner, Jan 3, 2006
    #16
  17. Please let us know!
     
    William P.N. Smith, Jan 3, 2006
    #17
  18. IIRC, the way the DHCP lease is supposed to work is that at half the
    lease time, the client machine asks to extend the lease with the same
    IP address, so the IP will (rarely) change.

    I have noticed some trouble with routers crashing, losing their
    context, and assigning the same IP to multiple machines. This isn't
    _supposed_ to happen (someone is supposed to ask "Is this IP in
    use?"), but I've seen it...
     
    William P.N. Smith, Jan 3, 2006
    #18
  19. dll2002dll

    Rico Guest

    Jeff, I browsed the documentation you posted above (Got an older 54G 1.1)
    that I want to put DD-WRT on to 'play' with. I saw there are some shell
    script examples, but missed what shell is running. Is it bash or sh or do
    you know?

    fundamentalism, fundamentally wrong.
     
    Rico, Jan 3, 2006
    #19
  20. (Rico) hath wroth:
    ~ # sh -v
    BusyBox v1.01 (2005.11.18-11:12+0000) Built-in shell (ash)
    Enter 'help' for a list of built-in commands.

    Built-in commands: ------------------- : alias bg break cd chdir
    command continue eval exec exit export
    false fg getopts hash help jobs kill let local pwd read readonly
    return set shift times trap true type ulimit umask unalias unset
    wait
     
    Jeff Liebermann, Jan 3, 2006
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.