Linksys Wireless Router 2.4-GHz, Ubuntu, not working

Discussion in 'Linux Networking' started by Dawson, Jun 10, 2007.

  1. Dawson

    Dawson Guest

    Hi, I've just bought a Linksys Wireless ADSL Router, attached it to my
    laptop via RJ45 cable, setup and all working fine! However, although I
    can see the SID being broadcast, it's telling me connection failed --
    I have put in the correct WEP key as per the router administration but
    it's still not working. I've tried everything but can only get online
    via the hard-wire cable :(
     
    Dawson, Jun 10, 2007
    #1
    1. Advertisements

  2. Dawson

    Dawson Guest

    Right, further investigations. I have disabled the WEP key and allowed
    anonymous access and it's still telling me connection failed? any
    ideas? Thank you
     
    Dawson, Jun 10, 2007
    #2
    1. Advertisements

  3. Dawson

    ynotssor Guest

    In
    ....
    RTFM. "Troubleshooting."
     
    ynotssor, Jun 10, 2007
    #3
  4. What does iwconfig say?
    And "iwlist scan ..."?
     
    Timothy Murphy, Jun 11, 2007
    #4
  5. Dawson

    Dawson Guest

    [email protected]:~$ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    eth1 unassociated ESSID:"hippy_commune"
    Mode:Managed Frequency=nan kHz Access Point: Not-
    Associated
    Bit Rate:0 kb/s Tx-Power:16 dBm
    Retry limit:15 RTS thr:eek:ff Fragment thr:eek:ff
    Power Management:eek:ff
    Link Quality:0 Signal level:0 Noise level:0
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:5483 Missed beacon:0



    --------------------------------------------------


    [email protected]:~$ iwlist scan
    lo Interface doesn't support scanning.

    eth0 Interface doesn't support scanning.

    eth1 Scan completed :
    Cell 01 - Address: 00:13:10:DB:3B:CD
    ESSID:"hippy_commune"
    Protocol:IEEE 802.11bg
    Mode:Master
    Channel:6
    Encryption key:eek:ff
    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
    11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36
    Mb/s
    48 Mb/s; 54 Mb/s
    Quality=92/100 Signal level=-39 dBm Noise
    level=-39 dBm
    Extra: Last beacon: 480ms ago
     
    Dawson, Jun 11, 2007
    #5
  6. So at least it sees the access point.

    I should say that I'm no expert.
    If the access point is using dhcp,
    I would look at this,
    eg by looking at /var/log/messages on the remote machine
    (or possibly on the access point, if this is running Linux),
    and also /etc/dhcpd.conf .

    Is the ESSID definitely correct?

    I'd look too at /etc/sysconfig/network-scripts/ifcfg-eth1
    to see that the settings there are correct.
     
    Timothy Murphy, Jun 11, 2007
    #6
  7. Dawson

    Dawson Guest

    I'm not sure really, I just click on the network icon, select the SSID
    and click connect, and it says connection fails. This is with my new
    linksys router -- it worked fine before with the BT Broadband Hub we
    were originally using. So I figured it must be the Linksys hardware
    configuration, but on disabling authentication and allowing free
    access, it's still not working -- i'm stumped.
     
    Dawson, Jun 11, 2007
    #7
  8. As I said, I am no expert,
    but how do you know the access point does not have an encryption key set?

    I have a LinkSys WRT54GL.
    I can access this over the web and set or unset the ESSID and key.

    Also, are there any dhcpd entries in /var/log/messages
    on the remote machine?
     
    Timothy Murphy, Jun 11, 2007
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.