Linksys WET11 not acquiring DHCP address from ISC DHCPd server

Discussion in 'Linux Networking' started by Kevin T. Neely, Jul 18, 2006.

  1. (I also posted this in alt.networking.wireless earlier today, as my
    DHCP server is running Ubuntu 6.06 Linux, I thought this group might
    be able to help. Thank you.)


    I am trying to get one of the Linksys WET11's to bridge a couple
    desktops to the rest of my home network. The problem is that the
    WET11 does not acquire a DHCP address from my Linux server running ISC
    DHCPd. (Diagram of my network below)

    While watching the syslog, I can see the WET11's MAC address appear
    along with the DHCP requests, like this:

    Jul 17 12:46:08 piglet dhcpd: DHCPDISCOVER from 00:06:25:45:78:d5 via
    eth1
    Jul 17 12:46:09 piglet dhcpd: DHCPOFFER on 192.168.0.8 to
    00:06:25:45:78:d5 via eth1

    The problem is that the WET11 never makes its DHCPREQUEST back to the
    server. I can set a static IP address for the WET11 just fine, but
    the clients connected to the WET11 have the same behavior as the
    above.

    The WET11 is configured in infrastructure mode and otherwise seems to
    be working. It is version 1, and the latest firmware. The WAP11 is
    also v.1 and the latest firmware. I have two of the WET11's and they
    both exhibit the same behavior.

    any ideas?
    K


    Diagram Legend
    | denotes wired link
    } denotes wireless link

    Internet
    |
    Motorola Cable Modem
    |
    XUbuntu Linux server
    2 Ethernet Interfaces
    Shorewall / IPTables
    ISC DHCP server
    |
    Linksys 10/100 Hub
    |
    Linksys WAP11 v 1.0 (not running DHCP)
    }
    Linksys WET 11
    |
    10/100 switch
    |
    Desktop clients
     
    Kevin T. Neely, Jul 18, 2006
    #1
    1. Advertisements

  2. Kevin T. Neely

    Ken Roberts Guest

    Try enabling BOOTP to see if that works.

    I've noticed a few network appliances that need BOOTP, which is a pain
    because I don't want that enabled and can't have it in some cases.
     
    Ken Roberts, Jul 18, 2006
    #2
    1. Advertisements

  3. Thank you for the response. I tried adding a bootp range to my
    /etc/dhcpd.conf file, but it does not seem to have worked. Watching
    the syslog after powering up the WET11, I still see only the
    DHCPDISCOVER and DHCPOFFER messages. This is what the subnet's dhcp
    configuration looks like:

    subnet 192.168.0.0 netmask 255.255.255.0 {
    range 192.168.0.2 192.168.0.50;
    range dynamic-bootp 192.168.0.51 192.168.0.55;
    option broadcast-address 192.168.0.255;
    option routers 192.168.0.1;
    }

    thank you,
    K
     
    Kevin T. Neely, Jul 18, 2006
    #3
  4. Kevin T. Neely

    Ken Roberts Guest

    Some routing equipment doesn't like a zero octet. Try changing to
    192.168.1.x instead.

    My Cisco gear needs a special configuration parameter to acknowledge a
    zero octet. Not sure why, but I think it's either a bug in the
    original tcp stack or an omission in the spec.
     
    Ken Roberts, Jul 18, 2006
    #4
  5. Still no dice. I did this:

    subnet 192.168.0.0 netmask 255.255.254.0 {
    range 192.168.1.2 192.168.1.50;
    range dynamic-bootp 192.168.1.51 192.168.1.55;
    option broadcast-address 192.168.1.255;
    option routers 192.168.0.1;
    }


    Do I need to go "all-in" and change the subnet, as well? I just
    extended the netmask and put all the DHCP clients on the the x.x.1.x
    half of the subnetwork. I did not want to change all my router and
    network settings, and was afraid that if I only changed the DHCP
    settings, the client would not be able to reach the router and would
    still fail, albeit for a different reason.

    thanks,
    K
     
    Kevin T. Neely, Jul 19, 2006
    #5
  6. Kevin T. Neely

    Ken Roberts Guest

    If your router doesn't work well with zero octets, that would mean ALL
    zero-octet addresses would need to go away, where the zero is in the
    network number.

    In other words, change all occurrences of 192.168.0 to be 192.168.1.
    You'd have to change the router first, so you can get to it after your
    other gear switches over.

    Keep in mind that this might not be your problem. Some gear has that
    problem, other gear does not. As I said earlier, I think it's a bug.
     
    Ken Roberts, Jul 19, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.