Linksys router; Can't stay connected? <b>Unacceptable</b>

Discussion in 'Linux Networking' started by =?ISO-8859-1?Q?Ga=E9tan_Martineau?=, Jun 15, 2004.

  1. I happen to find out (on page 34 out of 59), after a week, why the
    router I recently bought "can stay connected". Finally. The
    documentation reads : (My connection is PPPoE, router is Linksys BEFSR41)

    "PPPoE is not actually a dedicated or always-on connection. The DSL ISP
    can disconnect the service after a period of inactivity" (...oh yeah???..)

    "There is a set-up option to keep-alive the connection" (Does not work!)
    "This may not always work" (Yeah, I noticed) "If the connection is lost
    again, follow steps E and F to re-establish connection" (What???) Ok,
    but unacceptable to me!

    I have a web server on the network inside. There is documentation on
    this server that *needs* to be available and I won't stay here following
    "steps E and F". Short of going back to my previous configuration (linux
    box acting as a router and server), is there any way I can keep this
    connection ON ?

    I am thinking of a crontab entry asking to dowload a dummy something of
    whatever to keep some trafic going through this router... Any suggestion
    toward the best solution is most welcome... Thanks.

    =?ISO-8859-1?Q?Ga=E9tan_Martineau?=, Jun 15, 2004
    1. Advertisements

  2. Since you have a server that _needs_ to remain connected, why not use the
    server (I assume Linux, subject of newsgroup) as firewall/router to
    remain connected with 'persist' pppd option for pppoe. Just make sure you
    keep up to date with security.

    I personally just have a personal web server and mail, so I have mine set
    as a demand connection and idle 0 (does not disconnect unless dropped).
    But I run [email protected], so it reconnects on demand when that exchanges work
    units. Dynamic DNS (for is updated automatically from
    /etc/ppp/ip-up with: /usr/local/bin/noip2 -i $4
    David Efflandt, Jun 15, 2004
    1. Advertisements

  3. Well, yes, but, in other words, this means that I made a mistake buying
    this router and I should have kept my previous configuration...
    Thanks you for this information.

    =?ISO-8859-1?Q?Ga=E9tan_Martineau?=, Jun 15, 2004
  4. [...]
    True enough. PPPoE connections typically will be disconnected at least
    every 24 hours. Depending on the intentions of the ISP in question,
    even more often than that to free up connections.
    True. Some of the HW routers fail to realise that the connection
    has been dropped by the ISP and therefor do not restart the PPPoE


    Simply setup a cronjob to send out a ping to some external site once every
    5 minutes or so. Other than that, if you really need a 7/24 connection
    for your server, think about renting a dedicated server at a hosting

    Michael Buchenrieder, Jun 15, 2004
  5. Why not just ping an outside domain from the server. This would make
    litle traffic an will keep the connection alive (within a second).
    So ssh to your server and do a `ping 2>&1 > /dev/null <
    /dev/null &` and your server should keep your internet connection

    Mathias Krause, Jun 15, 2004
  6. Thanks very much for the information. I put a cron job to ping 1 packet
    every 5 minutes. I will then see what will happen. And, well, yes,
    renting a dedicated server begins to be an interestng option to me as
    from now.

    =?ISO-8859-1?Q?Ga=E9tan_Martineau?=, Jun 15, 2004
  7. =?ISO-8859-1?Q?Ga=E9tan_Martineau?=

    jack Guest

    Perhaps it's easier to create a ping in the background and using its
    command line parameters: "ping -i 237 -q $REMOTE_IP &".

    The "-i" option specifies the interval between the ICMP-echo-requests,
    "-q" makes it run in quiet mode, and giving a fixed public IP address
    rather than a name will avoid DNS queries. - BTW, it doesn't matter
    whether the ping is sucessful or not, You just want to generate some
    traffic to keep the link from being idle and hence timing out.

    Ah, and "-i 237" was just an idea to avoid even numbers in seconds or

    Using plain ping, as some other poster suggested, is not a good idea
    since it will slow down Your link significantly and use up system

    Personally, I put the ping commmand in "/etc/ppp/ip-down", which will
    be called after a connection is terminated. Before that, there's a loop
    that kills its predecessor, namely the ping that had been started upon
    the last disconnection.

    Depending of what sorts of services You want to provide, You may obvi-
    ously be better off with a remote server. Nowadays, You can get them at
    a rate that compares to Your flat rate, so what.

    Again, my own experience is to have mail and http on a leased system,
    and only some services hosted at home (via no-ip, coincidentally).

    Cheers, Jack.
    jack, Jun 15, 2004
  8. =?ISO-8859-1?Q?Ga=E9tan_Martineau?=

    Matt Payton Guest

    As in previous responses, there are a number of ways to do this...And it
    may very well help work around the problem.

    As for what the issue is, have you updated the firmware on the Linksys ?

    I know there were issues with some of their revisions. Also, sometimes
    updating the firmware was the *cause* of the issue...If you recently
    updated it, maybe try downgrading to a previous release.
    And, if the Linksys is one of the wrt models ( which run linux ), there
    are some modified versions of the firmware that have some enhancements
    over the "stock" Linksys versions. Don't know if any of them have any
    pppoe enhancements, but worth a shot.

    Check out,16 for some decent
    discussions on Linksys ( and other ) Broadband routers.
    Matt Payton, Jun 15, 2004
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.