LinkSys BEFSR81 v1: Bad latency/ping issues of over a second. Anyone else seen it?

Discussion in 'Broadband' started by Bloke at the pennine puddle (Replace n.a.v.d with, Oct 22, 2003.

  1. Calling all who have a LinkSys router and more then one computer on
    it. Specifically the `BEFSR81 v2` router with the latest firmware.
    Router is firmware date `2.44.2z, Dec 13 2002`

    The `BEFSR41 v2` might show the same symptoms.

    If you've got the 8 port version, do the following. I'm trying to
    identify a problem with the router's firmware and if others have the
    same problem and may also have a need to bombard LinkSys to get the
    bug fixed. It affects the people who love to have the lowest ping
    possible.

    If the fault is there, post your request to have it fixed as indicated
    at: http://www.linksys.com/international/country.asp?rgid=4


    <<<<<< The first bit >>>>>>

    Connect a computer to port 1 and another to port 2.

    Turn on and configure QoS on the router (if you have it) and configure
    it to the following.

    FTP, HTTP, POP3 and port 554 to high priority.
    TELNET, SMTP and port 119 to low priority.
    Set the last entry to port 0 and to `disable`.

    Port 1 to high priority.
    Ports 2, 3 and 4 to low priority.

    Plug a computer into port 1 on the router and turn off the computer,
    to the point where the router is showing no link present. Maybe it'll
    work by unplugging the network cable from port 1 on on the router and
    turn on the computer on port 2, open up a DOS box and type the
    command:

    tracert www.bbc.co.uk

    Do you get the following timings stupid?

    Tracing route to www.bbc.net.uk [212.58.224.112]
    over a maximum of 30 hops:

    1 1014 ms 1008 ms 1004 ms 10-23-32-1 [10.23.32.1]
    2 1009 ms 1006 ms 1006 ms oldh-t2cam1-b-v115.inet.ntl.com [80.5.164.189]
    3 1029 ms 1007 ms 1077 ms mant-t2core-b-ge-wan62.inet.ntl.com [213.104.242.169]
    4 1008 ms 1006 ms 1008 ms man-bb-b-so-210-0.inet.ntl.com [62.253.184.61]
    5 1012 ms 1014 ms 1013 ms win-bb-a-so-300-0.inet.ntl.com [62.253.185.138]
    6 1007 ms 1811 ms 1012 ms gfd-bb-b-so-500-0.inet.ntl.com [213.105.172.130]
    7 1012 ms 1016 ms 1017 ms tele-ic-2-so-100-0.inet.ntl.com [62.253.185.74]
    8 1016 ms 1010 ms 1019 ms 212.58.239.217
    9 2009 ms 2005 ms 2005 ms www.bbc.net.uk [212.58.224.112]

    Your route to www.bbc.net.uk will be different to mine, but notice the
    time taken (or noted) for the echo to return from each router/server!

    Now, telnet (and it's allowed!) to `route-server.as5388.net` and trace
    route back to your router's public IP, so if NTL assigns you an IP of
    81.97.98.100, the command to issue to the remote router is . ..

    traceroute 81.97.98.100

    Everything between that router hosted at Energis and the last hop to
    your router will be small and normal, but the last hop from the UBR to
    your router will be in the high-milliseconds! Remember to have `Block
    WAN requests` on your router for this to work.


    <<<<<< The second bit >>>>>>

    Make port 1 on the router active. As in, just plug in the cable, or
    turn on the computer if it's off. Just so the router registers that
    there is a network card attached to port 1, and do the same thing.

    Tracing route to www.bbc.net.uk [212.58.224.116]
    over a maximum of 30 hops:

    1 10 ms 9 ms 10 ms 10-23-32-1 [10.23.32.1]
    2 10 ms 11 ms 9 ms oldh-t2cam1-b-v115.inet.ntl.com [80.5.164.189]
    3 14 ms 15 ms 10 ms mant-t2core-b-ge-wan64.inet.ntl.com [213.104.242.181]
    4 10 ms 30 ms 9 ms man-bb-b-so-210-0.inet.ntl.com [62.253.184.61]
    5 18 ms 19 ms 16 ms win-bb-a-so-300-0.inet.ntl.com [62.253.185.138]
    6 38 ms 18 ms 42 ms gfd-bb-b-so-500-0.inet.ntl.com [213.105.172.130]
    7 18 ms 18 ms 19 ms tele-ic-2-so-100-0.inet.ntl.com [62.253.185.74]
    8 19 ms 20 ms 18 ms 212.58.239.217
    9 52 ms 21 ms 19 ms www.bbc.net.uk [212.58.224.116]

    Now, spot the huge difference!

    Question: Anyone else suffering from this problem? Complain to
    LinkSys if you are.

    My diagnosis shows that the firmware is faulty, especially that the
    same stupid timings can be replicated by a ping or trace route
    originating to my public IP from the Internet.
     
    Bloke at the pennine puddle (Replace n.a.v.d with , Oct 22, 2003
    #1
    1. Advertisements

  2. Bloke at the pennine puddle (Replace n.a.v.d with

    Ian Stirling Guest

    The "high/low" priorities are probably at fault.
    All else being equal, if two computers start to download the same file
    from the same place over the same connection, then the higher latency one
    will tend to get starved out of the connection.
    This is apparently what happens when you set a port to low priority.
    Don't do that then.

    --
    http://inquisitor.i.am/ | mailto: | Ian Stirling.
    ---------------------------+-------------------------+--------------------------
    He had been eight years upon a project for extracting sunbeams out of cucumbers,
    which were to be put in vials hermetically sealed, and let out to warm the air
    in raw inclement summers. -- Jonathan Swift, "Gulliver's Travels" (1726)
     
    Ian Stirling, Oct 22, 2003
    #2
    1. Advertisements

  3. Thanks for reply Ian. I'll try your suggestion and set all the ports
    to low priority, but the issue is that the timings are all screwed up
    when there is no `link` present on port 1. As soon as a `link` is
    detected on port one, everything on the other ports show believeable
    figures.

    Remember, it's not about data transfer. Just turning on the PC on
    port 1 and pressing pause so it's not even had a chance to boot
    anything from the hard disk `cures` the symptom. Remove the `network
    device` from port 1 and we are back to stupid 1000ms+ for the echo to
    return. as opposed the the usual average of 11ms.
     
    Bloke at the pennine puddle (Replace n.a.v.d with , Oct 22, 2003
    #3
  4. Did the extra tests....

    Okay. I turned off the QoS on the router and also, for good measure,
    reset the router. I turned on the computer on port 2 and turned off
    the computer on port 1.

    The trace route result from my end to `www.bbc.co.uk` ...

    Tracing route to www.bbc.net.uk [212.58.224.124]
    over a maximum of 30 hops:
    1 999 ms 1008 ms 1020 ms 10.23.32.1
    2 1007 ms 1002 ms 1006 ms oldh-t2cam1-a-v115.inet.ntl.com [80.5.164.61]
    3 1006 ms 998 ms 1000 ms mant-t2core-a-ge-wan62.inet.ntl.com [213.104.242.41]
    4 1828 ms 1010 ms 1007 ms man-bb-a-so-230-0.inet.ntl.com [62.253.184.57]
    5 1009 ms 1006 ms 999 ms man-bb-b-ae0-0.inet.ntl.com [62.253.187.178]
    6 1014 ms 1038 ms 1012 ms win-bb-a-so-300-0.inet.ntl.com [62.253.185.138]
    7 1007 ms 1009 ms 1009 ms gfd-bb-b-so-500-0.inet.ntl.com [213.105.172.130]
    8 1016 ms 1029 ms 1039 ms tele-ic-2-so-100-0.inet.ntl.com [62.253.185.74]
    9 1029 ms 1010 ms 1016 ms 212.58.239.217
    10 2684 ms 2009 ms 2009 ms www24.thdo.bbc.co.uk [212.58.224.124]
    Trace complete.

    Now, I got `route-server.as5388.net` to trace route to my router, and
    the result is ...

    route-server.as5388.net>traceroute 81.97.98.144
    Type escape sequence to abort.
    Tracing the route to cpc1-roch1-5-0-cust144.mant.cable.ntl.com (81.97.98.144)
    1 ge1-2.pbr-1.msl.as5388.net (195.92.201.106) 0 msec 0 msec 0 msec
    2 195.92.55.141 8 msec 8 msec 8 msec
    3 linx-gw1.router.ntli.net (195.66.224.22) [AS 5459] 8 msec 8 msec 20 msec
    4 gfd-bb-a-so-320-0.inet.ntl.com (62.253.185.77) [AS 5089] 8 msec 8 msec 8 msec
    5 gfd-bb-b-ae0-0.inet.ntl.com (213.105.172.6) [AS 5089] 12 msec 8 msec 12 msec
    6 win-bb-a-so-500-0.inet.ntl.com (213.105.172.129) [AS 5089] 8 msec 12 msec 8 msec
    7 man-bb-b-so-600-0.inet.ntl.com (62.253.185.137) [AS 5089] 16 msec 16 msec 16 msec
    8 mant-t2core-b-pos31.inet.ntl.com (62.253.184.62) [AS 5089] 16 msec 16 msec 16 msec
    9 oldh-t2cam1-b-ge-wan54.inet.ntl.com (213.104.242.182) [AS 5089] 28 msec 28 msec 32 msec
    10 ubr01roch-ge20.inet.ntl.com (80.5.164.190) [AS 5089] 24 msec 16 msec 16 msec
    11 cpc1-roch1-5-0-cust144.mant.cable.ntl.com (81.97.98.144) [AS 5089] 1044 msec 1064 msec 1112 msec
    route-server.as5388.net>

    Notice the 11th entry. It's in the thousands, and at the preceeding
    UBR it's only in the tens, and QoS is knocked off.

    While getting the computer on port 2 to ping `www.bbc.co.uk`
    constantly I turned on the computer on port 1. After about 15 seconds
    the ping times on port 2 suddenly dropped from the thousands to the
    tens. Maybe that was triggered within the router by the computer on
    port 1 sending data of whatever nature? Also, doing a trace route from
    `route-server.as5388.net` also shows things return to normal.

    With the fault active, and tracerouting from
    `route-server.as5388.net`, the 1000 is what it says. It takes a second
    for each echo sent to the router to return to
    `route-server.as5388.net`.

    It's a fault with the firmware within LinkSys router. I'm convinced.
    If it was any settings then the WAN side of the router would not be a
    affected.

    Maybe if enough people indicate this potential bug to LinkSys/Cisco,
    something might be done about it.
     
    Bloke at the pennine puddle (Replace n.a.v.d with , Oct 22, 2003
    #4
  5. I FOUND THE FAULT!

    The router is set to send all it's logging data to my main machine
    `172.16.0.1`. If the logging client is not there to receive the log
    data then the router waits for one second! Like if the computer is
    turned off!

    I just proven it. On the router I changed the logger IP from
    `172.16.0.1` to an IP that does not exist on my LAN and guess what, 2
    second pings for every packet! Changed it back to `172.16.0.1` and we
    are back to 10ms(ish).

    I knew it was a bug with the Firmware. It's not often that I'm wrong.
     
    Bloke at the pennine puddle (Replace n.a.v.d with , Oct 22, 2003
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.