Is there any way of forcing it to Acquire Network Address?

Discussion in 'Wireless Internet' started by Tristán White, Nov 21, 2005.

  1. My neighbour's WiFi, to which I connect using the network key he has
    given me (and slip him a tenner every month), sometimes is so hard to
    get onto.

    The signal strength is almost always good, more often than not very
    good, sometimes even excellent, and connects at 11 Mbps speed. Uses
    WEP encryption, and I have his Network key. I have it all set to
    connect automatically.

    But sometimes it's hard to acquire the address!

    You can be sitting there looking at that little TVscreen with the
    three green brackets, waiting for it to flash and say Acquiring
    Network Address. Once that happens, I'm on and rarely booted off.

    However, sometimes it's so stubborn. It won't connect. I go to "Choose
    a wireless network" where I see his network with at least four of the
    green panpipe thingies lit up (very good signal), and set to
    "Automatic". If I double click on it or click on connect, this does
    not make it acquire the network address... it just tries to connect
    and after about 15 seconds goes back to Automatic. But not to
    Connected.

    When this happens I've tried everything, from Repairing the
    connection, to reentering the network key, anything. Moving my little
    DLink antenna. Rebooting the PC.... But when it gets stubborn like
    this it just won't work. The signal stays strong, it just won't
    actually connect, even if you hit connect.

    Eventually, it decides to "Acquire the network address" and then I go
    straight in.

    Is there any way of enforcing it to Acquire the network address? Some
    DOS command I could use or something? Last night I really wanted to
    use it and it took 2 hours until I managed to get on. It's a complete
    PITA.

    Some of you will probably say that that's WiFi/Dlink for you, but I
    could understand it if I got a shite signal. But if I get a good or
    very good signal, and I click on Connect (although it is meant to
    connect automatically) I cannot see why it doesn't say AHA My master
    wants to connect, I'm going to acquire a network address for him and
    connect. Instead I have this pantomime.

    Any thoughts or help gratefully appreciated.

    TRISTÁN
     
    Tristán White, Nov 21, 2005
    #1
    1. Advertisements

  2. Tristán White

    aljuhani Guest

    aljuhani, Nov 21, 2005
    #2
    1. Advertisements

  3. Tristán White

    David Taylor Guest

    Is there any way of enforcing it to Acquire the network address? Some
    Just assign a static IP address and be done with it.

    David.
     
    David Taylor, Nov 21, 2005
    #3
  4. Tristán White

    __spc__ Guest

    Yeah, find out the router/AP's IP address range, then assign your
    network adaptor an IP address in that range (one that won't get used by
    anyone else).

    You might also want to run winsockXPfix.exe (Google for it) and repair
    your TCP stack.
     
    __spc__, Nov 21, 2005
    #4
  5. Tristán White, Nov 21, 2005
    #5

  6. Thank you... I'll try it all out.

    Ta
     
    Tristán White, Nov 21, 2005
    #6
  7. Tristán White

    David Taylor Guest

    Thank you!! I'll try that next time!

    I don't know why it does that though, i've experienced the same thing
    but only with a low signal. Difficulty in obtaining an address yet once
    I have one, it'll stay connected rock solid.

    Very odd.
    David.
     
    David Taylor, Nov 21, 2005
    #7
  8. Tristán White

    aljuhani Guest

    Yes it will work on XP and other Windows Version.

    First try only ipconfig and you will have a list
    of your interfaces with thier IP addresses and subnets

    then you have other options to /release ip or /renew etc.
    as listed in the microsoft docs mentioned earlier.

    regards,

    -aljuhani
     
    aljuhani, Nov 21, 2005
    #8
  9. Tristán White, Nov 21, 2005
    #9
  10. Tristán White

    David Taylor Guest

    Actually, will that work on XP??

    absolutely but it's still going to be more effective to configure a
    static address :)
     
    David Taylor, Nov 21, 2005
    #10
  11. Tristán White

    aljuhani Guest

    Well as David Taylor say, it is better that
    you assign your computer with a static IP address.

    You will need to contact your neighbour about
    the DHCP range on his router so you can choose
    a reserve IP on same subnet outside that range.

    regards

    -aljuhani
     
    aljuhani, Nov 21, 2005
    #11
  12. Tristán White

    aljuhani Guest

    Well it depends on the router setup.
    you need to ask the guy providing you with
    wireless connection.

    No problem, you can ask any question here.

    -aljuhani
     
    aljuhani, Nov 21, 2005
    #12

  13. HI - which is it then? outside the range (Aljuhani), or inside the
    range (__spc__)?

    Sorry, I'm a newbie at wifi....
     
    Tristán White, Nov 21, 2005
    #13
  14. Thanks, I'll pop in tonight to my neighbour and find out.
     
    Tristán White, Nov 21, 2005
    #14
  15. Tristán White

    aljuhani Guest

    aljuhani, Nov 21, 2005
    #15

  16. May have to rethink this. He's told me that it's not advisable for him
    to give out a static ip address as we live on a busy road with lots of
    neighbours. As it is, from my house, I can normally see about 3 other
    wifis...
     
    Tristán White, Nov 22, 2005
    #16
  17. Tristán White

    David Taylor Guest

    May have to rethink this. He's told me that it's not advisable for him
    Meaningless because *anyone* can configure their machine statically and
    I'd hope he's not relying on an IP address as the only security?!!

    David.
     
    David Taylor, Nov 22, 2005
    #17
  18. Tristán White

    aljuhani Guest

    Ok then if that what he wants, you will need to stay dynamic but since
    you are talking
    about 4 wifis being detected, I guess your problem is something to do
    with XP keeps switching between connections.

    There is of course away to configure your default connection and ignore
    others.

    regards.

    -aljuhani
     
    aljuhani, Nov 22, 2005
    #18
  19. Tristán White

    David Taylor Guest

    Ok then if that what he wants, you will need to stay dynamic but since
    That's the joke, he doesn't, he can *still* configure his machine with a
    static IP address. You can bet that the friend doesn't have 254 hosts
    on the network and that the IP range isn't limited. Just see what IP
    address was offered in the DHCP lease and pick something say 50 higher
    or lower.

    High likelihood that it will work just fine, affect nothing and his
    friend can't stop him setting that IP address anyway without ownership
    of the machine.

    David.
     
    David Taylor, Nov 22, 2005
    #19
  20. Tristán White

    aljuhani Guest

    Fully agree with you but I was thinking to go along with such mentality
    and not
    to cause problems to someone that expected a help from us here.

    -aljuhani
     
    aljuhani, Nov 22, 2005
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.