Is a Cisco DPC3925 a piece of junk?

Discussion in 'Wireless Internet' started by dold, Mar 5, 2014.

  1. dold

    dold Guest

    I had some cable modem whose brand I don't remember, and a Netgear WNR1000
    at my house.

    One day, "the Internet" seemed slow, and some ping testing showed dropped
    packets.

    I called Mediacom support.
    They said there was nothing wrong on their side, but my modem was old, so
    they sent me a Cisco DPC3925.

    They didn't mention that it was a cable modem and WiFi router with four
    ports. I plugged my Netgear into one of the ports, logged on to the Cisco,
    killed the WiFi, and carried on.

    Still dropping packets through the NetGear.
    I connected to a Cisco port directly, no dropped packets. I connected to
    the Cisco WiFi, no dropped packets.

    A few rounds with Netgear support, and I got an RMA for the Netgear.
    Cross-ship was $20, so I opted for send and receive.
    I connected my wired gadgets to the Cisco, and reconfigured the WiFi to use
    the same IP range, SSID and WPA2 password as the Netgear, thinking none of
    my wireless gadgets would need to be reconfigured.

    That was not true.
    Lots of stuff was unhappy.
    Android tablets and Android phones just needed to manually reconnect once.
    A Kindle refused to connect.
    DirecTV DVRs had to re-do the internet connection steps, and then reset.
    DirecTV GenieGo had to be plugged directly into the Cisco, rather than
    sharing the LAN side of another switch.

    And my Ubuntu laptop, which had connected for a while, stopped connecting
    after I did a factory reset, which allowed the Kindle to connect.
    It was getting a failure with "reason=3" and then "reason=15", both of
    which are discussed on the web a few years ago as a bad WiFi driver.
    I am still able to connect to my phone's mobile hotspot.

    I have a total of 25 IP addresses in my house.
    Is that too much for the Cisco DPC 3925?
    They aren't all on at once, and some have not connected yet, but I wonder
    what the real limit is. Maybe there was nothing on the Netgear that
    suddenly broke, just the addition of one more IP in the house.

    Do I need a better quality router?

    The interface on the Cisco looks like it's 10 years old. Features about
    dedicated IP addresses from the DHCP pool are awkward, and the "attached
    devices" list shows varying numbers of devices, rarely the full amount.
     
    dold, Mar 5, 2014
    #1
    1. Advertisements

  2. dold

    miso Guest

    wrote:

    <sniP>

    I would first make sure you are not double NATed. That is, make the modem
    DMZ to your router. I'm not one to care about how a set up page looks old.
    The GUI doesn't really do much in the long run. [Don't even get me started
    on web 2.0]

    If you are a regular here, you will know I am not a fan of Netgear. I won't
    use their stuff if it was free. Actually I have turned down free Netgear
    stuff.
     
    miso, Mar 5, 2014
    #2
    1. Advertisements

  3. dold

    dold Guest

    I had to DMZ, because I have some ports mapped in through my router. That
    didn't work any more when I plugged in my router to one of the ports on the
    new router.

    I still wind up with double NAT, though. Outbound is passing through an
    extra translation, since the Cisco is a router.
    The features on the web page were lacking. I don't care how fancy it
    looks.
    The Cisco looks very nice, but the web pages are all in javascript, so I
    can't even fetch them via curl, or copy-paste information from some of
    them.
    I used to think several of the low end were interchangeable.
    I have grown unfond of Netgear now, with a WNR3000 and WNR1000 both
    failing. I just realized that I have a DLink DIR-655 in the garage that I
    replaced with the WNR3000 when I particpated in the SamKnows internet survey.

    Replacing the router was more trouble than I expected, and it's still not
    good. My Ubuntu box is unstable, and I am beginning to think it just
    coincidentally is failing.

    I counted some more, and I think I have 26 devices in my "Internet of
    things".

    What router do you like?
     
    dold, Mar 6, 2014
    #3
  4. dold

    miso Guest

    For unmanaged switches, I have a few Dlinks. However, Dlink has its share of
    detractors. I'm using the Dlink Green series. The particular models aren't
    make anymore. For a wifi router, I have a Buffalo G450 running DD-WRT. I've
    never had a defective Dlink device and never had one fail on me.

    You can go on Newegg and read reviews. There is always some wanker that got
    a DOA unit. Doesn't matter what brand. Filter that person out unless there
    are a lot of them. The thing with Newegg reviews is you look at what people
    don't like, i.e. specific complaints, and see if the problem would bother
    you. That is, the reviews give you something to read about, feature wise. If
    the review says "it sucks" and they aren't specific, ignore the review.

    While I hold netgear in total contempt, some people like their gear. I've
    have two Netgear wifi routers fail I just can't waste any more money on that
    shitty company. Remember, they were so shitty they had to change the name.
    I have to say this Buffalo G450 is the most reliable wifi router I ever
    owned. I never have to boot it. I never boot the switches either.
     
    miso, Mar 6, 2014
    #4
  5. dold

    dold Guest

    I buy a lot of stuff from NewEgg. I'm not sure why I have an affiinity
    towards them.
    I recall Jeff liking Buffalo, too. They seem so young, and I am so mired
    in the past.
     
    dold, Mar 6, 2014
    #5
  6. dold

    miso Guest

    Buffalo uses a lot of Broadcom chipsets. Broadcom makes good stuff. I'm just
    amazed at how that company has grown. If you drive around Silicon Valley,
    Broadcom is like the Borg. They are everywhere.

    All the Netgear wifi routers that I have ripped apart after they failed seem
    to marry some wifi module with an existing router. Broadcom makes the whole
    thing. They even make Arm processors. So the device tends to be better
    integrated.

    Times change. Routers are just chips and firmware. It isn't hard for someone
    to come along and make a mark since the market itself is so big.

    Netgear has started to use Broadcom in some routers, as well as Dlink. So
    possibly some Netgear stuff isn't shit, but then again, they peddle the
    crappiest wall warts. When a Netgear box fails, the first thing you check is
    the wall wart. But Linksys is equally bad in the wall wart arena.
     
    miso, Mar 6, 2014
    #6
  7. dold

    dold Guest

    Here's a feature of their web page that caused me grief.
    Because it is a router, the web interface appears on some variable IP
    address, let's call it 192.168.0.1, that I might change to some other
    address.
    Because it is a cable modem, it always appears at 192.168.100.1

    Accessing 192.168.100.1 from the Factory Reset allowed me to login in
    with username and password blank, and then I set values for that.

    Now, I can no longer log in on 192.168.100.1, although the appearance is
    identical to 192.168.47.250, my configured local address, where I can log in.
     
    dold, Mar 6, 2014
    #7
  8. dold

    dold Guest

    Is this the one?
    < http://www.newegg.com/Product/Product.aspx?Item=N82E16833162048 >
    BUFFALO AirStation HighPower N450 Gigabit DD-WRT Wireless Router -
    WZR-HP-G450H $83.99
     
    dold, Mar 7, 2014
    #8
  9. dold

    miso Guest

    Yes, though someone in the reviews claims this is one is not Broadcom based.
    Could be true since DD-WRT calls the wifi ath0.

    Some person claims he boots his 9 times a day. I have to laugh at that since
    I have a squeezebox that has been attached for 22 days. And I think that was
    because I disconnected the squeezebox to clean up.

    I will verify that the little bit of plastic that they call a stand is not
    wide enough if you use shielded cables, which are kind of stiff. It isn't a
    big deal, but the router is light and the cables push it around.

    Range? I set up the timing to restrict my range. I don't have any problems
    with range. It is high power. Speed? I don't bother with N since I just have
    plain old DSL. There are less N channels, and why be a bandwidth pig since
    it won't make any difference in the data rate to my phone and other devices.
     
    miso, Mar 7, 2014
    #9
  10. dold

    dold Guest

    Last one in the pool is a rotten egg.
    Over the last couple of days, what seems to be little steps of success are
    actually just vagaries of which devices are connected.

    I connected a couple of things to a DLink DIR-655 and discovered that it is
    not on the "same network" as the Cisco. There is no setting about "Network
    Isolation" in the Cisco. I have a LAN port from the Cisco going to a LAN
    port on the DLink, a technique I was using to extend the wireless range for
    a few years, but it doesn't work with the Cisco. Programs and apps that
    need to be "on the same network" don't work. DirecTV In-Home viewing shows
    that it is out-of-the-home, as does an HP scanner, and ePrint.
    The IP addresses are the same regardless of which WiFi I associate with,
    and the Cisco shows the WiFi connections of the DLink as being on a wired
    port of the Cisco.

    It seems that the Cisco DPC3925 can only handle 16 devices, LAN and WiFi.
    More devices than that connect and drop on WiFi, like a MAC filter is in
    place.

    Ubuntu is the only place I get a clue about the problem.
    wpa_supplicant[1538]: wlan0: CTRL-EVENT-CONNECTED - Connection to
    4c:72:b9:06:11:1b completed (reauth) [id=0 id_str=]

    wpa_supplicant[1538]: wlan0: CTRL-EVENT-DISCONNECTED
    bssid=4c:72:b9:06:11:1b reason=15
     
    dold, Mar 8, 2014
    #10
  11. dold

    dold Guest

    I tried to eliminate the router/wifi portion of the Cisco as much as
    possible, using it as if it were the old Cable Modem, and my DLink-DIR-655
    was my router and WiFi.

    The Cisco WiFi won't turn off!
    It says it is disabled, but it is still a visible SSID, it just won't
    connect anymore.

    I set a "DMZ" to the IP address of the DLink, after rearranging the wiring
    so that the DLink WAN is connected to a LAN port on the Cisco.
    That doesn't work, if the DLink is getting a DHCP address. I reserved it.
    It doesn't change. The DMZ accepted it, but it doesn't work. Nothing
    passes to it.
    And my very sensitive DirecTV gadgets still think they are "out of home".
    I can tell something is wrong because the GenieGo App shows an address of
    my 173 Internet address. When it is working, it shows my local 192
    address.
    I set the Cisco Port Forwarding to pass the needed ports to the DLink, and
    set the DLink to pass them to the appropriate places. That made some services
    work, but not the DirecTV.

    I turned off DHCP in the Cisco, set static addresses, and the DMZ. Now the
    DirecTV is happy, and my other services are happy.
     
    dold, Apr 5, 2014
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.