ipv6 and XDMCP

Discussion in 'Linux Networking' started by Captain Dondo, Jan 19, 2005.

  1. I'm setting up a network where logins happen via gdm + XDMCP. Everything
    works fine, except that all the Fedora Core 2 machines show up twice in
    the browser, once with their IPV4 name and IP address, and once with just
    the IPV6 address.

    This is really frustrating... I can't figure out how to turn off the
    ipv6 address in Fedora Core 2.

    Is there a way to prevent ifconfig (or the kernel) issuing out IPV6
    addresses? Do I need to turn off all of the IPV6 stuff in the kernel and
    recompile?

    Is there a setting somewhere that I've missed?

    TIA
     
    Captain Dondo, Jan 19, 2005
    #1
    1. Advertisements

  2. Captain Dondo

    Bit Twister Guest

    I know on Mandrakelinux you can read
    /etc/sysconfig/network-scripts/ifup
    to see what can controls can be used.

    For us,

    /etc/sysconfig/network and add the line
    NETWORKING_IPV6=no (note: add a carriage return)

    Update
    /etc/modules.conf and add the line
    alias net-pf-10 off (note: add a carriage return)

    if you do not have
    /etc/modprobe.conf and add the line
    alias net-pf-10 off (note: add a carriage return)
     
    Bit Twister, Jan 19, 2005
    #2
    1. Advertisements

  3. Captain Dondo

    ynotssor Guest

    You might try:

    In /etc/syscong/network
    NETWORKING_IPV6=no

    and in /etc/modprobe.conf
    # Turn off IPv6
    alias net-pf-10 off
    alias ipv6 off
     
    ynotssor, Jan 19, 2005
    #3
  4. <rant>

    From /etc/sysconfig/networking-scripts/ipv6-init.global:

    # NETWORKING_IPV6=yes|no: controls global IPv6 initialization (default: no)

    Note the default.... Nowhere was I able to find a line that says
    NETWORKING_IPV6=yes

    Clearly, the default has changed from Fedroa Core 1 to 2 and the docs have
    not kept pace...

    </rant>

    (I know, I should offer to update the documentation.....)

    Thanks for the pointers, guys. I'll make the changes when the computers
    wake up this morning....
     
    Captain Dondo, Jan 19, 2005
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.