How to run rcp over crossover cable on crude network config

Discussion in 'Linux Networking' started by linq936, Aug 13, 2005.

  1. linq936

    linq936 Guest

    Hi,
    I just installed Fedora Core 3 on my laptop and I selected network
    support in installing. This laptop is basically used for me to try out
    Linux. I will not use this laptop to connect to any network, the only
    use of its ethernet connection is for me to transfer some big files to
    other machine. And I have some problem here.

    I use a crossover cable to connect this laptop to my PC which is on
    my employer network, this PC is running Windows XP. I have cygwin
    installed on the PC.

    I name the laptop IP address as 1.2.3.4 when i installed Fedora,
    obviously such address is not accessible from PC, so I run this command
    to add it to the routing table of PC,

    Route add 1.2.3.4 mask 255.255.255.255 xxx.xxx.xxx.xxx metric 1 if 3

    "xxx.xxx.xxx.xxx" is the PC gateway address.

    Now from PC I ping 1.2.3.4 good, this basically tells me that IP
    connection between PC and laptop through crossover cable is good.

    Then I think I can run rcp to copy files, so in cygwin I run this,
    rcp file_1 1.2.3.4.my_login_in_laptop:

    But what I get is:
    1.2.3.4:Connection refused

    I check the web and it seems i need to set up ~/.rhosts in laptop, but
    isn't true that it is only needed if I do not want to input password?
    Anyway, I created the file in laptop and its content is simply as,
    + +

    this is to trust anyone on any machine, right?

    But rcp still has the same problem, connection refused.

    Is there any simple way to set up for rcp to run? I prefer not to
    bother about those dauting services like domain name resolution, you
    can see that my application is only a copy over crossover cable.

    Thanks.
     
    linq936, Aug 13, 2005
    #1
    1. Advertisements

  2. Is your firewall turned off?
     
    Allen McIntosh, Aug 13, 2005
    #2
    1. Advertisements

  3. Just try ssh (with scp) instead of rcp.

    Rainer
     
    Rainer Krienke, Aug 13, 2005
    #3
  4. linq936

    Bill Marcum Guest

    Is an rsh server running on the laptop? Is it even installed? You
    might try scp instead.
     
    Bill Marcum, Aug 13, 2005
    #4
  5. linq936

    Tauno Voipio Guest

    Install the SSH daemon on your laptop, and get the
    WinSCP utiliuty to the Windows computer.

    After the computers are connected and set up so they
    can ping each other, fire up WinSCP on the Windows
    computer, log in into the Linux computer and use
    the utility's window (much like any Windows file
    tool) to manage the files on either computer.
     
    Tauno Voipio, Aug 13, 2005
    #5
  6. My guess is that the rcp service is not running on the Fedora
    box. And I can't remember the name of this service. But rcp is
    regarded as insecure, and Fedora may not even contain server s/w
    for it.

    You may be better off using scp (secure copy) which is one of the
    features of ssh (secure shell). For Linux, ssh is the client
    program, and sshd (ssh daemon) is the server program. Fedora will
    certainly contain both of these, but sshd may not be started in a
    default install - you may have to start it yourself. You can find
    many ssh and scp clients for windows (putty and filezilla come to
    mind), but I don't now about ssh servers.

    If you're just trying to copy files, it might be easier to go to
    the Linux machine and mount the windows shared folders. I don't
    know which program Fedora supply for this though. Try entering:
    smb://xxx.xxx.xxx.xxx/C$
    into the konqueror address bar.

    The Cog
     
    Cantankerous Old Git, Aug 13, 2005
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.