hopefully simple ppp dns or routing problem on Slack 9.1

Discussion in 'Linux Networking' started by John Gabriele, Apr 21, 2004.

  1. I recently posted this on alt.os.linux.slackware, but I think it
    might be more relevant here:

    I'm just trying to get a simple desktop dialup setup working. I haven't set
    up any LAN. I'd like to be able to use ppp-on/off as a regular user, but for
    now I just want to get it working for root. I'm running a stock Slack 9.1
    install with bare.i.

    (Foreshadow: I'm beginning to think that this problem might have something
    to do with the fact that I've got an unused (but recognized) PCI ethernet
    NIC in my machine.)

    I've run netconfig and told it I just want to setup a loopback connection
    (for "modem or no net").

    I've run pppsetup and given it the usual input.

    I can run ppp-on as root and get my external modem to dialup and connect.
    /var/log/messages tells me:

    CONNECT
    -- got it
    Serial connection established.
    Using interface ppp0
    Connect: ppp0 <--> /dev/modem


    Once connected, If I try to ping the one dns IP in my /etc/resolv.conf,
    I get:

    connect: Network is unreachable


    If I try to ping something else

    ping www.osnews.com


    I get

    ping: unknown host www.osnews.com


    Trying to traceroute the IP of my DNS listed in /etc/resolv.conf

    traceroute: findsaddr: Can't find interface

    Running 'ifconfig -a' lists eth0, lo, and ppp0. In the ppp0 section,
    there's no "inet" or "UP" lines present like there are in the lo section.


    Some more (possibly relevant) info from my config files:

    /etc/resolv.conf:
    search my_isp.net
    nameserver 123.456.789.123

    /etc/host.conf:
    order hosts, bind
    multi on

    /etc/hosts:
    127.0.0.1 localhost
    127.0.0.1 me.example.net me

    /etc/networks:
    loopback 127.0.0.0
    localnet 127.0.0.0

    /etc/nsswitch.conf:
    # [snip] Everything says "files" except
    hosts: files dns

    Also, /etc/ppp/options mentions:
    defaultroute
    noipdefault

    Further -- once connected, "netstat -rn" output only lists that one line
    starting with 127.0.0.1 for the lo interface. That's the same as when I'm
    *not* connected.

    Maybe something to do with setting up a default route?

    Any help is appreciated. If there's a trick here, I'll be sure to notify
    the relevant developers of it. Thanks.

    --- remove zees if attempting to reply via email ---
     
    John Gabriele, Apr 21, 2004
    #1
    1. Advertisements

  2. You need networking enabled to create a PPP functional (networking)
    interface.

    No "UP, RUNNING" for the PPP interface means PPP no workie.

    --
    Clifford Kite Email: "echo |rot13"
    PPP-Q&A links, downloads: http://ckite.no-ip.net/
    /* "PPPoE has many advantages for DSL service providers, and
    practically none for DSL consumers."
    - David F. Skoll */
     
    Clifford Kite, Apr 21, 2004
    #2
    1. Advertisements

  3. Thanks for the reply Cliff. I'm not sure what you mean by "I need
    networking enabled", since I've got some /etc/rc.d/rc.inet* scripts
    that *are* getting run.

    I'm also getting some help on this where I originally posted it in
    alt.os.linux.slackware (subject: slack, help with simple ppp dialup).
    *** I probably should've given the post there a few days fermentation
    time before posting here and having duplication. :) ***

    Please direct any further interest to that thread. Thank you. (I don't
    yet have a solution, but am getting there.)
     
    John Gabriele, Apr 21, 2004
    #3
  4. You said:

    I've run netconfig and told it I just want to setup a loopback connection
    (for "modem or no net").

    To me that 'no net' meant 'no networking,' but looking at the netconfig
    scripts convinces me that it means no network card. I run Slackware,
    but it started life as 7.1 and has been upgraded whenever necessary.
    It's been something like four years since the install and it's doubtful
    that I've ever run netconfig, unless it was a part of the initial setup.

    Add the pppd option debug and the chat -v option. Run pppd and look
    in /var/log/debug and /var/log/messages for clues. Post exact copies
    (cut-and-paste) of the chat and pppd generated messages in those logs
    should you need more help.
    I've added the alt group to the follow-up part of the header, but
    any request for help from me should include this group, since the
    alt group is not one that I monitor. FWIW, I specialize in helping
    people with PPP problems.
     
    Clifford Kite, Apr 22, 2004
    #4
  5. After I run netconfig to configure my NIC (as if I was using it with a
    static IP on a LAN even though nothing is plugged into it), the only
    changes I see are in:

    1. /etc/hosts -- 127.0.0.1 me.example.net me ==>
    192.168.0.0 me.example.net me

    2. /etc/networks -- localnet 127.0.0.1 ==> localnet 192.168.0.0

    3. /etc/rc.d/rc.inet1.conf -- IPADDR[0] and NETMASK[0] now have values
    in them you'd expect (they were empty strings before).

    4. /etc/resolv.conf -- search my_isp.net ==> search example.net (which
    I see can't work (since I'm not running my own DNS server or even a
    LAN).

    No changes to /etc/rc.d/rc.inet1 or rc.inet2 -- which is where I'd expect
    to see a change if some part of the networking system was enabled.
    The ppp package I've got installed is ppp-2.4.1-i486-1. Looks there's a
    more current version available, but I don't have an easy way to get it
    on that machine (I'm typing this from my old PowerBook running OS X).
    No CD burner on this thing, and it won't read my ext2-formatted USB
    flash drive. Pfft! :)
    Yup. I've already uncommented that option in /etc/options.
    That's already being specified in /usr/sbin/ppp-go.
    I there, I see some messages from pppd saying things like:
    using channel 1
    using channel 2
    using channel 3
    using channel 4

    along with what seems like many ("message repeated 9 times"...) messages like:

    sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xd18d00f6> <pcomp> <accomp>]

    but those hex numbers after "magic" change.
    Well, since that machine can't connect to the net, and as I said, I can't
    get OS X to read ext2, I'm stuck hand-typing for now. But I'll type stuff
    in as best I can. :)
    I don't know what the follow-up header means, but I'm sending this
    to both alt.os.linux.slackware and comp.os.linux.networking.

    Hitting the "reply-all" button puts your email address in the "to"
    field, so I just hit "reply", it came up addressed to a.o.l.s, and
    I added the c.o.l.n address by-hand.
    Thank you very much. I'm glad I bumped into you. :)

    ---J
    --- if contacting via email, remove zees ---
     
    John Gabriele, Apr 22, 2004
    #5
  6. Hmm... /etc/ppp/ip-up isn't getting called.
     
    John Gabriele, Apr 22, 2004
    #6
  7. That's only done when PPP successfully completes IPCP negotiations.
    It never got past LCP negotiations so ip-up wasn't called.
     
    Clifford Kite, Apr 22, 2004
    #7
  8. I'll take that to mean that these lines appear in /etc/hosts:

    127.0.0.1 me.example.net me
    192.168.0.0 me.example.net me

    I don't think the first one is a good idea, but there will be some that
    agree with me and some that won't. I'd replace the first line with
    these two:

    127.0.0.1 localhost
    127.0.0.2 me.example.net me
    I'd prefer to replace the first with

    loopback 127.0.0.0

    But it's rather doubtful that the above configurations are related to
    your problem.
    The domain names are just examples and should be replaced by whatever
    the actual domains are. Just as "me.example.net me" is an example for
    the hosts file. You should to put your ISP domain name as a search
    argument in place of my_isp.net and the ISP DNS nameserver IP addresses
    need to be in resolv.conf. I'd recommend you buy the "Running Linux"
    book published by Dover - it should be worthwhile since you run Slackware.

    My /etc/resolv.conf contains:

    search ev1
    options attempts:5 rotate
    nameserver 216.88.76.6
    nameserver 216.88.77.7

    I'd suggest you read "man 5 resolver" for explanations of the options.
    Hmm. This is new to me, although the channel numbers likely refer to
    /dev/pts/{1,2,3,4} which are PPP device files.

    Do you have /dev/pts and /dev/ppp? The first is a device directory,
    not a file. You should see /dev/pts/{0,1,2,3,4} when connected.
    This is not new. Pppd quit after 10 attempts to start PPP negotiations
    with the peer, which apparently isn't responding in any way.
    I don't know what "OS X" is.

    Is there no way to transfer files from the problem host to the one with
    "OS X" except though an Internet connection? For example, with a floppy
    disk with an MS filesystem that both can read.

    If there's no way then please include the timestamps, which sometimes
    can provide a clue.

    That's it for this time around.
     
    Clifford Kite, Apr 22, 2004
    #8
  9. John Gabriele

    Bill Unruh Guest

    ]> Clifford Kite wrote:

    ]> After I run netconfig to configure my NIC (as if I was using it with a
    ]> static IP on a LAN even though nothing is plugged into it), the only
    ]> changes I see are in:

    ]> 1. /etc/hosts -- 127.0.0.1 me.example.net me ==>
    ]> 192.168.0.0 me.example.net me

    ]I'll take that to mean that these lines appear in /etc/hosts:

    ]127.0.0.1 me.example.net me
    ]192.168.0.0 me.example.net me

    ]I don't think the first one is a good idea, but there will be some that
    ]agree with me and some that won't. I'd replace the first line with
    ]these two:

    ]127.0.0.1 localhost
    ]127.0.0.2 me.example.net me

    I agree with Kite. The first address obtained will be the address used to get name to ip
    mapping. Thus me.example.net will always resolve to 127.0.0.1.


    ]> 4. /etc/resolv.conf -- search my_isp.net ==> search example.net (which
    ]> I see can't work (since I'm not running my own DNS server or even a
    ]> LAN).

    The search option is more or less useless. you do not need it. What you
    need is the nameserver lines to point to proper DNS IP resolvers, and
    MUST be IP addresses not names.




    ]>> and /var/log/messages for clues. Post exact copies
    ]>> (cut-and-paste) of the chat and pppd generated messages in those logs
    ]>> should you need more help.

    ]> Well, since that machine can't connect to the net, and as I said, I can't
    ]> get OS X to read ext2, I'm stuck hand-typing for now. But I'll type stuff
    ]> in as best I can. :)

    ]I don't know what "OS X" is.

    Macintosh operating system I assume.
    Put it onto a floppy.

    You could also try reading
    www.theory.physics.ubc.ca/ppp-linux.html
    which may give you hints as to how to hook up your ppp, and to debug the
    connection.

    It sounds to me like your pppd never dialing out and making the
    connection, or your ISP expects something you are not sending.

    YOur log with time stamps are crucial to figure this out.
     
    Bill Unruh, Apr 22, 2004
    #9
  10. Thanks for the continued replies Cliff. To make this less confusing,
    I'll refer to my actual computer, domain, and isp names (instead of
    the made-up "me" and the default (which is now changed) "example.net").
    I just edited /etc/HOSTNAME and /etc/hosts: My computer is now
    avocado.pinecountry.net. I ran Slack's netconfig again (using this
    new name when prompted) and then ran pppd's "pppsetup" utility again.

    While running netconfig, it asked what my gateway was, and said it
    was ok to leave it blank -- so I did.

    To briefly recap, before running ppp-go, "ifconfig -a" shows eth0 and
    lo only (both show up as being "UP").

    "route -n" tells me

    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

    *After* running ppp-go (during which I can hear and see (modem lights)
    the modem dialing up and negotiating), route -n tells me the same thing
    as it just did. "ifconfig -a" though shows ppp0 now listed after eth0 and
    lo but with no "UP" line (the eth0 and lo entries are the same as before).

    Ok, continuing...
    ^^^
    Nope. The lines I have in /etc/hosts are:

    127.0.0.1 localhost
    192.168.0.1 avocado.pinecountry.net avocado
    ^^^
    Ok, thanks. :) I've added that extra line, so now I've got three lines
    in there:

    127.0.0.1 localhost
    127.0.0.2 avocado.pinecountry.net avocado
    192.168.0.1 avocado.pinecountry.net avocado
    Check. Re-runnig the config programs has left me with 2 lines
    in that file:

    loopback 127.0.0.0
    localnet 192.168.0.0
    Sorry for the confusion. Since the above-mentioned renaming, my resolv.conf
    file now has in it:

    search bestweb.net
    nameserver 209.94.100.100

    since bestweb is my ISP.
    I'll have to have a look through the couch cushions and
    see if I can come up with the dough. :) I didn't realize
    that the book had substantial Slackware-related info.

    I figure you mean this one (4th edition)
    http://www.powells.com/cgi-bin/biblio?inkey=17-0596002726-0
    by Welsh, Kaufman, and Dalheimer -- though it's published by
    O'Reilly rather than Dover.
    Hmm... Ok, I added a 2nd nameserver line (since my isp provides 2,
    and the resolver man page you point out says I can have 3).
    Thanks for the pointer. I don't see any mention of the "attempts"
    variable for the "options" config option. Only "debug" or "ndots:n".
    When not connected I have /dev/pts/{0,1,2}. Same when I'm connected.
    These are, of course, just the three terminal windows I happen to have
    open right now.

    /dev/ppp is always

    crw-rw---- 1 root uucp 108, 0 Mar 25 2001 /dev/ppp

    "chat" just gives me the usual in /var/log/messages:

    .... [snip]

    OK
    -- got it
    send (atdt6632120^M)
    timeout set to 75 seconds
    expect (CONNECT)
    ^M
    atdt6632120^M^M
    CONNECT
    -- got it

    ------------- then pppd goes on to tell me:

    Serial connection established.
    Using interface ppp0
    Connect: ppp0 <--> /dev/modem

    with nothing about IP addresses (like mine and the ISP's gateway)
    getting set.

    How can I ask the system to tell me how authentication is going?
    I'd love to see something like "authentication failed/succeeded".
    Sorry. Macintosh OS X. The only other computer I have is a PowerBook G3
    running Apple's OS X operating system.
    The PowerBook has no floppy drive, and I have no external floppy drive.
    I've got a USB flash drive, but when I use OS X to format it (UFS or some
    Windows/DOS format), I can't read the thing in Linux -- and when I format it
    in Linux (ext2), I can't read the thing in OS X.

    I've got a CD burner in the x86 box, but since I've only recently installed
    Slack, I haven't yet even attempted to burn anything with it yet.

    Also, I've got a hub and some cables, but I haven't yet looked into what's
    necessary to make these 2 computers talk to each other.

    Ok, I'll attempt to copy/past some log file data to this thread.
    Which log files, specifically? /var/log/messages and /var/log/debug?
    Thanks for the help.
     
    John Gabriele, Apr 23, 2004
    #10
  11. Check. Made the change.
    Yup. I've got numbers in there. Sorry for the confusion.
    Thank you. I'll have a read.
    Ok, I'll uncomment the "debug" line in /etc/ppp/options and try
    to get something more. Are there other log files I need to be looking
    at besides /var/log/messages and /var/log/debug?

    Can I tell syslog (?) to log more stuff to those files?

    Thanks.
     
    John Gabriele, Apr 23, 2004
    #11
  12. John Gabriele

    Bill Unruh Guest

    ]Bill Unruh wrote:
    ]>
    ]> ] > Clifford Kite wrote:
    ]> ]
    ]> ] > After I run netconfig to configure my NIC (as if I was using it with a
    ]> ] > static IP on a LAN even though nothing is plugged into it), the only
    ]> ] > changes I see are in:
    ]> ] >
    ]> ] > 1. /etc/hosts -- 127.0.0.1 me.example.net me ==>
    ]> ] > 192.168.0.0 me.example.net me
    ]> ]
    ]> ] I'll take that to mean that these lines appear in /etc/hosts:
    ]> ]
    ]> ] 127.0.0.1 me.example.net me
    ]> ] 192.168.0.0 me.example.net me
    ]> ]
    ]> ] I don't think the first one is a good idea, but there will be some that
    ]> ] agree with me and some that won't. I'd replace the first line with
    ]> ] these two:
    ]> ]
    ]> ] 127.0.0.1 localhost
    ]> ] 127.0.0.2 me.example.net me
    ]>
    ]> I agree with Kite. The first address obtained will be the address used to get name to ip
    ]> mapping. Thus me.example.net will always resolve to 127.0.0.1.

    ]Check. Made the change.

    ]>
    ]> ] > 4. /etc/resolv.conf -- search my_isp.net ==> search example.net (which
    ]> ] > I see can't work (since I'm not running my own DNS server or even a
    ]> ] > LAN).
    ]>
    ]> The search option is more or less useless. you do not need it. What you
    ]> need is the nameserver lines to point to proper DNS IP resolvers, and
    ]> MUST be IP addresses not names.

    ]Yup. I've got numbers in there. Sorry for the confusion.

    ]>
    ]>
    ]> [snip]
    ]>
    ]> You could also try reading
    ]> www.theory.physics.ubc.ca/ppp-linux.html
    ]> which may give you hints as to how to hook up your ppp, and to debug the
    ]> connection.

    ]Thank you. I'll have a read.

    ]> It sounds to me like your pppd never dialing out and making the
    ]> connection, or your ISP expects something you are not sending.
    ]>
    ]> YOur log with time stamps are crucial to figure this out.

    ]Ok, I'll uncomment the "debug" line in /etc/ppp/options and try
    ]to get something more. Are there other log files I need to be looking
    ]at besides /var/log/messages and /var/log/debug?

    ]Can I tell syslog (?) to log more stuff to those files?

    Well, make sure you have
    daemon.*;local2.* /var/log/ppplog
    ^^^^^^ or whatever you want to
    call it-- maybe debug?

    and then do killall -1 syslogd.

    debug logs everything in the negotiations.
     
    Bill Unruh, Apr 23, 2004
    #12
  13. John Gabriele

    Bill Unruh Guest

    ]Clifford Kite wrote:

    ]Thanks for the continued replies Cliff. To make this less confusing,
    ]I'll refer to my actual computer, domain, and isp names (instead of
    ]the made-up "me" and the default (which is now changed) "example.net").
    ]I just edited /etc/HOSTNAME and /etc/hosts: My computer is now
    ]avocado.pinecountry.net. I ran Slack's netconfig again (using this
    ]new name when prompted) and then ran pppd's "pppsetup" utility again.

    ]While running netconfig, it asked what my gateway was, and said it
    ]was ok to leave it blank -- so I did.

    ]To briefly recap, before running ppp-go, "ifconfig -a" shows eth0 and
    ]lo only (both show up as being "UP").

    ]"route -n" tells me

    ] Destination Gateway Genmask Flags Metric Ref Use Iface
    ] 192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    ] 127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

    ]*After* running ppp-go (during which I can hear and see (modem lights)
    ]the modem dialing up and negotiating), route -n tells me the same thing
    ]as it just did. "ifconfig -a" though shows ppp0 now listed after eth0 and
    ]lo but with no "UP" line (the eth0 and lo entries are the same as before).

    Is there an address listed for ppp0?




    ] 127.0.0.1 localhost
    ] 127.0.0.2 avocado.pinecountry.net avocado
    ] 192.168.0.1 avocado.pinecountry.net avocado

    I would not have the second. Whenever you ask for the IP for avocado,
    127.0.0.2 will be returned (a loopback address).

    ] search bestweb.net

    The search line is usually pretty useless. It is what to use if you hand
    your computer just a single undotted name.

    ] nameserver 209.94.100.100

    Well, without a route to it, it is pretty useless.


    ]>>sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xd18d00f6> <pcomp> <accomp>]

    If yuo have those with no response then your ISP at the other end is not
    responding. We need to see the rest of the negotiations to see if it is
    your fault or the ISP's fault.


    ] OK
    ] -- got it
    ] send (atdt6632120^M)
    ] timeout set to 75 seconds
    ] expect (CONNECT)
    ] ^M
    ] atdt6632120^M^M
    ] CONNECT
    ] -- got it

    Are you sure there is nothing after the CONNECT

    ]------------- then pppd goes on to tell me:

    ] Serial connection established.
    ] Using interface ppp0
    ] Connect: ppp0 <--> /dev/modem

    ]with nothing about IP addresses (like mine and the ISP's gateway)
    ]getting set.

    Should not be yet. There is a bunch of negotiation yet to do (or debug
    output to be logged)



    ]How can I ask the system to tell me how authentication is going?
    ]I'd love to see something like "authentication failed/succeeded".

    You need the debug option and the above option in /etc/syslog.conf.



    ]Also, I've got a hub and some cables, but I haven't yet looked into what's
    ]necessary to make these 2 computers talk to each other.

    Ah. If you have ethernet cards on both, you should be able to make them
    see each other via the net.

    Set up your Linux to be say 192.168.1.1 and the Mac to be 192.168.1.2,
    run a null ethernet cable between them (or a regular one from each to
    the hub) and connect. Get ssh installed on the mac, make sure it is
    installed on your Linux machine, start sshd on the Linux, and then do
    scp from teh mac to the linux to copy over the files.



    ]> If there's no way then please include the timestamps, which sometimes
    ]> can provide a clue.

    ]Ok, I'll attempt to copy/past some log file data to this thread.
    ]Which log files, specifically? /var/log/messages and /var/log/debug?

    Wherever you put the debug output from pppd
    See the above line I suggest you put into /etc/syslog.conf
    If you use my line, then it is the output in /var/log/ppplog.
     
    Bill Unruh, Apr 23, 2004
    #13
  14. It helped me a lot and I still refer to it occasionally.
    My bad. It _is_ O'Reilly, the Dover slipped in because, long ago,
    it was a source of inexpensive but good books on subjects I was
    pursuing then.

    Mine is the first edition, but the versions since then should be good
    too and provide updated information.
    Maybe you need to update the man pages. Here they contain:

    attempts:n
    sets the number of times the resolver will send a
    query to its name servers before giving up and return-
    ing an error to the calling application. The default
    is RES_DFLRETRY (see <resolv.h> ).

    Actually the options are there to help keep DNS server lookups going
    until PPP comes up for IP when using demand dial-out. Otherwise the
    application that brought pppd to life will likely exit.
    I agree with Bill Unruh, there should be one more line at least:

    <date, ect>[<chat pid>]: send(<something>)

    The very last part of the chat configuration should read

    CONNECT \d\c

    or similar. Double escapes if on the chat command line.

    Not doing this could be causing the problem since otherwise, with some
    ISPs, you might get a login prompt or menu that ignores pppd's attempt
    at starting LCP negotiations.
    You will get that after the PPP negotiations finish authentication.
    You don't see anything now because negotiations don't get past the
    first stage, LCP (Link Control Protocol).
    That's likely to have a fairly steep learning curve.
    Bill Unruh's suggestion about a cross-over cable is good. Those should
    be bought (it's a pain to make one), are relatively inexpensive, and
    are easy to use.
    Follow Bill Unruh's recipe to create a log file that should contain all
    the messages. But they may be in /var/log/{debug,messages}, as they
    are here.
     
    Clifford Kite, Apr 23, 2004
    #14
  15. ....in /etc/syslog.conf I figure you mean. Ok, check.
    Whoops, I restarted the machine instead -- see notes below.
    Ok, hooked up the hub so now I can ssh into the Slack box from OS X. Neither scp nor
    rcp work for me, but I can cat files to the terminal window and copy/paste so that's
    good enough for now. :)

    Uncommented the "debug" line in both /etc/ppp/options and options.demand.
    Added the line:
    daemon.*;local2.* -/var/log/ppplog
    to my /etc/syslog.conf, then restarted stuff with
    root# cd /etc/rc.d
    root# ./rc.inet2 stop
    root# ./rc.inet1 stop
    root# ./rc.inet1 start
    root# ./rc.inet2 start
    touched /var/log/ppplog.
    Opened up three xterms to "tail -f" /var/log{messages,debug,ppplog}

    Hmm... nothing going to ppplog. Restarting the machine (forgot about Bill's
    "killall" advice)...

    Once restarted, the following log files show what happens when I run ppp-go.
    Note, once "connected", I try a couple of pings, wait about 20 seconds, then
    disconnect (with ppp-off at time: 14:00:03).

    [email protected]:~$ cat messages.txt
    Apr 23 13:47:46 avocado kernel: mice: PS/2 mouse device common for all mice
    Apr 23 13:47:46 avocado sshd[931]: Server listening on 0.0.0.0 port 22.
    Apr 23 13:47:56 avocado kernel: lp0: using parport0 (polling).
    Apr 23 13:52:14 avocado kernel: [drm] AGP 0.99 aperture @ 0xd0000000 64MB
    Apr 23 13:52:14 avocado kernel: [drm] Initialized mga 3.1.0 20021029 on minor 0
    Apr 23 13:52:18 avocado gconfd (john-1010): starting (version 2.4.0.1), pid 1010 user 'john'
    Apr 23 13:52:19 avocado gconfd (john-1010): Resolved address
    "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only config source at position 0
    Apr 23 13:52:19 avocado gconfd (john-1010): Resolved address
    "xml:readwrite:/home/john/.gconf" to a writable config source at position 1
    Apr 23 13:52:19 avocado gconfd (john-1010): Resolved address
    "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only config source at position 2
    Apr 23 13:52:30 avocado kernel: cdrom: This disc doesn't have any tracks I recognize!
    Apr 23 13:58:48 avocado kernel: CSLIP: code copyright 1989 Regents of the University of
    California
    Apr 23 13:58:48 avocado kernel: PPP generic driver version 2.4.2
    Apr 23 13:58:48 avocado pppd[1085]: pppd 2.4.1 started by root, uid 0
    Apr 23 13:58:49 avocado chat[1088]: timeout set to 60 seconds
    Apr 23 13:58:49 avocado chat[1088]: abort on (ERROR)
    Apr 23 13:58:49 avocado chat[1088]: abort on (BUSY)
    Apr 23 13:58:49 avocado chat[1088]: abort on (NO CARRIER)
    Apr 23 13:58:49 avocado chat[1088]: abort on (NO DIALTONE)
    Apr 23 13:58:49 avocado chat[1088]: send (AT&FH0^M)
    Apr 23 13:58:49 avocado chat[1088]: expect (OK)
    Apr 23 13:58:49 avocado chat[1088]: AT&FH0^M^M
    Apr 23 13:58:49 avocado chat[1088]: OK
    Apr 23 13:58:49 avocado chat[1088]: -- got it
    Apr 23 13:58:49 avocado chat[1088]: send (atdt6632166^M)
    Apr 23 13:58:50 avocado chat[1088]: timeout set to 75 seconds
    Apr 23 13:58:50 avocado chat[1088]: expect (CONNECT)
    Apr 23 13:58:50 avocado chat[1088]: ^M
    Apr 23 13:59:17 avocado chat[1088]: atdt6632166^M^M
    Apr 23 13:59:17 avocado chat[1088]: CONNECT
    Apr 23 13:59:17 avocado chat[1088]: -- got it
    Apr 23 13:59:17 avocado pppd[1085]: Serial connection established.
    Apr 23 13:59:17 avocado pppd[1085]: Using interface ppp0
    Apr 23 13:59:17 avocado pppd[1085]: Connect: ppp0 <--> /dev/modem
    Apr 23 14:00:03 avocado pppd[1085]: Terminating on signal 2.
    Apr 23 14:00:03 avocado pppd[1085]: Connection terminated.
    Apr 23 14:00:04 avocado pppd[1085]: Exit.
    [email protected]:~$


    [email protected]:~$ cat debug.txt
    Apr 22 22:15:33 avocado kernel: CPU: After generic, caps: 0183f9ff c1c7f9ff 00000000
    00000000
    Apr 22 22:15:33 avocado kernel: CPU: Common caps: 0183f9ff c1c7f9ff 00000000
    00000000
    Apr 23 13:01:01 avocado kernel: CPU: After generic, caps: 0183f9ff c1c7f9ff 00000000
    00000000
    Apr 23 13:01:01 avocado kernel: CPU: Common caps: 0183f9ff c1c7f9ff 00000000
    00000000
    Apr 23 13:14:39 avocado in.identd[1062]: started
    Apr 23 13:43:27 avocado pppd[1251]: using channel 1
    Apr 23 13:43:28 avocado pppd[1251]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic
    0xd83b4aaa> <pcomp> <accomp>]
    Apr 23 13:43:55 avocado last message repeated 9 times
    Apr 23 13:47:46 avocado kernel: CPU: After generic, caps: 0183f9ff c1c7f9ff 00000000
    00000000
    Apr 23 13:47:46 avocado kernel: CPU: Common caps: 0183f9ff c1c7f9ff 00000000
    00000000
    Apr 23 13:59:17 avocado pppd[1085]: using channel 1
    Apr 23 13:59:18 avocado pppd[1085]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic
    0xdd58b32e> <pcomp> <accomp>]
    Apr 23 13:59:46 avocado last message repeated 9 times
    [email protected]:~$



    [email protected]:~$ cat ppplog.txt
    Apr 23 13:52:10 avocado modprobe: modprobe: Can't locate module char-major-10-134
    Apr 23 13:52:14 avocado modprobe: modprobe: Can't locate module char-major-226
    Apr 23 13:52:14 avocado last message repeated 3 times
    Apr 23 13:58:48 avocado pppd[1085]: pppd 2.4.1 started by root, uid 0
    Apr 23 13:58:49 avocado chat[1088]: timeout set to 60 seconds
    Apr 23 13:58:49 avocado chat[1088]: abort on (ERROR)
    Apr 23 13:58:49 avocado chat[1088]: abort on (BUSY)
    Apr 23 13:58:49 avocado chat[1088]: abort on (NO CARRIER)
    Apr 23 13:58:49 avocado chat[1088]: abort on (NO DIALTONE)
    Apr 23 13:58:49 avocado chat[1088]: send (AT&FH0^M)
    Apr 23 13:58:49 avocado chat[1088]: expect (OK)
    Apr 23 13:58:49 avocado chat[1088]: AT&FH0^M^M
    Apr 23 13:58:49 avocado chat[1088]: OK
    Apr 23 13:58:49 avocado chat[1088]: -- got it
    Apr 23 13:58:49 avocado chat[1088]: send (atdt6632166^M)
    Apr 23 13:58:50 avocado chat[1088]: timeout set to 75 seconds
    Apr 23 13:58:50 avocado chat[1088]: expect (CONNECT)
    Apr 23 13:58:50 avocado chat[1088]: ^M
    Apr 23 13:59:17 avocado chat[1088]: atdt6632166^M^M
    Apr 23 13:59:17 avocado chat[1088]: CONNECT
    Apr 23 13:59:17 avocado chat[1088]: -- got it
    Apr 23 13:59:17 avocado pppd[1085]: Serial connection established.
    Apr 23 13:59:17 avocado pppd[1085]: using channel 1
    Apr 23 13:59:17 avocado pppd[1085]: Using interface ppp0
    Apr 23 13:59:17 avocado pppd[1085]: Connect: ppp0 <--> /dev/modem
    Apr 23 13:59:18 avocado pppd[1085]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic
    0xdd58b32e> <pcomp> <accomp>]
    Apr 23 13:59:46 avocado last message repeated 9 times
    Apr 23 13:59:49 avocado pppd[1085]: LCP: timeout sending Config-Requests
    Apr 23 14:00:03 avocado pppd[1085]: Terminating on signal 2.
    Apr 23 14:00:03 avocado pppd[1085]: Connection terminated.
    Apr 23 14:00:04 avocado pppd[1085]: Exit.
    [email protected]:~$
     
    John Gabriele, Apr 23, 2004
    #15
  16. [email protected] /home/john # route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo


    [email protected] /home/john # ifconfig -a
    eth0 Link encap:Ethernet HWaddr [*edited out by me*]
    inet addr:192.168.0.1 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:11 Base address:0x2000

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:2 errors:0 dropped:0 overruns:0 frame:0
    TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

    ppp0 Link encap:point-to-Point Protocol
    POINTOPOINT NOARP MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:1 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)


    [email protected] /home/john #

    Check. Commented it out.
    Check. Commented that line out.
    Thanks for the tips! As mentioned in my other post, I can now ssh from
    my laptop to the Slackware box. :)
     
    John Gabriele, Apr 23, 2004
    #16
  17. Ok, I added the options line to my /etc/resolve.conf, and with Bill's
    recent advice too, it now says:

    #search bestweb.net
    options attempts:5 rotate
    nameserver 209.94.100.100
    nameserver 209.94.100.200

    I restarted the machine and tried to connect again but still have
    the same problem.
    ???

    Hmm... this could be something. My /etc/ppp/pppscript just ends with that
    one CONNECT line. There's nothing funny after it. I've tried with and without
    a newline after it, but it (thankfully :) doesn't seem to make a difference.
    (Note -- I've been on a software project where a module was bombing because
    of an extra newline at the end of a config file. Yikes.)

    Wait... I think there's a space character after the word CONNECT. Ack, now
    how do I get vim to show me this file in hex...
     
    John Gabriele, Apr 23, 2004
    #17
  18. Unless these files have been modified and start/stop arguments added,
    they are equivalent to doing ./rc.inet? twice. This is Slackware..

    As you found out, logging didn't work without the "killall -1 syslogd"
    or rebooting (restarting?).
    The old Hayes standard defined H0 as a signal to the modem to hang up.
    But everything below looks okay for chat so either the definition has
    changed or is not accepted when appended to AT&F .
    PPP negotiation still doesn't get past LCP negotiation. It looks like
    the ISP simply didn't start PPP. If ending the chat script correctly
    doesn't work then do "killall -TERM pppd" and add the pppd option dryrun
    so we can see the options pppd actually uses. On restarting pppd the
    desired output is sent to the console and pppd should exit.
     
    Clifford Kite, Apr 23, 2004
    #18
  19. John Gabriele

    Walt R Guest

    **

    Here is the output of my route -n and ifconfig -a

    [email protected]_srv01:~ # route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    69.19.219.148 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
    127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
    0.0.0.0 69.19.219.148 0.0.0.0 UG 0 0 0 ppp0

    It looks like you are connected to the modem, but not to the server.
    you are missing the IP address on the ppp0 interface.


    [email protected]_srv01:~ # ifconfig -a
    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:30 errors:0 dropped:0 overruns:0 frame:0
    TX packets:30 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:1500 (1.4 Kb) TX bytes:1500 (1.4 Kb)

    ppp0 Link encap:point-to-Point Protocol
    inet addr:66.81.27.54 P-t-P:69.19.219.148 Mask:255.255.255.255
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1524 Metric:1
    RX packets:1724 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1274 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:1757393 (1.6 Mb) TX bytes:284191 (277.5 Kb)

    Have you uncommented the debug in the /etc/ppp/options script?
    This will give you extensive error messages.
    Walt R.
     
    Walt R, Apr 23, 2004
    #19
  20. Thanks! I was pretty pleased with myself! :)
    Whoops. Correct you are. Although /etc/rc.d/rc.inet1 accepts start/stop
    args, rc.inet2 does not (it just ignores any you pass it).
    Sorry for the sloppy language: I rebooted (since I wasn't exactly sure
    if /etc/rc.inet1 stop, then start restarted everything.

    Right. Should've writted "Rebooting" instead of "Restarting".
    Ok, I removed the H0 from that line in /etc/ppp/pppscript so now
    it just reads

    "" "AT&F"

    Restarted networking by running "/etc/rc.d/rc.inet1 stop" then again
    with "start". Tried dialing up but still the same problem, so I'm putting
    the H0 back in.
    Hm? Everything seems to end just fine when I run /usr/sbin/ppp-off.
    That line above that says "Terminating on signal 2." is what happens
    when I run ppp-off.
    # killall -TERM pppd
    pppd: no process killed
    Hmm... well, there's a line in the ppp-go script that includes:

    /usr/sbin/pppd -detach connect "/usr/sbin/chat -v -f /etc/ppp/pppscript" &

    so I figure what you mean is, that I should just run a line like that, but
    with the dryrun option (and without backgrounding it). Doing that yields
    (on the command line where I ran the command from):


    [email protected] /etc/ppp # pppd -detach connect \
    "/usr/sbin/chat -v -f /etc/ppp/pppscript" dryrun

    pppd options in effect:
    debug # (from /etc/ppp/options)
    -detach # (from command line)
    dryrun # (from command line)
    name # (from /etc/ppp/options)
    /dev/modem # (from /etc/ppp/options)
    115200 # (from /etc/ppp/options)
    lock # (from /etc/ppp/options)
    connect /usr/sbin/chat -v -f /etc/ppp/pppscript # (from command line)
    crtscts # (from /etc/ppp/options)
    modem # (from /etc/ppp/options)
    asyncmap 0 # (from /etc/ppp/options)
    passive # (from /etc/ppp/options)
    noipdefault # (from /etc/ppp/options)
    defaultroute # (from /etc/ppp/options)
    [email protected] /etc/ppp #



    (note, I'm spam-proofing my email address for the newsgroup posting, even
    though in real life my correct email address is being used) and this in
    /var/log/ppplog:

    Apr 23 18:32:58 avocado pppd[1219]: pppd options in effect:
    Apr 23 18:32:58 avocado pppd[1219]: debug^I^I# (from /etc/ppp/options)
    Apr 23 18:32:58 avocado pppd[1219]: -detach^I^I# (from command line)
    Apr 23 18:32:58 avocado pppd[1219]: dryrun^I^I# (from command line)
    Apr 23 18:32:58 avocado pppd[1219]: name ^I^I# (from /etc/ppp/options)
    Apr 23 18:32:58 avocado pppd[1219]: /dev/modem^I^I# (from /etc/ppp/options)
    Apr 23 18:32:58 avocado pppd[1219]: 115200^I^I# (from /etc/ppp/options)
    Apr 23 18:32:58 avocado pppd[1219]: lock^I^I# (from /etc/ppp/options)
    Apr 23 18:32:58 avocado pppd[1219]: connect /usr/sbin/chat -v -f /etc/ppp/pppscript^I^I#
    (from command line)
    Apr 23 18:32:58 avocado pppd[1219]: crtscts^I^I# (from /etc/ppp/options)
    Apr 23 18:32:58 avocado pppd[1219]: modem^I^I# (from /etc/ppp/options)
    Apr 23 18:32:58 avocado pppd[1219]: asyncmap 0^I^I# (from /etc/ppp/options)
    Apr 23 18:32:58 avocado pppd[1219]: passive^I^I# (from /etc/ppp/options)
    Apr 23 18:32:58 avocado pppd[1219]: noipdefault^I^I# (from /etc/ppp/options)
    Apr 23 18:32:58 avocado pppd[1219]: defaultroute^I^I# (from /etc/ppp/options)
    Apr 23 18:32:59 avocado pppd[1219]: Exit.
    Yup.

    One thing to note is how my ISP requires that I use my email address (username
    plus their domain name) to login with. Though, not sure if that might be an
    issue here.

    Oh, and that character after CONNECT in my pppscript was just a space. I removed
    it. No change.

    I'm still reading Bill's "How to Hook up PPP in Linux" doc.
     
    John Gabriele, Apr 23, 2004
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.