help - static arp entries disappear on reboot

Discussion in 'Windows Networking' started by SlickRCBD, Dec 12, 2006.

  1. SlickRCBD

    SlickRCBD Guest

    I tried to assign a static arp entry for my router using the arp -s
    command at the command prompt. According to the help blurb (arp /?) "the
    entry is permanent". Yet upon reboot it changes back to a dynamic entry
    for the router, and no entry for the other (Macintosh) computer on the
    network (which doesn't need a static entry but I put in for testing
    purposes).

    How can I correct this so there it persists after a reboot? I tried
    adding the line to autoexec.bat but it told me that arp can't be run in
    MS-DOS mode. It seems like a major flaw for a static entry to diappear
    on a client OS like windows 98 after a reboot, as clinets are routinely
    shut down at the end of the day, so I suspect I'm doing something wrong
    or some configuration is locked.
     
    SlickRCBD, Dec 12, 2006
    #1
    1. Advertisements

  2. SlickRCBD

    Franc Zabkar Guest

    Try adding the arp command to an appropriate .bat file and place a
    link to it in your C:\Windows\Start Menu\Programs\StartUp folder.

    Otherwise try adding arp to your registry at ...

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run

    Or try adding it to winstart.bat in your %windir% (this probably won't
    work).

    - Franc Zabkar
     
    Franc Zabkar, Dec 12, 2006
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.