help, pretty please, with linux on top. CUPS WOES! cant print

Discussion in 'Linux Networking' started by Rob \ the nut \, Jul 18, 2004.

  1. Hi.


    I have just installed mandrake 7.2 on a older system. I tried
    installing the latest version 10.0 but failed , perphaps due to the
    low system power. its a pentium 150mhz 16 megs of ram. It currently
    runs on console only.

    Currently I have setup, samba on the system, and I am able to share
    files with my XP home edition.

    However, I am not able to print.

    I tried using the CUPS admin web tool via explorer on my XP box.
    http://192.168.0.2:631. There was no printer added according to cups,
    so I tried to add a printer. However, after the inital quesions such
    as printer name and location, it wants to know to what device the
    printer is attached to. When I click on the pulldown menu, there are
    no devices at all! LPO or anything else for that matter are simply not
    there.


    If i check my /etc/cups/ I see a printer.conf file. here it is

    # Printer configuration file for CUPS v1.1.4
    # Written by cupsd on Sat Jul 17 09:35:15 2004
    <DefaultPrinter Panasonic>
    Info Linux Box Dot Matrix
    Location Linux Box
    DeviceURI parallel:/dev/lp0
    State Idle
    Accepting Yes
    JobSheets none none
    </Printer>


    According to the conf file above, the printer is installed and
    accepting jobs. However, the only time I ever got cups ADMIN to work,
    it didnt show listed the panasonic printer.

    I can print directly to the printer via the console by typing the
    follwing command

    ls >/dev/lpo

    it will print. So the LP0 port drivers and hardware are operational.

    What else can I do to make it work under cups?
     
    Rob \ the nut \, Jul 18, 2004
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.