help: 8139 network card

Discussion in 'Linux Networking' started by TheRG, Oct 1, 2006.

  1. TheRG

    TheRG Guest

    Hi all,

    My Linux box has one 8139 card, but needs some tricky booting.

    When it boots straight into Linux, no network services are available,
    even a trivial ping fails miserably ("host unreachable").

    Booting Windows first, then rebooting Linux again -without turning
    power off- and voilà!, networking magically appears.

    I guess Windows initializes something that Linux needs later, so
    the question is: how do I tell Linux to do it itself?

    Thanks in advance

    TheRG
     
    TheRG, Oct 1, 2006
    #1
    1. Advertisements

  2. Is it a real 8139, or a clone, and what module (rtl8139 or 8139too)?
    Some Linux versions might try to use rtl8139 for clones which might not
    work if 8139too is the proper module. I had trouble with Dlink DFE-530TX+
    nics going into a frenzy with heavy packet loss (using 8139too, when auto
    system use of rtl8139 did not work). My only solution in that case was to
    force 10baseT (using mii-tool -A 10BaseT-FD,10baseT-HD eth0, full-duplex
    worked).
    I used to have trouble booting directly from Windows to Linux because
    Windows seemed to not reset the nic to a state that Linux could use. But
    now it seems to be the other way around. If I warm boot from Linux to
    Windows, Win XP does not see my nic (have to shutdown and cold boot).
     
    David Efflandt, Oct 5, 2006
    #2
    1. Advertisements

  3. TheRG

    TheRG Guest

    Yes, the module used is 8139too. The NIC is a Skintek SK-220TX, its
    chipset label has two words: "RTL8139D" and "28106S1".

    I tried also with a similar card, one Edimax that claims to work
    with Linux, chipset labeled "RTL8139D" and "25144S1". Both behave
    exactly the same way, i.e. need Windows warm start first.

    This is what lspci says about both NICs:

    01:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
    RTL-8139/8139C (rev 10)

    and this is what mmi-tool -v reports:

    eth0: 10 Mbit, half duplex, no link
    product info: vendor 00:00:00, model 0 rev 0
    basic mode: 10 Mbit, half duplex
    basic status: no link
    capabilities:
    advertising:

    Changing "PnP OS" settings did not help either: "NO" and "YES"
    have both the same effect. Did you try it in your machine?

    The only way I can do a cold boot directly into Linux is to reset
    the BIOS's ESCD data. Trouble is, you have to tweak CMOS settings
    every time you cold-boot (yes, it's faster than booting Windows
    first, but it forces you to be in front of the keyboard).

    Thanks,

    JL
     
    TheRG, Oct 9, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.