GPRS card connected to the GPRS network in Linux 2.6.15, can send SMS messages, but still no interne

Discussion in 'Linux Networking' started by D2army, Feb 16, 2006.

  1. D2army

    D2army Guest

    Hi there,

    I have managed to get the Sony Ericsson GPRS GC89 card to connect to the
    T-Mobile GPRS network in Linux 2.6.15 and I got messages like these from
    pppd :

    <beginning of messages from pppd>


    Starting GPRS connect script...

    Setting the abort string

    Initializing modem
    AT+cfun=1
    OK
    AT+cfun=1
    OK
    AT+cgreg=1
    OK
    Setting APN


    +CGREG: 5
    AT
    OK
    AT+CGDCONT=1,"IP","internet3.voicestream.com"
    OK
    Dialing...

    AT+CGDCONT=2,"IP","internet3.voicestream.com"
    OK
    ATD*99***1#
    CONNECTSerial connection established.
    using channel 4
    Using interface ppp0
    Connect: ppp0 <--> /dev/ttyS4
    sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xbdf9233d> <pcomp> <accomp>]
    rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xbdf9233d> <pcomp> <accomp>]
    sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xbdf9233d> <pcomp> <accomp>]
    rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xbdf9233d> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x60 <mru 1500> <asyncmap 0x0> <auth pap> <magic
    0x30bfe8> <pcomp> <accomp>]
    No auth is possible
    sent [LCP ConfRej id=0x60 <auth pap>]
    rcvd [LCP ConfReq id=0x61 <mru 1500> <asyncmap 0x0> <magic 0x30bfe8> <pcomp>
    <accomp>]
    sent [LCP ConfAck id=0x61 <mru 1500> <asyncmap 0x0> <magic 0x30bfe8> <pcomp>
    <accomp>]
    sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15>]
    sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns3
    0.0.0.0>]
    rcvd [LCP ProtRej id=0x62 80 fd 01 01 00 0c 1a 04 78 00 18 04 78 00]
    rcvd [IPCP ConfReq id=0x60 <addr 72.250.5.0> <compress VJ 0f 01>]
    sent [IPCP ConfRej id=0x60 <compress VJ 0f 01>]
    rcvd [IPCP ConfNak id=0x1 <addr 72.250.5.8> <ms-dns1 66.94.9.120> <ms-dns3
    66.94.25.120>]
    sent [IPCP ConfReq id=0x2 <addr 72.250.5.8> <ms-dns1 66.94.9.120> <ms-dns3
    66.94.25.120>]
    rcvd [IPCP ConfReq id=0x61 <addr 72.250.5.0>]
    sent [IPCP ConfAck id=0x61 <addr 72.250.5.0>]
    rcvd [IPCP ConfAck id=0x2 <addr 72.250.5.8> <ms-dns1 66.94.9.120> <ms-dns3
    66.94.25.120>]
    not replacing existing default route to eth0 [192.168.1.1]
    local IP address 72.250.5.8
    remote IP address 72.250.5.0
    primary DNS address 66.94.9.120
    secondary DNS address 66.94.25.120
    Script /etc/ppp/ip-up started (pid 10848)
    Script /etc/ppp/ip-up finished (pid 10848), status = 0x0

    </end of connection messages>


    My connect script for pppd looks like:

    ###########################################
    /dev/ttyS4
    57600
    lock
    crtscts
    methods
    modem
    defaultroute
    user ""
    password ""

    noipdefault
    usepeerdns
    novj
    noauth
    persist
    debug
    nodetach
    ipcp-max-configure 20
    maxfail 0
    connect "/usr/sbin/chat -v -V -t3 -f /etc/ppp/peers/chat-gprs"



    So I apparently I have an ip address for my "ppp0" device in ifconfig:

    ppp0 Link encap:point-to-Point Protocol
    UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
    RX packets:6 errors:0 dropped:0 overruns:0 frame:0
    TX packets:11 errors:0 dropped:2 overruns:0 carrier:0
    collisions:0 txqueuelen:3
    RX bytes:190 (190.0 b) TX bytes:511 (511.0 b)


    But I am apparently still not on the internet. Pinging anywhere doesn't
    work. However, I can successfully send SMS messages when I log onto the card
    using minicom and playing around with AT commands

    I was hoping to consult with everyone on what might be the problem here. Did
    I miss a specific step?

    Thanks in advance!
    I.S.
     
    D2army, Feb 16, 2006
    #1
    1. Advertisements

  2. D2army

    Aniruddha Guest

    Using interface ppp0
    I think the problem is pppd is not replacing default route on your
    system. Look at log "not replacing existing default route to eth0
    [192.168.1.1]".

    Try adding options "defaultroute" and "replacedefaultroute" to your
    pppd configuration
     
    Aniruddha, Feb 16, 2006
    #2
    1. Advertisements

  3. D2army

    wild bill Guest

    Have you looked through the Sony Ericsson AT Commands manual and
    properly set up your card to connect with your service provider?

    http://www.cepag.de/GC85_GC89/PC Cards AT Commands_Rev B.pdf

    Covers: GC75 GC79 GC82 GC83 GC85 and GC89 (and probably a lot more!)

    Bill
     
    wild bill, Feb 16, 2006
    #3
  4. D2army

    Sven Geggus Guest

    how does your routing table (route -n) look like after the ppp connection
    has been established?

    Sven
     
    Sven Geggus, Feb 16, 2006
    #4
  5. D2army

    M.Kmann Guest

    where is the IP?
     
    M.Kmann, Feb 16, 2006
    #5
  6. D2army

    D2army Guest

    Hi Sven

    yes, it is indeed a problem with the routing table, thanks. The connection
    process is unable to modify the routing table for some reason when my
    Ethernet is plugged in or enabled. I disabled the Ethernet, re-ran the
    connection script, the routing table does gets modified and now the
    connection works. :)

    However, the connection is rather unstable for some reason. I observed that
    if the network bandwidth gets too high(like around 113kbps) , the modem will
    hang up and the connection will terminate. Then if the script tries to
    reconnect and gets to the point of executing the AT+CGDCONT commands, I see
    a CME Error 3 which means operation not allowed. I will then minicom to the
    card and then try to do AT+CFUN=1 to reset the card, but after I execute
    that command, everything else i execute afterwards will give a CME Error 513
    which means Link Layer Error apparently

    I am wondering if this has something to do with how I wrote my Connection
    Script. The card connection is not this unstable when used in XP.
     
    D2army, Feb 16, 2006
    #6
  7. Unless I'm mistaken, your "AT+CGDCONT" needs to be executed once
    only, when you first set your device up for your particular
    carrier. That setting should then persist through sessions and
    power-ups indefinitely.

    John
     
    John Henderson, Feb 16, 2006
    #7
  8. D2army

    D2army Guest

    Hi John

    I believe you are right, but when pppd is going to do a reconnection after
    getting disconnected, it will just call the same connect script. This means
    those AT+CGDCONT commands will inevitably get called again.

    Is it possible to just jump straight to dialing ( "ATD*99***1#" ) during a
    reconnection? Is this the right thing to do anyway?

    Thanks!
    I.S.
     
    D2army, Feb 17, 2006
    #8
  9. That's what I do (Linux kppp dialer). Otherwise only an "ATZ"
    command gets executed in my GPRS setup (Wavecom external modem
    attached to /dev/ttyS0).

    John
     
    John Henderson, Feb 17, 2006
    #9
  10. D2army

    D2army Guest

    Yea, ATZ attempts to restore the card to the factory settings.

    But sometimes if I get disconnected, and then I try to even do ATZ, I still
    get a CME Error 513

    By the way, is there a GUI version of a ppp program for Gnome? I think KPPP
    is for KDE

    Thanks
     
    D2army, Feb 19, 2006
    #10
  11. Just in case it matters at some stage, "ATZ" restores the
    default configuration (which needn't be factory defaults - you
    can make certain changes, and use "AT&W" to write them).
    "AT&F" is the command to reset to factory defaults.
    Have you tried the "AT+CGACT?" command to check your attachment
    status? Or the "AT+CGACT=0,1" command to specifically
    deactivate the current session prior to trying again?
    I didn't find one when I looked around on my system for it some
    time ago. I'm fairly sure I read about something once though.
    Maybe someone else knows.

    John
     
    John Henderson, Feb 19, 2006
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.