FQDN - why does the problem below arise at all?

Discussion in 'Linux Networking' started by Doug Laidlaw, Feb 9, 2004.

  1. Doug Laidlaw

    Doug Laidlaw Guest

    I recently installed Mandrake 9.2. Because I run Leafnode, I have
    given my computer a fully qualified domain name. In Mandrake, there
    is no file /etc/hostname, only /etc/hosts. On this occasion, I
    omitted to include the new name in /etc/hosts. This stopped
    gtk-gnutella from working properly. The application would open but
    not run, and I had to use Ctrl-C to close it. I was wondering
    whether there was some problem with a graphics library, until strace
    showed that it was trying to connect to my FQDN. Updating /etc/hosts
    solved the problem completely. I use KDE, but the same thing happens
    with GNOME users who don't do the same.

    My question is: why does the program even imagine that it has to
    connect to the hostname in the first place? Isn't it just internal
    housekeeping?

    Doug.
     
    Doug Laidlaw, Feb 9, 2004
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.