eth0: unknown interface: No such device

Discussion in 'Linux Networking' started by tom, Oct 31, 2003.

  1. tom

    tom Guest

    I am getting the message:

    eth0: unknown interface: No such device

    when I boot up.

    This computer was in mothballs for a while, but it also
    has windows on it and the computer networks under
    windows.

    As I remember this computer was set up to network
    under Linux also using Samba. The one change is that
    it was 10baseT network previous but that should not
    matter as the card works under windows. Should it?

    Where do I go from here if I want to get the network
    card on this old ancient computer working?

    Networking must be compiled into the kernel if I am
    getting the eth0 unknown message I assume?
     
    tom, Oct 31, 2003
    #1
    1. Advertisements

  2. Hi,

    most likely your kernel is not recognizing the card. If you can boot into
    Windows and see what make/model you have and post it here, it would help.
    Afterwards, you can compile the network card support into the kernel or as
    a module and things should get recognized, hopefully.

    Cheers,
    Ognen
     
    Ognen Duzlevski, Oct 31, 2003
    #2
    1. Advertisements

  3. I just went through a similar problem where a generic NIC worked without a
    problem in Windows but was not recognized in Linux. My solution was a
    modified Tulip driver ( from Donald Becker) that is part of a driver package
    you can find here:

    http://www.scyld.com/network/updates.html#release

    You may find what you need there as well. Good luck.

    Glenn Butzlaff
     
    Glenn Butzlaff, Nov 1, 2003
    #3
  4. You have to load a driver (module) for the card.
    Which means exactly nothing.
    Bullshit. Whether anything works under Windoze (or not, as is usually
    the case) does not have anything to do with it working under Linux.
    As for concluding that SINCE it worked as 10mbit under Windoze AND it
    happened to also work under Linux THEN that must mean that it will now
    work under Linux BECAUSE it works under Windoze - you'd better kill
    your logic teachers and start high school over again - that's horrible
    reasoning no matter what the subject.
    Load the module for the card.

    First, know what the card is - if it's a PCI card, a simple "lspci" will
    tell you the make & model, if it's ISA you'll have to run "pnpdump" and
    a few other utils to get it to work.

    Second, load the module for this card with "modprobe modulename".

    Check that it's loaded with "lsmod".

    Then try to get the interface up again - should work perfectly.
    Nope, completely wrong again.
    IF te driver for this particular card was compiled into the kernel it
    would work out of the box, but it doesn't, so it isn't.

    Ergo, you have to load the module for it.

    "Networking" - as in Ethernet and TCP/IP v4 networking - is definitely
    built into the kernel, but that has nothing to do with any particular
    hardware you might have; it only means that without it a network card
    would be useless.
     
    Jeroen Geilman, Nov 2, 2003
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.