DI-524 router having problems acquiring network address

Discussion in 'Wireless Internet' started by google, Mar 26, 2006.

  1. google

    google Guest

    Hi,

    I upgraded the firmware on my D-Link DI-524 router yesterday. I am
    using 5.20C at this point. I also changed from WPA to WPA2-PSK.

    I am running on Windows XPon a Toshiba notebook. What I'm finding now
    is that when I try to get a connection, the wireless card gets stuck on
    the "Acquiring Network Address" / "Renewing your IP address" stage of
    connecting.

    What I also notice is that if I plug in to the LAN directly, the
    wireless network at that point seems to acquire the address
    successfully.

    Any idea what might be happening?

    Thanks,
    Steve
     
    google, Mar 26, 2006
    #1
    1. Advertisements

  2. hath wroth:
    Yep. That's an encryption key mismatch failure. Try going back to
    WPA-PSK and see if that works. This would be a good time for you to
    test ALL the various encryption modes to see which ones work and which
    ones do not.
    No-encryption
    WEP64
    WEP128
    WPA-PSK
    WPA2-PSK-TKIP
    WPA2-PSK-AES
    My crystal ball tells me that some of the WPA2 modes may not work on
    your setup.

    Also, check if you have the latest greatest WPA update from
    Microsloth.
    http://support.microsoft.com/default.aspx?scid=kb;en-us;815485
    You probably have this unless you're running a pre-SP2 version of
    Windoze XP.
    Good test for the DHCP server, but not for the wireless encryption.
     
    Jeff Liebermann, Mar 26, 2006
    #2
    1. Advertisements

  3. google

    google Guest

    Thanks for your repsonse, Jeff.

    My router has the option to use WPA2 for Security and it offers PSK or
    EAP.

    I'm pretty sure I have the latest WPA update since I installed the WPA2
    stuff yesterday.

    In Windows as far as I can tell I have to choose either WPA2-PSK-TKIP,
    WPA2-PSK-AES, WPA2-TKIP, or WPA2-AES.

    I don't see an option to use just WPA-PSK as you described.

    Regards,
    Steve
     
    google, Mar 26, 2006
    #3
  4. On 26 Mar 2006 09:56:08 -0800, in alt.internet.wireless ,
    Disable all security, and try again. If it worries you, unplug the
    router from the internet while doing this test.
    Huh? Not sure what you mean by plugging the wireless unit into the lan
    directly...
    Mark McIntyre
    --
     
    Mark McIntyre, Mar 26, 2006
    #4
  5. hath wroth:
    I don't have a DI-524 (what hardware version?) in front of me. The
    online emulator at:
    http://support.dlink.com/emulators/di524/h_wireless.html
    shows only a much older firmware. Digging through the Dlink web pile,
    I find the latest US versions are:
    E1 5.00
    D1 4.00
    C1 3.24
    A1 1.21
    None of these correspond to your 5.20C version. If you are NOT in the
    US, please disclose your country and exact model number.

    The wireless settings should be on the above mentioned URL. As I
    vaguely recall, you should have a choice between WPA and WPA2.
    However, as I don't have such a unit, I can't verify this.

    As for:
    "In Windows as far as I can tell I have to choose either
    WPA2-PSK-TKIP, WPA2-PSK-AES, WPA2-TKIP, or WPA2-AES."
    could you be a bit more specific as to what Windoze mutation you're
    using, to what service pack level, whether you're using Windoze
    Wireless Zero Config, or Config-Free from Toshiba, or the
    manufacturers drivers? The model number of the Toshiba should be
    helpful. My guess (reading between your lines) is that you're using
    Config-Free which should give you WPA-PSK or WPA1 as an option.
    However, I don't have Config-Free handy so I'm guessing from memory
    again.
     
    Jeff Liebermann, Mar 26, 2006
    #5
  6. google

    google Guest

    Sorry what I mean is that my notepad has a wireless adapter as well as
    an ethernet port. If I plug into the ethernet port it does connect to
    the router. Once I connect via this method, the wireless connection
    also succeeds. Otherwise it stalls at the "Acquiring network address"
    point.

    What I have been able to do a few times is just authenticate this way
    and then unplug (thereby dropping the hardwire connection) and use the
    wireless connection.

    I haven't tried disabling all security altogether I will try and give
    that a shot, tho it won't really solve my problem.

    I have done stuff like disable my static dhcp's. This all worked fine
    before I went to 3.20!

    Thanks for your help.

    Steve
     
    google, Mar 26, 2006
    #6
  7. google

    google Guest

    Hi Jeff,

    Hmm. Well we seem to be looking in slightly different places. I'm
    looking here:

    http://support.dlink.com/products/view.asp?productid=DI-524_revC

    I don't see a version 3.24 there. I only have version 3.20. I am in
    Canada. Not sure if that makes a difference.

    Here is the firmware date as it appears in the router: Firmware
    Version: 3.20 , Thu, 18 Aug 2005

    I'm running Windows XP SP2. I'm not using Config-Free. I am using the
    wireless configuration interface built into Windows XP.

    The Toshiba Model No. doesn't exist in the US, but it's a 1.6 GHz
    Centrino. I noticed that the DI-524A model had a fix for Centrino
    processors, but the C model which I use doesn't use this.

    Thanks again for your help.

    Steve
     
    google, Mar 26, 2006
    #7
  8. hath wroth:
    It does. You should be using this web pile:
    http://www.dlink.ca
    http://support.dlink.ca/ProductView.asp?ProdID=356
    That would be the C1 hardware version. Please look at the serial
    number tag on your DI-524 for the hardware version number.

    Also note that you posted:
    "I upgraded the firmware on my D-Link DI-524 router yesterday.
    I am using 5.20C at this point. I also changed from WPA to
    WPA2-PSK."
    which is what inspired my question. Your number appears to be a typo
    error.

    The Canadian web pile also lists 3.20 as the latest version for C1
    hardware:
    http://support.dlink.ca/ProductView.asp?ProdID=356#firmware
    That's Windoze Wireless Zero Config. If you have SP2, you probably
    also have the necessary WPA support. Windoze XP SP2 does not support
    all mutations of WPA2. That's because the WPA patch was released
    before the Wi-Fi Daliance released their changes to WPA2. This sorta
    covers the problem:
    http://blogs.zdnet.com/Ou/?p=67
    Anyway, try the other encryption modes. I suspect that's the problem.
    Really? Flip your Toshiblah Centrino laptop over and kindly supply
    the model number. It's something like A45-S213 or something similar.
    That will tell me if there are any MiniPCI card, driver, or model
    specific issues.
    Actually, it was the Centrino chipset that was broken but nobody
    wanted to fix it. So, everyone had to tweak their timing to
    accomidate Intel/Philips.
     
    Jeff Liebermann, Mar 27, 2006
    #8
  9. google

    google Guest

    Hi Jeff,

    You're right - when I stated the firmware version was 5.20C I was
    incorrect. I should have stated that I upgraded the firmware to 5.20,
    but the hardware version I have of my router is C1. Sorry about that.

    Here is my Toshiba model number: PSM40C-JM300E. I remember reading a
    while back how it was only released in Canada.

    I upgraded the router firmware because I have been experiencing a lot
    of errors where I was clicking a link and the response came back
    "Cannot find server" and then I'd refresh and it would work after that.
    Someone in another post suggested I get the most recent firmware.

    Wrt the other possible encryption settings. None of them seem to work
    for me now. In addition to upgrading my firmware to support the WPA2
    security, I upgraded my Windows driver also which previously didn't
    have the WPA2 security. So the problem may either be with the firmware
    or with the Windows upgrade.

    In any case, the only way at present I can get wireless to work is to
    first plug into my ethernet port, which seems to also allow my wireless
    connection to authenticate. This doesn't make sense to me since they
    are different devices, but when I don't plug in to the ethernet port,
    the wireless card never manages to renew its IP address.

    Thanks again for your help.

    Regards,
    Steve
     
    google, Mar 27, 2006
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.