DHCP server setup on RH Linux - Not configured to listen on any interfaces!

Discussion in 'Linux Networking' started by KAL, Dec 12, 2006.

  1. KAL

    KAL Guest

    Hi all,

    I am trying to setup DHCP server on a Linux machine. After configuring
    /etc/dhcpd.conf file and restarting the dhcpd service, here is what I
    see:

    Shutting down dhcpd: [FAILED]
    Starting dhcpd: Internet Systems Consortium DHCP Server V3.0.1rc14
    Copyright 2004 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/
    Wrote 0 leases to leases file.
    No subnet declaration for eth0 (0.0.0.0).
    ** Ignoring requests on eth0. If this is not what
    you want, please write a subnet declaration
    in your dhcpd.conf file for the network segment
    to which interface eth0 is attached.
    Not configured to listen on any interfaces!


    As a matter of fact etc/sysconfig/dhcpd file contains the following
    line:
    DHCPDARGS=eth0

    I wonder why it still gives "Not configured to listen on any
    interfaces!" error.


    Here is how the /etc/dhcpd.conf file is setup:

    ddns-update-style interim;
    ignore client-updates;
    subnet 10.10.10.0 netmask 255.255.255.0
    {
    # --- default gateway
    option routers 10.10.10.1;
    option subnet-mask 255.255.255.0;
    # option nis-domain "domain.org";
    # option domain-name "domain.org";
    # option domain-name-servers 192.168.1.1;
    # option time-offset -18000; # Eastern Standard Time
    # option ntp-servers 192.168.1.1;
    # option netbios-name-servers 192.168.1.1;
    # --- Selects point-to-point node (default is hybrid).
    # --- Don't change this unless
    # --- you understand Netbios very well
    # option netbios-node-type 2;
    range dynamic-bootp 10.10.10.15 10.10.10.200;
    default-lease-time 21600;
    max-lease-time 43200;
    # we want the nameserver to appear at a fixed address
    # host ns {
    # next-server marvin.redhat.com;
    # hardware ethernet 12:34:56:78:AB:CD;
    # fixed-address 207.175.42.254;
    # }
    }


    Here is the result of "ifconfig -a" on my Linux box -

    eth0 Link encap:Ethernet HWaddr 00:15:C5:4E:C3:36
    inet6 addr: fe80::215:c5ff:fe4e:c336/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:17 errors:0 dropped:0 overruns:0 frame:0
    TX packets:476 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1646 (1.6 KiB) TX bytes:32176 (31.4 KiB)
    Interrupt:193

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:9024 errors:0 dropped:0 overruns:0 frame:0
    TX packets:9024 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:4183987 (3.9 MiB) TX bytes:4183987 (3.9 MiB)

    sit0 Link encap:IPv6-in-IPv4
    NOARP MTU:1480 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    Please help!
     
    KAL, Dec 12, 2006
    #1
    1. Advertisements

  2. KAL

    Pravind Guest

    I don't see the IP address of the eth0 interface on the ifconfig
    output. May be assigning it a static ip address (preferably on the same
    subnet on which you plan to dole out ip addresses) could help.

     
    Pravind, Dec 12, 2006
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.