D-Link Warning

Discussion in 'Broadband' started by CT, Sep 24, 2004.

  1. CT

    CT Guest

    Attention, do NOT buy the D-Link DSL-604T

    This modem/router is just no FUN!

    What's the point of something that works perfectly straight out of the box,
    and requires only a minute to set it up?!

    Home networking enthusiasts want to fiddle, and pither, and faff, and fart,
    and download lots of firmware, updates/patches/bug fixes, etc, etc

    We want to be part of a world-wide congregation - all desperately trying to
    get their modem/router working properly, we want to swap tips, share
    frustrations, console each other's tragedies, and celebrate each others
    triumphs!

    WE DO NOT simply want to plug it in and forget about it while it beavers
    quietly away doing exactly what it says on the box!

    In short, we want a Linksys WAG54G - NOT a smugly working D-Link!
     
    CT, Sep 24, 2004
    #1
    1. Advertisements

  2. CT

    Steve Guest

    Don't care about fun, I would just like it to work.,

    Their wireless access point was the biggest piece of flying shite I have
    ever been unlucky enough to use; the support site was also untested with
    browsers other then IE. They don't test their kit.
    If only.

    Indeed, they want to look at the log when a wireless piece of kit that
    worked perfectly before no longer works with their D-Link. Well tough
    shit, you are fiddling, therefore the D-Link piece of crap will lock up -
    everytime, 100% guaranteed.

    Indeed, with D-link, you are guaranteed that swapping tips etc with be
    pointless, swap tips all you like, it still will not work.

    So you box said "grey piece of shit, never works".
     
    Steve, Sep 24, 2004
    #2
    1. Advertisements

  3. CT

    Paul King Guest

    I noted the tongue in cheek sarcasm. It does as it says - works straight
    out of the box. My SOHO LAN is all D-Link equipment and is working fine! 6
    PCs - 4 wired, 2 wireless - for 15 months or so now.

    For the record :-
    DSL 300G+ modem
    DI 624 Router
    DWL-G520 PCI Wireless adapter (x2)

    Its all good.
     
    Paul King, Sep 25, 2004
    #3
  4. Well my Wag54G is fine - setup & go in early August - still going now..
     
    nigel. carron, Sep 25, 2004
    #4
  5. CT

    Andrew Cook Guest

    Sure, it works straight out of the box, though requires more like 30
    minutes to set up than 1.

    Then it stops working after 12 hours and has to be replaced. Then
    replaced again, and finally returned for refund.

    It's DHCP server leaves something to be desired too.

    Stay well away.

    //Andrew
     
    Andrew Cook, Sep 25, 2004
    #5
  6. CT

    Steve Guest

    Just try connecting non-dlink kit then you will have problems which you
    cannot diagnose because they crash when you try to view the logs - why
    bother add features when they are untested and blatantly do not work.
     
    Steve, Sep 25, 2004
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.