D-Link DSL-300G+ & Belkin Router problems

Discussion in 'Broadband' started by Des Small, Nov 16, 2003.

  1. Des Small

    Des Small Guest

    Can anyone shed any light on my problem? I have a LAN based on a Belkin 4
    port cable/DSL router gateway and connect a D-Link DSL-300G+ ADSL modem to
    the WAN port.
    Initially everything worked as expected, I could access the broadband
    connectin from any computer on the LAN.
    But now something has changed, so that I can only connect to the net if I
    plug the modem directly into an individual computer and every time I use a
    different computer I have to delete the address information and recreate it
    on the new computer.

    When I contact my work tech support to re eastablish the VPN connection,
    they tell me that the modem is acting as a DHCP server and that only the
    router should behave in this manner.

    Anyone know how to disable the DHCP function on the DSL-300G+?

    Any help would be greatly appreciated.

    Des
     
    Des Small, Nov 16, 2003
    #1
    1. Advertisements

  2. Des Small

    SNG Guest

    Des,
    I had much the same happen but with the D-Link modem and a Buffalo G54
    Airstation. You need DHCP servers on both the modem and the router.

    I assume you are using adsl, in which case the normal operation would be as
    follows:
    The modem is set to PPPoA and runs a DHCP server. The router runs a DHCP
    client on it's WAN port. On initial connection, the modem serves an address
    in the private address space 192.168.0.0/16, usually 192.168.0.2, to the
    router. Meanwhile, on the LAN side the router runs its own DHCP server
    which must be *in a different sub-net* to the modem. Your PC clients will
    then get their IP addresses and routing information from the router DHCP
    server. As far as I know you can't change the subnet that the 300G+ modem
    uses, so you must make sure that the Belkin router's DHCP isn't in set to
    that subnet. I have no idea if the Belkin router can be changed or not but
    think it is highly likely. So that's the first issue.

    Now the second issue, and this is where things try to get clever. Once the
    initial connection has been made between the modem and the router *and* the
    modem has established the adsl connection, at the next DHCP renewal the
    modem doesn't renew the private address previously given but substitutes the
    public address which it has been given, in turn, by your ISP. To ensure
    this happens promptly the initial (private IP) lease period is only 30
    seconds. The modem passes on the public address with a longer lease but
    this is only 60 seconds, which in DHCP terms is still a very short lease.

    So the second problem is that not all routers can handle these short lease
    periods It all depends on how the firmware, which manages the lease
    renewal, has been written. I don't know if the Belkin is compatible or not,
    however, the Buffalo Airstation firmware was modified to be compatible with
    the 300G+ and I was not expecting any problems. Initially my installation
    worked fine but then, after about one week stable operation, it lost the
    connection between the router and the modem. Re-starting both modem and
    router got things going again for a short time and then it would fail again.

    I traced the problem to the DHCP server in the modem which had defaulted to
    the 30 second address lease period rather than 60 seconds when serving the
    public address. The router DHCP client just couldn't keep up with the
    renewal requests, which it was trying to do every 20 seconds, in order to
    ensure that it had a continuous lease. (Hope this all makes sense!)

    I've searched for 300G set up information, but you need to use the telnet or
    local console ports to do any of the clever stuff and I'm dammed if I can
    find any information on the commands available, either syntax or meaning!
    Perhaps someone on here can help with this?

    After much messing around I inadvertently solved my problem when I tried
    re-setting both modem and router to factory defaults, by pressing their
    respective re-set tits. On doing this the modem died and has refused to
    come back to life since. So if yours is a similar problem I'm afraid I can
    help no further 'cos at that point I cut my losses and got an adslNation
    X-modem instead!

    Hope this is of some help and at least gives you some clues as to where to
    start looking.

    Good luck
    SNG
     
    SNG, Nov 16, 2003
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.