D-Link DSL-300G+ ADSL modem & a LinkSys WRT54G - do they actually work?

Discussion in 'Broadband' started by John, Aug 18, 2004.

  1. John

    John Guest

    Not sure if this is your problem but the DSL-300G+ only likes talking to the
    MAC address it was configured by.
    If the Linksys has the option to 'clone the pc's MAC address' give it a try.
    Otherwise try reconfiguring the modem through the router.
     
    John, Aug 18, 2004
    #1
    1. Advertisements

  2. John

    Peter Guest

    A friend is trying to set up the above, on a new BB connection,
    PlusNet.

    It all works fine with just the modem, no router.

    But if the router is connected, there are intermittent comms failures.
    Initially it worked for a whole day, but no more.

    A google search finds various problem postings with this combination,
    e.g.
    Can anyone suggest anything?

    Presumably, in the short term, the PC is relatively safe without a NAT
    router if running XP with the firewall enabled?


    Peter.
     
    Peter, Aug 18, 2004
    #2
    1. Advertisements

  3. John

    Peter Guest

    I don't think one can set the mac address of the router.


    Peter.
     
    Peter, Aug 18, 2004
    #3
  4. John

    John Guest

    John, Aug 18, 2004
    #4
  5. John

    Peter Guest

    The point is that if this was the real problem, loads of users would
    be unable to use the modem. Can it really be true? The only users who
    would be able to get the D-Link modem working would be those without a
    router.


    Peter.
     
    Peter, Aug 18, 2004
    #5
  6. John

    Paul King Guest

    <snip search info>

    I've got a Dlink DSL-300G+ connected to a Dlink DI-624 router and did have
    lots of disconnect probs, but I've solved it! Try this....

    Connect the DSL-300G+ directly to the PC and configure it as "bridge" and
    use PPPoE instead of PPPoA protocol (I know ADSL should be PPPoA, but some
    BT exchanges are converting to PPPoE - it might work for you, it did for me
    :) ). Once that's all working disconnect the modem from the PC and plug it
    into the router WAN port, then plug the router into the PC.

    Note, however, that in bridge mode you will now not be able to access the
    modem on its default (unchangeable) 192.168.0.1 IP address! If you need to
    change any modem settings you will need to plug the modem directly into the
    PC to "see" it.

    In this (bridge) mode mine's been rock solid for over nine months now!
    HTH
     
    Paul King, Aug 18, 2004
    #6
  7. John

    John Guest

    How do you come to that conclusion ?
    Yes, lots of people DO have problems with the modem until they are made
    aware of the MAC issue.
    If you were to change PC's or LAN cards you will find that your direct
    connection will stop working too !
     
    John, Aug 18, 2004
    #7
  8. John

    John Guest

    Here is the official word from D-Link's Aussie website.
    http://www.dlink.com.au/tech/drivers/files/modems/dsl300_FAQ2.htm
     
    John, Aug 18, 2004
    #8
  9. John

    Piers James Guest

    this is unnecessaryas if you configure the modem through the router then
    modem knows it should be connected to the router, because it stores the
    router's MAC address in the configuration settings.

    You need to plug PC into router, log on to router, change the IP address of
    the router, and other settings as necessary, then plug modem into router,
    log on to modem and set that up.
     
    Piers James, Aug 18, 2004
    #9
  10. John

    Peter Guest

    Twice as many things to go wrong :) Just getting into the router
    config can be a job. I spent hours trying to do it once.

    In fact I think there is a bug, in that if one selects a fixed IP
    (disable DHCP etc) then the router stops working completely - as if
    they have never tested it in that mode.


    Peter.
     
    Peter, Aug 18, 2004
    #10
  11. John

    Piers James Guest

    worked OK for me, and once I got the encapsulation setting correct, (the
    other one from what virgin told me) everything has been great since.
     
    Piers James, Aug 19, 2004
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.