Curious DNS problem using DNS

Discussion in 'Home Networking' started by metadaptive, Sep 3, 2007.

  1. metadaptive

    metadaptive Guest

    Hi,

    So I'm trying to use ICS to share an internet connection between two
    XP Pro laptops (connected by a crossover ethernet cable). The
    Internet connection is provided by a public wireless LAN. I know this
    is a far from ideal situation but it is the only game in town as far
    as my current situation goes. Anyway laptop #1 can happily access the
    internet and has been set-up to share it's wireless connection as per
    the instructions for ICS on the MS website. Laptop #1 uses DHCP to
    obtain it's IP and DNS information from the wireless access point.

    Laptop #2 is set to use DHCP to obtain an IP address and DNS server
    and is able to see Laptop #1 and its shared internet gateway
    connection. It is also able to do the following:

    1) Ping any site you care to name - either as an IP address or as a
    domain name

    2) (And here's the weird part) View google.com/co.uk and related
    domains - including blogger and google groups. NB this is not just a
    caching issue as I can visit dynamically generated google pages too -
    indeed I'm writing this on said impaired laptop #2 and have no problem
    posting.

    However it cannot do the following:

    1) resolve hostnames other than those mentioned above - requests time
    out after a long period of waiting.

    2) fully complete tracert commands to domains that can be successfully
    pinged - the trace completes but requests for the hop IP's time out -
    though I'm guessing this could just be incidental to the problem at
    hand

    I'm frankly pretty much at a loss to explain what's going on, except
    that it probably involves a DNS problem of some sort - could it be
    that the (public) wireless connection I'm connecting to declines to
    resolve dns requests from what it determines to be shared connections
    some how? if so how come I can still view/use google domains?

    Anyway, all help or suggestions would be very gratefully received.

    Thanks

    Tom

    sample ipconfig /all, ping and tracert output for laptop #2 follows
    below for information - do ask if I could provide anything else that
    might help determine what's going on:


    C:\>ipconfig /all

    Windows IP Configuration

    Host Name . . . . . . . . . . . . : XXXXXX17
    Primary Dns Suffix . . . . . . . :
    Node Type . . . . . . . . . . . . : Mixed
    IP Routing Enabled. . . . . . . . : No
    WINS Proxy Enabled. . . . . . . . : No
    DNS Suffix Search List. . . . . . : mshome.net

    Ethernet adapter Local Area Connection:

    Connection-specific DNS Suffix . : mshome.net
    Description . . . . . . . . . . . : Realtek RTL8139/810x
    Family Fast Eth
    ernet NIC
    Physical Address. . . . . . . . . : 00-C0-9F-6B-13-57
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    IP Address. . . . . . . . . . . . : 192.168.0.221
    Subnet Mask . . . . . . . . . . . : 255.255.252.0
    Default Gateway . . . . . . . . . : 192.168.0.1
    DHCP Server . . . . . . . . . . . : 192.168.0.1
    DNS Servers . . . . . . . . . . . : 192.168.0.1
    Lease Obtained. . . . . . . . . . : 03 September 2007 16:46:37
    Lease Expires . . . . . . . . . . : 10 September 2007 16:46:37

    Ethernet adapter Wireless Network Connection 3:

    Connection-specific DNS Suffix . :
    Description . . . . . . . . . . . : Intel(R) PRO/Wireless
    2200BG Network
    Connection
    Physical Address. . . . . . . . . : 00-0E-35-A5-F1-E6
    Dhcp Enabled. . . . . . . . . . . : Yes
    Autoconfiguration Enabled . . . . : Yes
    Autoconfiguration IP Address. . . : 169.254.130.148
    Subnet Mask . . . . . . . . . . . : 255.255.0.0
    Default Gateway . . . . . . . . . :

    C:\>ping www.bbc.co.uk

    Pinging www.bbc.net.uk [212.58.226.232] with 32 bytes of data:

    Reply from 212.58.226.232: bytes=32 time=11ms TTL=115
    Reply from 212.58.226.232: bytes=32 time=10ms TTL=115
    Reply from 212.58.226.232: bytes=32 time=12ms TTL=115
    Reply from 212.58.226.232: bytes=32 time=18ms TTL=115

    Ping statistics for 212.58.226.232:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
    Minimum = 10ms, Maximum = 18ms, Average = 12ms

    C:\>tracert www.bbc.co.uk

    Tracing route to www.bbc.net.uk [212.58.226.232]
    over a maximum of 30 hops:

    1 <1 ms <1 ms <1 ms BENS.mshome.net [192.168.0.1]
    2 * * * Request timed out.
    3 * * * Request timed out.
    4 * * * Request timed out.
    5 * * * Request timed out.
    6 * * * Request timed out.
    7 * * * Request timed out.
    8 * * * Request timed out.
    9 * * * Request timed out.
    10 * * * Request timed out.
    11 * * * Request timed out.
    12 * * * Request timed out.
    13 * * * Request timed out.
    14 935 ms 11 ms 12 ms 212.58.226.232

    Trace complete.

    sample output ends

    Incidentally, both laptops have wireless adapters, but while laptop #1
    quite happily connects to the internet, laptop #2 stubbornly refuses
    to even detect any wireless networks at all at this location (when
    laptop #1 tells me that there are several within range and the latops
    are just inches apart, and I know laptop #2's wireless adaptor is
    working from recent use elsewhere). I tried to relsove this but got
    nowhere.
     
    metadaptive, Sep 3, 2007
    #1
    1. Advertisements

  2. metadaptive

    metadaptive Guest

    sory, post title should have read "..using ICS" not "...using DNS".

    I am not a total idiot. Honest I'm not.
     
    metadaptive, Sep 3, 2007
    #2
    1. Advertisements

  3. metadaptive

    Devs Guest

    If it is running ICS it has to have fixed IP of 192.168.0.1 and be a
    DHCP server.
    take yourself outside and have a quiet word with yourself for even
    thinking about such a kludge way of doing things.
     
    Devs, Sep 3, 2007
    #3
  4. metadaptive

    metadaptive Guest

    Perhaps I should have been more clear. Laptop #1's wireless connection
    (which is internet facing) uses DHCP.
    The same laptop's wired ethernet connection has a fixed IP of
    192.168.0.1 and is a DHCP server, as you put it, as that is part of
    ICS.

    Laptop #2's wired connection is also set to use DHCP and is using
    192.168.0.1 as it's default gateway, DHCP server and DNS servers (this
    is the IP of Laptop #1's wired adapter - as automatically set when ICS
    is enabled, but I'm sure you knew that). You can tell all that if you
    read the ipconfig data I provided above.

    Furthermore at least some DNS requests are being resolved via ICS as
    Laptop #2 is able to ping domains as well as IP's. Since Laptop #2's
    DNS server is set to Laptop #1's IP, ICS is clearly working for DNS at
    least. in part DHCP via ICS is clearly working too as Laptop #2 is
    able to acquire an IP from Laptop #1.

    Still figuring all that out would have required you to actually read
    my post in the first place AND understand all the long words in it,
    maybe you should take your own advice and
    thanks for your interest all the same.

    In the unlikely event of some one else encountering the same problem,
    I'm now fairly sure the issue is on the router/ internet connection
    side of the field - the free wireless I'm connecting to requires one
    click to accept a set of terms and conditions when you first connect -
    I think this may set a cookie on the client machine that is required
    to validate http requests. Or something like that.
     
    metadaptive, Sep 4, 2007
    #4
  5. metadaptive

    Rob Morley Guest


    says...
    Hehe. :)
    Sounds possible. If that's the case I wonder if you could get the
    second machine to use the cookie cache on the ICS machine to get around
    it.
     
    Rob Morley, Sep 4, 2007
    #5
  6. metadaptive

    ric Guest

    Hmm, sounds like it's at their end. You could try using some other
    public DNS servers to make sure, but I'd imagine that if you're
    connecting to a big public network they'll be using something like
    NoCatAuth or similar so that on first connection your web session gets
    redirected to a holding page where you have to accept their terms and
    conditions before proceeding.
    Not seen this on a cookies basis, but could be done based on mac
    address of network card as well. not too familiar with how ICS
    handles this kind of thing and if it routes properly...

    what happened when you first connected the PC running ICS to the
    network? did it point you at a splash screen page? If so, can you
    manually navigate to that from the other PC?

    It could well be that they've made this difficult to explicitly stop
    people hooking up multiple PCs to it...!

    Ric
     
    ric, Sep 4, 2007
    #6
  7. metadaptive

    Rob Morley Guest

    I suppose otherwise it would be rather easy for neighbours to set up a
    wifi bridge and get free internet. :)
     
    Rob Morley, Sep 4, 2007
    #7
  8. metadaptive

    Devs Guest

    My world is at an end. I have just been insulted by a numpty who posts
    from google, replies to his own posts with "I am not a total idiot.
    Honest I'm not" and cannot find an alternative to (not being able to)
    using ICS. The shame, oh the shame.
     
    Devs, Sep 4, 2007
    #8
  9. metadaptive

    metadaptive Guest

    thanks very much for your replies and ideas rob & ric,

    @ ric yes a splash screen did appear when I first connected - but I've
    been unable to get it to display again - as it only seems to appear
    that once - sessions seem to persist overnight despite around 10 hours
    of time without a connection. Plus the page was shown in a frame and
    I (foolishly) didn't identify the true address at the time as I didn't
    know then I'd want to do all this.

    The page only required me to click a radio box rather than select it
    and click a submit button (if that makes sense) - this suggested to me
    (though I'm quite prepared to accept otherwise) that there was
    probably no POST command or similar used, which made me think
    javascript and thence perhaps a cookie. I'm also none too familiar
    with ICS and whether acts as a true router/whether client MAC
    addresses are hidden from outside connections, though I doubt it's
    particularly fully featured given it's single-click add-on status.

    @rob - am going to have a play and see if I can get the client machine
    to use the other one's cookie cash, to be honest I'm perfectly aware
    that this isn't really the sort of thing that ICS was designed for and
    that there are much better ways of doing these things given time and
    resources - but it's kept me busy for a day of so of a deeply dull
    conference.

    The only odd thing is that this all seems a little advanced for a
    network that seems to have no content or traffic filtering implemented
    at all - I've found (just for giggles) that can happily bittorrent and
    VOIP without issue on the machine thats connecting directly - it all
    seems a little haphazard for a security policy - access is free so it
    can even just be that they're interested in protecting their wi-fi
    revenues (the location is in the conference area of a large hotel -
    guess I should just be happy that I'm not having to pay silly money
    per day for my packets.

    Anyway thanks again guys - if I get anywhere I'll report back.
     
    metadaptive, Sep 4, 2007
    #9
  10. metadaptive

    Nig Guest

    As your main machine can access the world OK, I'd suggest that the
    Wireless providers are doing nothing fancy and the problem you are
    seeing is purely down to ICS. Try putting in a public DNS server on
    lappy 2, instead of it using the DNS of the ICS server given by it's
    dhcp server. ICS's ability to run a decent DNS service has always been
    a bit flakey, IME.
    Just curious about the mask here. I thought that ICS always used a /24
    subnet? Shouldn't have any bearing on your problem, just seems a bit
    unusual.
     
    Nig, Sep 5, 2007
    #10
  11. metadaptive

    mattlise Guest

    Hi all,
    I have the same problem for some weeks now, altough ICS was working
    like a charm for months. It suddenly stopped forwarding DNS requests
    from the client computers....

    I tried your suggestion (specifying the provider DNS server IP adress
    manually on the client computer) and... IT WORKS !

    My two cents : wouldn't it be due to a new security update which would
    have introduced a bug ?

    Thanks !!

    Matthieu
     
    mattlise, Sep 17, 2007
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.