Configuring Wireless MA311 PCI Card On Debian Woody

Discussion in 'Linux Networking' started by Tom Purl, Dec 31, 2003.

  1. Tom Purl

    Tom Purl Guest

    When I do an ifconfig, I get the following:

    lo ...

    wlan0 Link encap:Ethernet HWaddr 00:09:5B:91:59:61
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes:0 (0.0 b) TX bytes:16800 (16.4 KiB)
    Interrupt:5 Memory:d3ab1000-d3ab2000

    I don't have an ip address. I have an ma311 PCI card (which has the
    prism chipset) and a no-name wired pci card. I would like to use the
    wireless pci card to interface with my gateway. Eventually I would like
    to use my computer as a gateway for a small network, using the wired nic.


    # /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

    # The loopback interface
    auto lo
    iface lo inet loopback

    # The first network card - this entry was created during the Debian
    installation
    auto eth0
    iface eth0 inet dhcp
    auto wlan0
    iface wlan0 inet dhcp

    I know that my router is set up properly because I'm able to use the
    card with Knoppix. I'm still using the "out-of-the-box" configuration
    for my router, meaning no wep or anthing like that. I also tried to
    start the wlan0 interface using the following command:

    pump -i wlan0

    The result of that is "Operation failed".

    My wlan.conf is the "stock" version. Also, here's my
    /etc/modutils/linux-wlan-ng file:


    # Aliases to tell insmod/modprobe which module to use when bringing up the
    # wlan0 interface.

    # Uncomment the line corresponding to the type of prism2 device you have.
    alias wlan0 prism2_pci
    #alias wlan0 prism2_usb
    #alias wlan0 prism2_cs
    #alias wlan0 prism2_plx

    Does anyone know what I'm missing? I don't know where to go next.

    Thanks in advance for any help!

    Tom Purl
     
    Tom Purl, Dec 31, 2003
    #1
    1. Advertisements

  2. Tom Purl

    archibald Guest

    Did you try pump as root ?

    Have you tried to allocate an ip adress with ifconfig ?
    root# ifconfig wlan0 up 10.0.0.2
     
    archibald, Dec 31, 2003
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.