Coffee shop wifi will not give me IP address, but gives everyone else IP address. But static IP work

Discussion in 'Wireless Internet' started by Jennifer R, Sep 24, 2007.

  1. Jennifer R

    Jennifer R Guest

    I'm sitting here in my favorite coffee shop, noticing people working
    around me with their laptops. They're all connected to the internet. I
    have a Dell M90, with a Dell Wireless 1490 Dual B and WLAN Mini-Card
    (Microsoft's Packet Scheduler), Windows XP SP2. I set up my connection
    using all the defaults -- WPA-Personal (PSK).

    Anyway, terrific signal strength, I have the password, the network ID
    is broadcast. BUT - the router refuses to give me -- and only me -- an
    IP address. With Ethereal/Wireshark in promiscuous mode, I can see
    packets flying all over the place on my adapter. I can see my computer
    sending "DHCP Discover" packets every 3 seconds. But the router NEVER
    sends a packet in reply. Nobody else here is at all sophisticated --
    they're using the default OS wifi settings, DHCP, etc.

    However, if I set my IP address to a static address, I can use their
    network just fine. Everything's peachy.

    What the heck? This is a new coffee shop, new router equipment, my
    laptop is new -- why would they refuse me (or my NIC type, or god
    knows what category they might be using)? I tried every other
    combination of wifi settings, to no avail.

    Nothing works. Help!
     
    Jennifer R, Sep 24, 2007
    #1
    1. Advertisements

  2. Well, I'll assume that your M90 connects to other wireless access
    points correctly.

    Does the coffee shop really use WPA-PSK encryption? Very very few
    coffee shops and public hot spots use encryption. Are you sure that
    "password" you're using is for WPA-PSK, or might it be for a login
    splash screen once you're connected?

    If you wanna double check, try this DHCP test tool:
    <http://www.weirdsolutions.com/weird...Software/desktopQueryTool/querytool_free.exe>
    If you get a DCHP offer as a reply, then there's something screwy with
    your XP IP stack. I've seen DHCP failures with XP that I could not
    fix. However, it was where all DHCP would not work with any wired or
    wireless router (and required a registry cleaned to fix). This seems
    different. I've also seen VPN shims and failed spyware removals mess
    up the DHCP client. However, again it should fail with all wired and
    wireless connections, not just one, and apparently that's not the case
    here. Weird.

    Any clue what they're using for a wireless router? Deploying new
    routers, with antique firmware seems to be a common practice. Methinks
    this is the most likely culprit.

    Have you tried to reboot your M90? I've found that running Wireshark
    sometimes causes my various NIC interfaces to go nuts which requires a
    reboot to clear.

    Also, are you perhaps spoofing your MAC address on the wireless card.
    That's usually harmless, but strange MAC addresses (i.e. all zeros or
    1's) can do odd things.
     
    Jeff Liebermann, Sep 25, 2007
    #2
    1. Advertisements

  3. Typically, I go to the counter and ask them to restart the router.
    "Because it seems to be down" usually works. Who are they to argue
    whether it's working for other people, since they are not on their
    computer actively going to Myspace, or wherever it is baristas go to
    these days. What might have happened, as what happens from time to time
    with my friends, is the router seems to have a long DHCP lease time, and
    only a small number range of IP addresses it's willing to give out.
    That's typically from not knowing how to properly install a public
    access point, or at least one that will encounter more than 50 MAC
    addresses a day, or however long the lease lasts. Attempting to fix the
    issue may be more difficult, and perhaps requires more social
    engineering on your part. Perhaps they run a router that happens to be a
    DD-WRT compatible device. TFTP a better alternative for them and make
    it, well, better!

    Sorry for the block of text.
     
    dualdflipflop, Sep 26, 2007
    #3
  4. Jennifer R

    Jennifer R Guest

    Well, I'll assume that your M90 connects to other wireless access
    Oh yes -- even this coffee shop's other store in another part of town.
    It would appear so. No splash screen (presumably in a browser). I
    tried other options for encryption and the 25-letter password they
    gave me (composed of three english words) was only appropriate for WPA-
    PSK and perhaps one other encryption type. Sorry, I'm not there now so
    I can't remember what the other form was. I work a lot from coffee
    shops and typically there's NEVER any configuration other than the
    password, therefore they seem to use the most user- and barrista-
    friendly wireless configurations, seemingly just the router the phone
    company supplies (the phone company this week is called AT&T, formerly
    SBC, formerly Ameritech, formerly Ohio Bell).
    Thanks! I'll give it a try.
    Most coffee shops don't hide their router -- you can point a browser
    at the gateway address -- e.g. 192.168.1.254 -- and really go to town
    viewing all the status pages.
    I reboot probably weekly. I'll try that from the coffee shop and then
    try to connect. Good suggestion.
    I don't think so. I'm writing from a different laptop so I can't
    confirm. Everything on this laptop -- bought only in July -- is pretty
    much as-installed-by-Dell.
     
    Jennifer R, Sep 29, 2007
    #4
  5. Jennifer R

    Jennifer R Guest

    Very interesting -- if they're using the default from-the-phone-
    company installation, it might not be configured for public access. I
    never thought of that

    Sadly, there's probably nobody associated with the coffee shop who
    knows ANYTHING about wifi. You ask them about the lease time and
    they'll tell you 24 months, water and sewer extra. :)
     
    Jennifer R, Sep 29, 2007
    #5
  6. That would probably be a 2wire router. I'll guess a 2801HG. Those
    usually come with the latest firmware and seem to have few problems.
    However, I did have some problems with old Intel Proset drivers on a
    laptop and this router when in WPA2-PSK-AES mode. Worked fine with
    TKIP encryption, but wouldn't connect in AES. Then, I updated the
    Proset driver, and the laptop lived happy ever after. I never did
    figure out if it was actually the driver, or if I had fixed something
    corrupted in the installation.
     
    Jeff Liebermann, Sep 30, 2007
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.