Can't use unique local address as default IPv6 gateway - why not?

Discussion in 'Linux Networking' started by Asfand Yar Qazi, Jun 17, 2007.

  1. Hi,

    I changed my IP, and tried to move over my ipv6 address allocation to
    it on the BTExact IPv6 tunnel website... and it didn't work. Creating
    a new tunnel, however, worked fine. It's broken.

    Anyhoo...

    I don't want to go through the pain of changing ipv6 addresses in all
    my configs, so I'm trying to remove a dependancy on btexact's
    allocated address range, and am trying out unique local addresses.

    I've hit a snag however. It (the kernel, /sbin/ip or whatever) won't
    let me use a unique local address as the default IPv6 gateway. It's
    strange that I can use the link-local one just fine (as well as
    obviously the one from global btexact's allocated subnet).

    Anyone know why?

    Thanks
     
    Asfand Yar Qazi, Jun 17, 2007
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.