Can't see other computer on network from win 98 computer

Discussion in 'Windows Networking' started by John, Dec 18, 2003.

  1. John

    John Guest

    have had trouble with a win 98 machine not being seen on
    the network. Simple network with four computers 2 xp, 1
    2000 and the 98 machine that can not be seen. It has
    worked till recently. All computers share the internet
    and the 98 machine shares the printer through the xp
    machine.
     
    John, Dec 18, 2003
    #1
    1. Advertisements

  2. Carey Holzman, Dec 18, 2003
    #2
    1. Advertisements

  3. Make sure that FIle and Printer Sharing is enabled on 98. If the 98
    machine doesn't appear in My Network Places on XP and 2000, try
    accessing it by typing its name in the Start | Run box in this form:

    \\computer

    If those suggestions don't help, try these:

    1. Permanently disable XP's built-in Internet Connection Firewall on
    local area network connections -- it's for use only on a direct modem
    connection to the Internet. Disable and un-install all other
    firewalls while troubleshooting. Details here:

    Windows XP Internet Connection Firewall
    http://www.practicallynetworked.com/sharing/xp/ic_firewall.htm

    2. Use only one protocol for File and Printer Sharing. If the network
    needs more than one protocol, unbind File and Printer Sharing from all
    but one of them. Details here:

    Windows XP Network Protocols
    http://www.practicallynetworked.com/sharing/xp/network_protocols.htm

    3. If the network uses TCP/IP, make sure that NetBIOS over TCP/IP is
    enabled on all computers. Details here:

    Enable NetBIOS Over TCP/IP (NetBT)
    http://www.practicallynetworked.com/sharing/troubleshoot/netbt.htm

    4. Run "ipconfig /all" on XP and look at the "Node Type" at the
    beginning of the output. If it says "Peer-to-Peer" (which should
    actually be "Point-to-Point") that's the problem. It means that the
    computer only uses a WINS server, which isn't available on a
    peer-to-peer network for NetBIOS name resolution.

    If that's the case, run the registry editor, open this key:

    HLM\System\CurrentControlSet\Services\Netbt\Parameters

    and delete these values if they're present:

    NodeType
    DhcpNodeType

    Reboot, then try network access again.

    If that doesn't fix it, open that registry key again, create a DWORD
    value called "NodeType", and set it to 1 for "Broadcast" or 4 for
    "Mixed".

    For details, see these Microsoft Knowledge Base articles:

    Default Node Type for Microsoft Clients
    http://support.microsoft.com/default.aspx?scid=kb;en-us;160177

    TCP/IP and NBT Configuration Parameters for Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;314053
     
    Steve Winograd [MVP], Dec 19, 2003
    #3
  4. Tarapia Tapioco, Dec 19, 2003
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.