Cannot connect desktop PC to router but laptop can connect

Discussion in 'Broadband' started by 405 TD Estate, May 11, 2007.

  1. My desktop PC refuses to connect to the router when I type in the
    routers set-up address eg http://gateway.2wire.net into MS explorer.

    I have tried all 3 types of available connection and none of them
    allow me to connect to the set-up page i.e USB network cable and
    wireless. When connected they all show (in the control panel - network
    settings) that they are connected and working correctly. I can
    'repair' each connection OK but this doesn't fix the problem. The
    connections appear in the LAN and high speed internet section - same
    as my laptop.

    I can use internet explorer to connect via a dial up modem OK but it
    doesn't seem to recognise the LAN connections - just says I am working
    offline and do I want to try a dial up connection.

    It seems as if the LAN connection is just not recognised by IE?

    Also via my laptop I can access shared files on my desktop PC (done
    via wireless) so the connection and wireless USB pen obviously work.

    Thanks for your help this is driving me nuts!

    Also tried it in safe mode - no luck.

    Perhaps uninstall norton security (it's already turned off as is the
    windows firewall) ?
     
    405 TD Estate, May 11, 2007
    #1
    1. Advertisements

  2. 405 TD Estate

    Graham Guest

    First - open a command window. On XP this is Start | Run - type CMD - then
    click OK

    Then type IPCONFIG /ALL

    You should see a long report including the IP address of your computer, and
    the IP address of the Default Gateway - this is the address of the router.
    Note this address carefully.

    Now type PING <address of router>

    Do you get replies? If so, you have a good connection to the router.

    Now open Internet Explorer. Wait for it to fail to show whatever its home
    web page is. Now on the menu bar, click on Tools | Internet Options - and
    find the Connections tab. Select the option "never dial a connection".
    This will ensure that it doesn't try to connect using the modem. OK out of
    this and look under the File menu. Do you see "Work Offline" is ticked?
    Untick it.

    Now type in the IP address of the router - the address you proved worked
    with the PING command.

    Tell us whether this shows the configuration page for the router.
     
    Graham, May 11, 2007
    #2
    1. Advertisements

  3. 405 TD Estate

    Gaz Guest

    And, makes sure dhcp client services is enabled, and that you havent put any
    manual settings in the ip configuration options. These are the most common
    reasons for such a situation...

    Gaz
     
    Gaz, May 11, 2007
    #3
  4. Got it working (at least can talk to the router) thanks to Graham's
    reply - looks like it was as simple as IE being set to offline mode!!
    I didn't know it did that (stupid thing!)

    All the pings etc worked but could not access the router by typing in
    the IP address - not that it matters as i could type the web type
    address in which works (or is that what Graham meant)

    Anyway thanks - now I'm just in the (bad) position of waiting for Talk
    Talk to connect the internet - 1.5 months waiting already (not good)
    they say this wednesday but after all the bad feedback of them on the
    web (should have read it first) they do not look like a good
    provider : (
     
    405 TD Estate, May 14, 2007
    #4
  5. 405 TD Estate

    Graham Guest

    [snip]

    The reason for me suggesting the IP address is as follows: - it should
    ALWAYS work. If you use the name - yours was http://gateway.2wire.net - you
    rely on some mechanism to map the name to an IP address. There are any
    number of ways this can be achieved, but if none of them are set up and
    working properly then you won't get anywhere.

    One mapping mechanism is probably provided by the program that the
    manufacturer's CD installs - but this brings in all sorts of other rubbish
    that is probably best avoided. A good rule of thumb when using a router is
    NEVER to install any software that was supplied with the router - the tools
    within windows (or a Mac) are sufficient to connect to the router and manage
    it.

    If IPCONFIG /ALL shows you that the IP address of the default gateway is
    192.168.0.1 then you should type into the browser:

    http://192.168.0.1/

    You can probably miss out the http: but the // before the IP address is
    sometimes necessary. If you find this doesn't work then I'm very suspicious
    of your browser - or your typing !

    -- Graham J
     
    Graham, May 14, 2007
    #5
  6. 405 TD Estate

    Nigel Guest

    For a 2wire router the IP address is usually http://192.168.1.254/
    http:\\home also works and is easier to remember.

    NigelĀ®
     
    Nigel, May 14, 2007
    #6
  7. 405 TD Estate

    Graham Guest

    My point being that you should not rely on memory or guesswork: the IPCONFIG
    /ALL command will tell you the value that you need to know.
     
    Graham, May 14, 2007
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.