Can connect to smb://192.168.0.112/share but not smb://NYS/share

Discussion in 'Linux Networking' started by Rich, May 11, 2004.

  1. Rich

    Rich Guest

    In Konqueror I get an error if I try to browse the windows network.
    The error is that the network is unreachable.

    However while at the smb:// prompt I can type
    smb://192.168.0.112/ShareName and pull up a windows share on this
    machine fine. However if I try and enter smb://NYW/Sharename to
    connect to the same share it just hangs (NYW is the computer at
    192.168.0.112)

    I am not sure if this is an issue with my samba config file(the server
    side of samba works fine, I can access the linux shares from windows
    fine) or if this is an error with my network configuration.

    I think this might be a netbios issue. If I ping "NYW" I get "unknown
    host NYW." However if I ping "NYW.JJ.COM" I get a response. I am
    thinking that I need to resolve that first. Is that correct? If so
    how do I fix this so that it either appends my domain name to all DNS
    lookups or uses netbios to find the machine.

    I included a copy of the top of my smb.conf just in case the problem
    lies there.

    Rich
    --------------
    # smb.conf is the main Samba configuration file. You find a full
    commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SuSE
    # Date: 2004-04-06
    [global]
    workgroup = JJ
    interfaces = 127.0.0.1 eth0
    bind interfaces only = yes
    printer admin = @ntadmin, root, administrator
    map to guest = Bad User
    security = server
    password server = NYS
    server string = Samba Serv
    domain master = no
    local master = no
    restrict anonymous = no
    preferred master = no
    max protocol = NT
    ldap ssl = No
    server signing = Auto


    [homes]
    comment = Home Directories
    valid users = %S
    read only = no
    msdfs proxy = no
    browseable = no

    [users]
    comment = All users
    read only = no
    inherit permissions = yes
    veto files = /aquota.user/groups/shares/
    msdfs proxy = no

    [groups]
    comment = All groups
    path = /home/groups
    read only = no
    inherit permissions = yes
    msdfs proxy = no

    [pdf]
    comment = PDF creator
    path = /var/tmp
    printable = yes
    print command = /usr/bin/smbprngenpdf -J '%J' -c %c -s %s -u '%u' -z
    %z
    create mask = 0600

    [printers]
    comment = All Printers
    path = /var/tmp
    printable = yes
    create mask = 0600
    browseable = no

    [print$]
    comment = Printer Drivers
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775
     
    Rich, May 11, 2004
    #1
    1. Advertisements

  2. Rich

    Alex Harsch Guest

    Hi,

    are you using SuSE9.1? If so, there is a bug in the Yast module which
    configures the smbclient. In this case, open yast>network>sambaclient and
    enter a WRONG workgroup name. This will make you able to browse the Windows
    shares in konqueror.
    Else:
    try smbclient -L 192.168.0.112
    and see what your box thinks, the Netbios name of NYS is.

    Regards, Alex
     
    Alex Harsch, May 12, 2004
    #2
    1. Advertisements

  3. Rich

    Jan Geertsma Guest

    The netbios names mapped to ip, can be set in the file /etc/lmhosts
    otherwise NYW needs to be resolved by a broadcast over the network, and
    this is a bit tricky and depends on you other systems too.
    setting the domain to jj.com should help to ping NYW
    oww and Alex's "smbclient -L localhost" should show you the workgroup
    and who is the master on your network.

    goodluck jan
     
    Jan Geertsma, May 13, 2004
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.