Belkin Wireless G USB Adapter doesn't go faster than 11Mbps

Discussion in 'Wireless Internet' started by Jonathan Eales, Nov 25, 2004.

  1. I just bought a Belkin Wireless G USB adapter F5D7050UK and loaded it on two
    computers (desktop and laptop) and I can't get either to go faster than
    11Mbps.

    The adapter is now sitting on top of the Linksys WRT54G router, so range
    isn't an issue. Other computers in other rooms connect happily at 54Mbps.

    I use Windows XP SP2 and WEP 64-bit security. It connects immediately.
    I've also tried downloading and installing the latest drivers from the
    Belkin web site.

    Any ideas? Anyone else with one of these gizmos that has it running at its
    rated speed?

    Jonathan
     
    Jonathan Eales, Nov 25, 2004
    #1
    1. Advertisements

  2. Jonathan Eales

    Alan White Guest

    What are you trying to measure? File transfers between computers or
    download speed from the Internet?

    If the latter, you are at maximum speed. 54 refers to file transfers only.
     
    Alan White, Nov 25, 2004
    #2
    1. Advertisements

  3. Jonathan Eales

    Jim Guest

    Make sure you have B/G option checked and if you have super G mode check
    that and lastly use G static mode and not dynamic mode
     
    Jim, Nov 25, 2004
    #3
  4. Thanks Guys, for your suggestions but the problem is fixed. If you use the
    supplied stand the speed is capped at 11Mbps, yet if you push the adapter
    directly into the USB socket the reported speed immediately jumps to 54Mbps.
    Go figure! Tried this on both computers and it works.

    Jonathan
     
    Jonathan Eales, Nov 26, 2004
    #4
  5. Can I guess? The stands were USB 1.1 only. The computah thinks it's
    talking to a USB 1.1 device and limits the speed. Max on USB 1.1 is
    12Mbits/sec, which is far too close to 11Mbits/sec for comfort. Dump
    the stand and plug in directly to a USB 2.0 port, and you get full
    speed. Most of the other USB 802.11g data sheets include warnings of
    diminished thruput when used with USB 1.1.
     
    Jeff Liebermann, Nov 26, 2004
    #5
  6. Jonathan Eales

    Beretta Guest

    <snip>

    Sounds to me like the "stand" may be using a USB 1.1 rated cable.

    Try it with a USB 2 rated cable
     
    Beretta, Nov 26, 2004
    #6
  7. The only real differnces between USB 1.1 and 2.0 cables are
    shielding and tolerances.

    The problem is that many of the cheapo 1.1 cables are not even close
    to meeting the USB 1.1 standard, much less meeting 2.0. The usual
    problem is with the tiny, highly flexible, cables found on digital
    cameras, media readers, and other single device cables. They don't
    suck much power, so the cable manufactory skimps on conductor size.
    Since the brilliant designers of USB elected to supply 5.0VDC, demand
    that the load work on no less than 5.0VDC, and totally ignore the
    voltage drop, a smaller guage power cable becomes critical. This may
    be what's happening here. The base unit, and the radio both require
    power from the computah. Wireless devices are NOT low power devices.
    If the cable drop is excessive, one or these two devices may "fail" in
    some way. Try a short "fat" cable and see if it helps.

    This may be of interest:
    http://www.everythingusb.com/forums/showthread.php?threadid=809
    I don't exactly agree with everything, but it gives the general idea.
     
    Jeff Liebermann, Nov 26, 2004
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.