Autofs/Automount on RedHat Linux Kernal 2.4.20-8 (Release 9) on i686

Discussion in 'Linux Networking' started by Murali Kanaga, Oct 17, 2003.

  1. Gurus,

    I am trying to mount an NFS exported dir from Solaris 8 onto
    this Linux client using autofs/automount:

    From the Linux client:

    root@Linux# showmount -e ns1
    Export list for ns1:
    /homes (everyone)

    root@Linux# cat /etc/auto.net
    # $Id: auto.misc,v 1.2 1997/10/06 21:52:04 hpa Exp $
    # This is an automounter map and it has the following format
    # key [ -mount-options-separated-by-comma ] location
    # Details may be found in the autofs(5) manpage

    # the following entries are samples to pique your imagination
    ns1 -fstype=nfs ns1:/homes

    root@Linux# cat /etc/auto.master
    # $Id: auto.master,v 1.2 1997/10/06 21:52:03 hpa Exp $
    # Sample auto.master file
    # Format of this file:
    # mountpoint map options
    # For details of the format look at autofs(8).
    /net /etc/auto.net --timeout=10

    [root@Linux# /etc/init.d/autofs status
    Configured Mount Points:
    ------------------------
    /usr/sbin/automount --timeout 10 /net file /etc/auto.net

    Active Mount Points:
    --------------------
    /usr/sbin/automount --timeout 10 /net file /etc/auto.net

    The whole dir is mounted under /net/ns1. I want this under /net/ns1/homes

    What I am doing wrong here? What needs to be changed in order to achieve
    this?

    Thanks,
    -Murali
     
    Murali Kanaga, Oct 17, 2003
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.