apache and misticaly closed port

Discussion in 'Linux Networking' started by gosha, Jul 16, 2003.

  1. gosha

    gosha Guest

    Hi all,
    I have server with Linux(Mandrake 9.1) with apache2 on it.
    I succesfully have run it.
    netstat -l shows that server is listening to port http(80),
    but i can't access the server from external compter in the LAN.
    If I run apache on another port - the same thing happens.
    But if i run httrd on port of ftp or ssh , it's possible to access the
    server by
    server:21 or server:22.
    I guess , that somewhere in configuration files the port of http and
    other port are closed .
    Please help..

    Thx
     
    gosha, Jul 16, 2003
    #1
    1. Advertisements

  2. gosha

    Xyerp Guest

    So 'lynx localhost' works then? Cool. Sounds like a firewall problem...?
     
    Xyerp, Jul 16, 2003
    #2
    1. Advertisements

  3. gosha

    gosha Guest

    Thnks Xyerp
    Yes, It was the linix firewall problem .
    I've stoped the service iptables and it has started to work.
    Gosha
     
    gosha, Jul 17, 2003
    #3
  4. gosha

    Xyerp Guest

    Cool. Even if it is a bit extreme to totally stop the firewall -
    unless you already have another one running. ;)

    If you want to start running the firewall again, I've found Webmin to
    be really useful for editing the rules.
     
    Xyerp, Jul 17, 2003
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.