Airport Extreme, problems with non-Apple devices/ help!

Discussion in 'Network Routers' started by Tom, Oct 11, 2015.

  1. Tom

    Tom Guest

    I'm trying to configurate a brand new Airport Extreme connected to an
    Internet Radio Modem (an antenna/modem unit
    https://plus.google.com/+Epmpwireless/photos)
    installed in Spain by Redytel.

    The Airport Extreme works fine with my Macbook-Pro, iPhone, and iPad,
    but there are problems when triying to connect my Samsung TV and Sony
    Receiver,
    they "see" my network, but there is no connection for this non-Apple
    devices to the Internet.

    The Airport Router is configured as " Bridge", and when I try with DHCP
    or other there is a "double DNS" error showing at the Airport Extreme
    interface.

    My Internet Radio Moderm is just a single Modem, and all the info I can
    find refers to Modem/routers connections.

    Does anyone here know how to solve this?

    Thanks in advance!
    Tom
     
    Tom, Oct 11, 2015
    #1
    1. Advertisements

  2. Tom

    Char Jackson Guest

    I would configure the Airport as a gateway router, not as a bridge. The
    Airport will need to be configured to acquire an IP address from your ISP,
    using whatever protocol they require, but everything on the LAN side of the
    Airport will get an IP from the Airport rather than from the ISP.
     
    Char Jackson, Oct 11, 2015
    #2
    1. Advertisements

  3. Tom

    Tom Guest


    Thanks for your help, Char!!

    After checking my “old†router settings I believe that the “Double NATâ€
    error is an Airport Extreme “mistakeâ€, as the TP-LINK Router setting
    was set as DHTP server.

    I set the AE to “DHCP and NAT “and all the devices at my network are
    working fine. The AE shows the “Double NAT†warning, but there is an
    option to “ignore it†through the Airport Utility.

    There are several discussions about this “Double NAT†error all around
    the Web, some
    ignore the error (as I do for now), and some say there could be problems.

    I now believe that probably the AE detects my single Modem as a Router,
    and so it indicates that there is an error and it must be set to
    “Bridge Modeâ€. But as the original
    configuration my ISP performed set its Router in DHCP mode, I believe
    the Modem Is just a single Modem so “DHCP and NAT†setting on the AE
    should be de correct one.

    I’ll try to get some info from my ISP tomorrow and wait for a while
    before returning
    the AE as it works really well and fast.

    NOTE: I am still confused as when the AE is in “bridge†mode, the
    “Double NAT†error does not show, and all the devices at my network
    work fine.
    But my wife’s MacBook-Air refuses to connect via Wi-Fi showing a “Self
    Assigned IP Problemâ€, and after trying everything without success, it
    works fine setting the AE
    To “DHCP and NATâ€, (probably the other devices did work because its IPs
    were somehow memorized?).

    What do you think?

    Thanks again.
    Tom
     
    Tom, Oct 12, 2015
    #3
  4. Tom

    Char Jackson Guest

    I don't consider double NAT to be an error or a problem. If you don't
    require the capability to initiate LAN-bound connections from the Internet,
    then you'd never know there was double NAT going on. It would be entirely
    transparent or invisible or whatever you want to call it. On the other hand,
    if you do require the capability to initiate inbound connections from the
    Internet, then just be aware that NAT is being performed on two devices,
    meaning both devices would need to be configured properly for port
    forwarding. For most people, it's not an issue.

    Having said that, if you can figure out how to run the modem in bridge mode,
    then I'd recommend doing that. The network path will be less complicated,
    although probably not to the point where you'd notice any performance
    improvement, and you'll get rid of the double NAT.
    Almost certainly.
    That's a good suggestion, but I'd say 'should' instead of 'must'. See above
    regarding my opinion of this as an error.
    I'm not familiar with your modem so I can't help much there. Perhaps you can
    find the model number and then a search may find a setup guide or manual.
    It sounds like the AE is working fine at the moment. All I see is just a
    minor configuration tweak to be done on the modem, but even that is
    optional.
    It sounds like DHCP address pool exhaustion. I'm guessing that your ISP
    allows you to use a certain number of their IP addresses, so it's first come
    first served until all of those are spoken for. Any device of yours that
    comes along after that is going to be out of luck.

    By adding the AE to the LAN side of the modem and setting the modem to
    bridge mode, you'll only use one IP address from your ISP. That IP address
    will be assigned to the WAN side of your AE. Each of your devices will then
    get IP addresses (from a new address range, hopefully!) via the DHCP server
    in your AE.
     
    Char Jackson, Oct 13, 2015
    #4
  5. Tom

    Tom Guest

    Thanks a lot for your help, Char!!!

    I belive you are right and "pool exhaustion" is the problem, so I'll
    try to convince my ISP
    to change the ePMP-10000 Modem to "bridge" mode, but I'm afraid this is
    not going to
    be fast or easy (this is Spain :)

    Regards,
    Tom.
     
    Tom, Oct 15, 2015
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.