ADSL connection problems with D-Link DSL-300T

Discussion in 'Broadband' started by Gundemarie Scholz, Jul 26, 2006.

  1. Hello again!

    Two days ago my ADSL was connected, provided by Eclipse. I got a USB
    modem from them which works fine, but as I prefer having a router with
    NAT and firewall between me and the rest of the internet I bought a
    secondhand DSL-300T modem to complement my DI-604 router.

    First issue was that I couldn't connect via browser to the modem, that
    was easily fixed by resetting it to factory defaults. But then I could
    not get any working internet connection. As I didn't buy the modem as
    new I am trying to figure out whether the line has a problem or rather
    the modem.

    Please note that the following description is what I remember as I don't
    have the modem here currently (given it away to get it tested on a
    different ADSL line).

    The status light of the modem blinks slowly, but regularly; the ADSL
    light is off, and then usually switches between blinking and steady. The
    log shows different states between these three:
    DSL carrier is up (light off)
    DSL carrier is down (light steady)
    DSL carrier is training (light blinking)

    If need be I can provide you with detailed logs.

    Sometimes the modem gets assigned an IP, a gateway and DNS servers by
    Eclipse, but exactly after ten seconds the connection goes down again.


    What I have done so far:
    - Even though the modem had the latest firmware I updated it, to
    make sure the former owner hadn't screwed something up. After I had
    done that the built-in web server providing the user interface
    rebooted every few minutes, so I updated the firmware a second time.
    - I reset the modem to factory defaults.
    - I called Eclipse and went through the modem settings with them.
    Modulation: MMODE
    Encapsulation: VC
    VPI: 0
    VCI: 38
    QoS: UBR
    MTU: 1458 (and 1430 for testing)
    MRU: 1492 (default value)
    Set route: checked (default value)
    On demand: unchecked (default value)
    - I tried out the 'Modem test', it gives four options:
    F4 end to end
    F4 seg to seg
    F5 end to end
    F5 seg to seg
    All options fail currently. After my first firmware update one of the
    F5 tests passed, I can't remember which one though.
    - I tried two different RJ-11 cables: the one that came with the D-Link
    modem and the one that came with the Speedtouch USB modem. I didn't
    notice any difference.
    - I called D-Link, unfortunately the guy answering the call was not
    really able to tell me what the "training" or the modem tests mean
    and do. He claims it is a line fault. He also claims the MTU should
    be set to 1500 regardless of what the provider says.


    And now my questions:

    I can ping the LAN IP, but not the WAN IP when it has been assigned. Is
    there anybody here who knows whether this is normal behaviour for this
    model?

    Currently I am using the phone socket I have in my bedroom, and as I
    said, the USB modem works fine, so I guess the wiring is ok. Is it
    possible the D-Link modem is more sensitive to some kind of problems
    than the USB modems thus making it necessary to use the master socket?

    How do I find out which of the eight sockets around the house is
    actually the master socket?

    Do you think the errors point rather towards a line problem than towards
    a modem problem?


    Thanks for your patience reading through all this!
    Gunde
     
    Gundemarie Scholz, Jul 26, 2006
    #1
    1. Advertisements

  2. Gundemarie Scholz

    Simon Dean Guest

    I got one of these. Unfortunately with my injury, Im not about to wonder
    upstairs anytime soon to check out my modem lights. I know for certain
    though that one of the lights does flash, even when everything's fine. I
    think it's the ADSL light.

    You should be able to access the web server of the modem by the local IP
    address.

    I believe it also comes setup in a Half Bridge mode, so, it should
    actually be transferring the external IP address (that provided by
    Eclipse), to your network card.

    My Settings include:

    PPPoA
    Encapsulation VC
    MTU 1400 (Hrm)
    MRU 1492
    VPI 0
    VCI 38
    QoS UBR


    My modem is connected by ethernet to the spare ethernet connection on
    my router.

    I have two ethernet ports on my router, one for the local network, and
    one for the ethernet modem. You can't just plug into your hub.

    Hope that gives you something to chew on.

    Good luck.

    Simon
     
    Simon Dean, Jul 26, 2006
    #2
    1. Advertisements

  3. Gundemarie Scholz

    Simon Dean Guest

    Simon Dean, Jul 26, 2006
    #3
  4. Status light flashes
    yep my public address was sent by DHCP (not that I use DHCP anymore).
    I also assigned an address from 192.168.x.x to my connected machine as a
    secondary[your os may vary].

    Adam
     
    Mr. Adam ALLEN, Jul 26, 2006
    #4
  5. Gundemarie Scholz

    Simon Dean Guest

    Which reminds me, I hear a story that the subnet for the router has to
    be different to the subnet of the modem...

    so modem could be 192.168.0.1 / 255.255.255.0 while the rest of the
    network including router could be 192.168.1.1 / 255.255.255.0

    Cya
    Simon
     
    Simon Dean, Jul 26, 2006
    #5
  6. Which is what I did. The DSL-300T is by default also a DHCP server and
    hands out IP addresses in the 192.168.1.0/24 network. If I connect a PC
    to the router the PC usually gets an IP address automatically assigned.

    Hmm, not in the default setting. Anyway I prefer a NATted network.
    That might depend on the provider.
    Actually you could, as the modem also is a router (whereas the DI-604
    that I want to use behind it is a router with an integrated switch).
    Yes, it is interesting, but unfortunately it doesn't help me a lot in
    regard to the question whether the line quality is suboptimal thus
    giving the modem a hiccough, or whether the modem is broken.

    Regards,
    Gunde
     
    Gundemarie Scholz, Jul 27, 2006
    #6
  7. There is an instruction on the D-Link website specifically mentioning
    the construction of using a router behind the DSL-300T. Basically it
    says you have to set that router to accept a dynamic IP that it gets
    handed by the DHCP server in the modem. The DSL-300T by default has the
    IP 192.168.1.1/24, the DI-604 by default has the IP 192.168.0.1/24.

    Regards,
    Gunde
     
    Gundemarie Scholz, Jul 27, 2006
    #7
  8. I stand corrected, just found the relevant information on the D-Link
    site, it emphasizes you cannot just connect a hub or switch to the
    DSL-300T.
     
    Gundemarie Scholz, Jul 27, 2006
    #8
  9. Gundemarie Scholz, Jul 27, 2006
    #9
  10. Gundemarie Scholz

    Simon Dean Guest

    What should happen, is that the DI-604 will assign local IP addresses to
    your network. Your network will see the DI-604 as the router/gateway and
    the DI-604 will provide the NAT.

    Which is what you get with the DI-604.

    Think of the DSL-300T as nothing more than a glorified modem, but the
    benefit you have, is that the DSL-300T does the authentication. You
    can't use the DSL-300T as a router because you can't do any port
    forwarding etc on it and in its default mode, will only pass the one ip
    address to your DI-604 - the external ip address.

    I myself use a "Smoothwall" box, so I have two ethernet network cards,
    one connecting to my local network providing the natting functionality,
    and the other one connected to my DSL-300T which is given my external ip
    address by dhcp

    So if we assume your modem is setup correctly, what information is
    giving in the logs?

    Does it forever say DSL Carrier is Training, or DSL Carrier is down?

    Might suspect in that case that your modem just cannot connect.

    If so, I had a couple of ADSL2MUE modems that just would not connect.
    But my current DSL-300T is fantastic.

    It's also much better to have a modem like this than a USB modem because
    you do get more throughput.

    What does your modem logs say? Does it indiciate that it's at least
    trying to authenticate? Have you at least entered your ISP login
    information into the modem?

    Thanks
    Simon
     
    Simon Dean, Jul 27, 2006
    #10
  11. Either that, or it does NAT, meaning I have one NAT network between
    modem and router, and another one between router and my LAN.
    For the troubleshooting I don't use the router, simply because I want to
    eliminate any additional causes of confusion and error.
    Ok, will paste the log tonight when I get home.
    It connects inbetween.
    Tested with different online tools last night. Line speed according to
    the little Windows taskbar icon was always between 2.3 Mbit/s and 3.9
    Mbit/s, but in reality my average download speed was around 350 kbit/s
    and 580 kbit/s. )-: It is probably unrelated to the USB modem, but
    disappointing nevertheless.
    Yes, and to quote myself: "Sometimes the modem gets assigned an IP, a
    gateway and DNS servers by Eclipse, but exactly after ten seconds the
    connection goes down again." I tested also with no username and password
    entered, and that gave me appropriate log entry.

    Thanks for asking though, it wouldn't have been the first time something
    as obvious as that gets missed out, and makes you slap your forehead
    once you discover the mistake.

    Regards,
    Gunde
     
    Gundemarie Scholz, Jul 27, 2006
    #11
  12. Thanks for all the replies a couple of weeks ago, by now everything is
    fine. It seems several factors caused my problems:
    - Faulty USB modem, Eclipse sent a replacement one that works.
    - Faulty in-house wiring causing the modems either not to connect
    at all or at least get a very bad connection, now plugged into
    a different socket.
    - Possibly faulty D-Link modem, at least it causes permanent
    noise in the phones as soon as it synchronises. Tested in
    different sockets with different filters and different phones
    attached. But at least in the master socket it gets a good
    signal and has no trouble connecting.

    So for now I am using the USB modem with a PC with internet connection
    sharing as router, behind it my trusty D-Link router with integrated
    switch acting as DHCP server and firewall.

    According to the Eclipse website and its connection manager my current
    line rate is 1,728 kbit/s, oddly enough the little RAS connection icon
    in the task bar claims it is between 2.4 and 2.9 Mbit/s. But the Eclipse
    tech support person said the rate gets adjusted automatically if the
    line gets better (eg by me using a shorter cable between modem and
    master socket).

    I am not as happy as I would have liked to be as after all it is
    ADSLMax, I would rather have settled just for a permanent rate of 1
    Mbit/s than permanently changing rates, especially as having an error
    and trying to eliminate the problem takes ages. Even with working
    equipment my line rate stayed around analogue modem speed downstram for
    another four days, until the BT equipment decided to updated the line
    speed. *sigh*

    Regards,
    Gunde
     
    Gundemarie Scholz, Aug 10, 2006
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.