A problematic switch from ACPI to APM

Discussion in 'Linux Networking' started by Madhusudan Singh, Aug 30, 2004.

  1. Hi

    I run Debian Sarge on my laptop which has APM (1.2) and ACPI (2.0).
    Almost everything on my laptop works (haven't tested the modem, but well) -
    see http://www.geocities.com/msdebian/dslaptop.html.

    However, suspend/resume and hibernate do not work. And since my
    laptop had APM capability, I decided to compile a kernel with at least
    suspend/resume working. My kernel configuration is at

    My network configuration, described in the first link, has eth0 -
    wired ethernet (e100 driver) and eth1 - wireless network (orinoco_cs
    driver). However, when the kernel booted (passed apm=on acpi=off options),
    DHCP (as usual) was attempted before PCMCIA was started (which is eth1).
    eth1 appeared as Null, while hotplug tried to find an eth2 !

    Other symptoms :

    1. My battery (which was fully charged and the laptop was running on
    battery) was showing 0% charge and charging (from the icon) in KDE.
    2. The PCMCIA wireless card had a steady light on (which is the case
    when it has detected a network and an essid) but showed no info on the
    essid in iwconfig (which returned an error that eth1 did not exist or some



    PS :
    A /var/log/messages extract from an untidy boot is at :

    Madhusudan Singh, Aug 30, 2004
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.